Junos OS

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Passing LDP labels between Routing-instance and Inet.3

    Posted 08-12-2020 10:26

    Hi 

    1- I have a vMX router(JMX1). on this router I have a routing-instance type virtual-router(Routing-instance MPLS) which has one interface inside of it.

    2- There is another router which is connected to this interface.(JMX2)

    3- Also there is another Interface which is not in this routing-instance(JMX3)

    4- There is an OSPF adjacency between JMX1 and JMX3 inside inet.0 and JMX1 and JMX2 inside Routing instance MPLS.

    5- Those JMX2 and JMX3 have already OSPF and MPLS and LDP neighbors with other connected routers for their own.

    6- Now inside of JMX1 I tried to redistribute OSPF routes from inet.0 into MPLS.inet.0 and vice versa.

    7- The configuration was OK and JMX2 and JMX3 have their route in their inet.0. I used export and rib-groups(Nothing fancy)

    8- Now I tried to do the same with LDP (Inet.3 and MPLS.inet.3)

    9- I could successfully do the same inside of JMX1. but this router did not advertise LDP routes to JMX2 and JMX3

    10. I enabled Egress policy on JMX1 and the propagation was done but this time inet.3 and MPLS.inet.3 of JMX1 were vanished.

    11- Is there any configuration guide or command for doing this? I want to have two separate OSPF domain but I want to maintain the LSP unbroken.

    I did my tests on Juniper vLABs which uses JunOS 19

    Thank you for your help and support.

     

     


    #routing-instnce
    #JUNOS
    #ldp


  • 2.  RE: Passing LDP labels between Routing-instance and Inet.3

    Posted 08-13-2020 01:09
      |   view attached

    I attached the configuration here

    Attachment(s)

    txt
    VM2.txt   14 KB 1 version


  • 3.  RE: Passing LDP labels between Routing-instance and Inet.3

    Posted 08-13-2020 02:38

    Hello,

     


    @Asoltanian wrote:

    I want to have two separate OSPF domain but I want to maintain the LSP unbroken.

     


     

    For this to happen, You need to use "instance-type no-forwarding" .

    I labbed up a simple topology for You:

     

    R5[ge-0/0/9.0]-------------[ge-0/0/9.0]R3[ge-1/0/3.0]---------[ge-0/0/3.0]R6
    lo0.0 198.51.100.5              lo0.0 198.51.100.3                     lo0.0 198.51.100.6

     

    R5 config:

     

    set protocols ldp track-igp-metric
    set protocols ldp interface ge-0/0/9.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/9.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set routing-options router-id 198.51.100.5
    set interfaces ge-0/0/9 unit 0 family inet address 169.254.35.1/31
    set interfaces ge-0/0/9 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 198.51.100.5/32

     

     

    R3 config:

     

     

    set policy-options policy-statement GRT->NFI term 1 from instance master
    set policy-options policy-statement GRT->NFI term 1 from protocol ospf
    set policy-options policy-statement GRT->NFI term 1 then accept
    set policy-options policy-statement GRT->NFI then reject
    set policy-options policy-statement NFI->GRT term 1 from instance OSPF-BLAH
    set policy-options policy-statement NFI->GRT term 1 from protocol ospf
    set policy-options policy-statement NFI->GRT term 1 then accept
    set policy-options policy-statement PL-OSPF-EX term 1 from protocol static
    set policy-options policy-statement PL-OSPF-EX term 1 from route-filter 198.51.100.3/32 exact
    set policy-options policy-statement PL-OSPF-EX term 1 then accept
    set policy-options policy-statement PL-OSPF-EX term 2 from protocol ospf
    set policy-options policy-statement PL-OSPF-EX term 2 then accept
    set routing-instances OSPF-BLAH routing-options static route 198.51.100.3/32 receive
    set routing-instances OSPF-BLAH routing-options router-id 198.51.100.3
    set routing-instances OSPF-BLAH routing-options instance-import GRT->NFI
    set routing-instances OSPF-BLAH protocols ospf area 0.0.0.0 interface ge-1/0/3.0
    set routing-instances OSPF-BLAH protocols ospf export PL-OSPF-EX
    set routing-instances OSPF-BLAH instance-type no-forwarding
    set routing-instances OSPF-BLAH interface ge-1/0/3.0
    set routing-options instance-import NFI->GRT
    set routing-options router-id 198.51.100.3
    set protocols ldp track-igp-metric
    set protocols ldp interface ge-0/0/9.0
    set protocols ldp interface ge-1/0/3.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/9.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols ospf export PL-OSPF-EX
    set interfaces ge-0/0/9 unit 0 family inet address 169.254.35.0/31
    set interfaces ge-0/0/9 unit 0 family mpls
    set interfaces ge-1/0/3 unit 0 family inet address 169.254.0.32/24
    set interfaces ge-1/0/3 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 198.51.100.3/32

     

    R6 config:

     

     

    set protocols ldp track-igp-metric
    set protocols ldp explicit-null
    set protocols ldp interface ge-0/0/3.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/3.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set routing-options router-id 198.51.100.6
    set interfaces ge-0/0/3 unit 0 family inet address 169.254.0.23/24
    set interfaces ge-0/0/3 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 198.51.100.6/32

     

     

    Verification:

     

    R5:

     

     

     

    regress@R5> show ospf neighbor 
    Address          Interface              State           ID               Pri  Dead
    169.254.35.0     ge-0/0/9.0             Full            198.51.100.3     128    33
    
    regress@R5> show ldp session 
      Address                           State       Connection  Hold time  Adv. Mode
    198.51.100.3                        Operational Open          23         DU
    
    regress@R5> show route table inet.3 protocol ldp 
    
    inet.3: 17 destinations, 17 routes (17 active, 0 holddown, 0 hidden)
    Restart Complete
    + = Active Route, - = Last Active, * = Both
    
    198.51.100.3/32    *[LDP/9] 00:31:48, metric 1
                        >  to 169.254.35.0 via ge-0/0/9.0
    198.51.100.6/32    *[LDP/9] 00:19:01, metric 1
                        >  to 169.254.35.0 via ge-0/0/9.0, Push 44
    

     

     

     

     

    R3:

     

     

     

     

    regress@R3> show ospf neighbor instance all 
    Instance: master
    Address          Interface              State           ID               Pri  Dead
    169.254.35.1     ge-0/0/9.0             Full            198.51.100.5     128    38
    
    Instance: OSPF-BLAH
    Address          Interface              State           ID               Pri  Dead
    169.254.0.23     ge-1/0/3.0             Full            198.51.100.6     128    31
    
    regress@R3> show ldp session 
      Address                           State       Connection  Hold time  Adv. Mode
    198.51.100.5                        Operational Open          28         DU
    198.51.100.6                        Operational Open          28         DU
    
    regress@R3> show route table inet.3 protocol ldp 
    
    inet.3: 9 destinations, 9 routes (9 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    198.51.100.5/32    *[LDP/9] 00:33:29, metric 1
                        >  to 169.254.35.1 via ge-0/0/9.0
    198.51.100.6/32    *[LDP/9] 00:24:18, metric 1
                        >  to 169.254.0.23 via ge-1/0/3.0, Push 0

     

     

     

     

    R6:

     

     

     

     

    regress@R6> show ospf neighbor 
    Address          Interface              State           ID               Pri  Dead
    169.254.0.32     ge-0/0/3.0             Full            198.51.100.3     128    38
    
    regress@R6> show ldp session 
      Address                           State       Connection  Hold time  Adv. Mode
    198.51.100.3                        Operational Open          25         DU
    
    regress@R6> show route table inet.3 protocol ldp 
    
    inet.3: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    198.51.100.3/32    *[LDP/9] 00:26:01, metric 0
                        >  to 169.254.0.32 via ge-0/0/3.0
    198.51.100.5/32    *[LDP/9] 00:24:44, metric 1
                        >  to 169.254.0.32 via ge-0/0/3.0, Push 43
    

     

     

    HTH

    Thx

    Alex



  • 4.  RE: Passing LDP labels between Routing-instance and Inet.3

    Posted 08-13-2020 11:20

    Hi

    Thank you for your efforts on This. I will test this and check the results and I will Inform you



  • 5.  RE: Passing LDP labels between Routing-instance and Inet.3
    Best Answer

    Posted 08-13-2020 11:31

    Hi

    Another question, about no-forwarding instance: Does this separate the entire OSPF domains from each other. I mean With this instance type I can redistribute routes from OSPF1 into OSPF2 and Vice versa. Is this assumption correct?

    Thank you

     



  • 6.  RE: Passing LDP labels between Routing-instance and Inet.3

    Posted 08-13-2020 19:54

    Hello,

     


    @Asoltanian wrote:

    Does this separate the entire OSPF domains from each other. I mean With this instance type I can redistribute routes from OSPF1 into OSPF2 and Vice versa. Is this assumption correct?

     


     

    Yes. Your assumption is correct.

    HTH

    Thx

    Alex

     

     



  • 7.  RE: Passing LDP labels between Routing-instance and Inet.3

    Posted 08-15-2020 03:06
      |   view attached

    Hi

    I tested your configuration and It worked!!!

    Refer to my diagram, I established MP-BGP session between vMX1 and vMX6 while vMX2 has two OSPF domain. vMX5 and vMX4 can ping each other loopback address without any issue.

    Some questions here:

    1- I don't understand the concept of "no-forward" instance. As documentation says:Use this routing instance type when a separation of routing table information is required. There is no corresponding forwarding table. All routes are installed into the default forwarding tables. IS-IS instances are strictly non forwarding instance types.

    Does this means there is no separate table with no-forward. Would you please explain me about the function of no-forward?

    2- As I check route there is no route in inet.3 of configured routing-instance.Is this normal?

     

    Thank you

     



  • 8.  RE: Passing LDP labels between Routing-instance and Inet.3

    Posted 08-15-2020 03:09

    Hi

    Sorry for the mistake, I selected my own post as solution...


    #Sorr