Junos OS

Expand all | Collapse all

IPv6 default gateway not sent by BRAS

Jump to Best Answer
  • 1.  IPv6 default gateway not sent by BRAS

    Posted 11-15-2018 02:53

    Im trying to implement IPoE on Juniper MX104 using dual stack configuration. Everything worked well except that the client is not getting IPv6 default gateway. If i manually put default gateway in client, then there is no issue. However, while i tried configuring dhcpv6 in linux server, all goes well. My configuration is as below:

    testdynprofile {
    routing-instances {
    "$junos-routing-instance" {
    interface "$junos-interface-name";
    }
    }
    interfaces {
    demux0 {
    unit "$junos-interface-unit" {
    family inet {
    unnumbered-address "$junos-loopback-interface";
    }
    family inet6 {
    unnumbered-address "$junos-loopback-interface";
    }
    }
    }
    }
    }
    VLAN-demux {
    routing-instances {
    "$junos-routing-instance" {
    interface "$junos-interface-name";
    }
    }
    interfaces {
    demux0 {
    unit "$junos-interface-unit" {
    vlan-tags outer "$junos-stacked-vlan-id" inner "$junos-vlan-id";
    demux-options {
    underlying-interface "$junos-underlying-interface";
    }
    family inet {
    unnumbered-address "$junos-loopback-interface";
    }
    family inet6 {
    unnumbered-address "$junos-loopback-interface";
    }
    }
    }
    }
    protocols {
    router-advertisement {
    interface "$junos-interface-name" {
    prefix $junos-ipv6-ndra-prefix;
    }
    }
    }
    }

    dhcp-local-server {
    dhcpv6 {
    access-profile local;
    group IPv6 {
    dynamic-profile testdynprofile;
    overrides {
    rapid-commit;
    }
    interface ae1.0;
    interface demux0.0;
    }
    }
    pool-match-order {
    ip-address-first;
    }
    dynamic-profile testdynprofile;
    access-profile local;
    group local {
    interface ae1.0;
    interface demux0.0;
    }
    }
    subscriber-management {
    gres-route-flush-delay;
    enable;
    }

    ae1 {
    description test-interface;
    flexible-vlan-tagging;
    auto-configure {
    stacked-vlan-ranges {
    dynamic-profile VLAN-demux {
    accept any;
    ranges {
    800-800,400-699;
    }
    }
    access-profile local;
    }
    remove-when-no-subscribers;
    }
    aggregated-ether-options {
    load-balance {
    adaptive {
    tolerance 10;
    }
    }
    lacp {
    active;
    }
    ethernet-switch-profile {
    tag-protocol-id 0x8100;
    }
    }


    lo0 {
    unit 0 {
    family inet {
    address 192.168.1.1/32;
    address 100.80.0.1/32 {
    primary;
    preferred;
    }
    }
    family inet6 {
    address 2100:d000::1/128;
    address 2100:d000:8901:0::1/64 {
    primary;
    preferred;
    }
    }
    }
    }


    pool WiFi-v6-pool {
    family inet6 {
    prefix 2100:d000:8901:0::/64 ;
    range 0-ffff {
    low 2100:d000:8901:0::2/128 ;
    high 2100:d000:8901:0::ffff/128;
    }
    dhcp-attributes {
    maximum-lease-time 3600;
    dns-server {
    2100:d000:1::2/64 ;
    }
    }
    }
    }

     

    I need some suggestions from BRAS guys. Please provide your valuable suggestions.



  • 2.  RE: IPv6 default gateway not sent by BRAS

     
    Posted 11-15-2018 02:59

    Here client is initiating /128 IANA address because of which default gateway is not set.

    Can we have PCAP from linux machine?

     

    Regards

    Rahul



  • 3.  RE: IPv6 default gateway not sent by BRAS

    Posted 11-15-2018 03:25

    Hi Rahul,

     

    Thank you for your reply.

    I changed the config to /64 as well but it didnt work. I even configured RA as well. However, the document from juniper has example with /128.

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB25760&smlogin=true

     

     



  • 4.  RE: IPv6 default gateway not sent by BRAS
    Best Answer

     
    Posted 12-25-2018 08:11

    Hi,

     

    Please share the result after configuring RA under the dynamic-profile.

     

    show dynamic-profiles
    test{
    routing-instances {
    "$junos-routing-instance" {
    interface "$junos-interface-name";
    }
    }
    interfaces {
    demux0 {
    unit "$junos-interface-unit" {
    family inet {
    unnumbered-address "$junos-loopback-interface";
    }
    family inet6 {
    unnumbered-address "$junos-loopback-interface";
    }
    }
    }
    }
    protocols {
    router-advertisement {
    interface "$junos-interface-name" {
    max-advertisement-interval 15;
    min-advertisement-interval 10;
    managed-configuration;
    dns-server-address x:x:x:x::x {
    lifetime 1800;
    }
    }
    }
    }
    }

     



  • 5.  RE: IPv6 default gateway not sent by BRAS

    Posted 12-26-2018 10:42
    test{ routing-instances { "$junos-routing-instance" { interface "$junos-interface-name"; } } interfaces { demux0 { unit "$junos-interface-unit" { family inet { unnumbered-address "$junos-loopback-interface"; } family inet6 { unnumbered-address "$junos-loopback-interface"; } } } } protocols { router-advertisement { interface "$junos-interface-name" { max-advertisement-interval 15; min-advertisement-interval 10; managed-configuration; dns-server-address x:x:x:x::x { lifetime 1800; } } } } }


  • 6.  RE: IPv6 default gateway not sent by BRAS

    Posted 12-28-2018 06:14