Junos OS

Expand all | Collapse all

EX4300 & VMware LAG Issue

Jump to Best Answer
  • 1.  EX4300 & VMware LAG Issue

    Posted 01-28-2017 19:52

    Evening All,

     

    Looking for some assistance because my head is about to explode looking over this issue. I've spent the day looking at it and I'm lost at this point.

     

    Scenario:

     

    Two EX4300s in a VC.

     

    VMware Host - Management IP is 10.1.111.6

     

    vSwitch0 - Eth0 and Eth4, IP Hashing, Untagged on VLAN111

    vSwitch1 - Eth1/2/3/5/6/7, IP Hashing, Tagged on VLAN10 and VLAN111

     

    Host ports Eth0 | Eth4 correlate to ge-0/0/0 and ge-1/0/0 on the EX4300 Virtual Chassis

    Host ports Eth1/2/3/5/6/7 correlate to ge-0/0/1-3 and ge-1/0/1-3 on the EX4300s

     

    EX4300 Config:

    interfaces {
        ge-0/0/0 {
            ether-options {
                802.3ad ae0;
            }
        }
        ge-0/0/1 {
            ether-options {
                802.3ad ae1;
            }
        }
        ge-0/0/2 {
            ether-options {
                802.3ad ae1;
            }
        }
        ge-0/0/3 {
            ether-options {
                802.3ad ae1;
            }
        }
        ge-1/0/0 {
            ether-options {
                802.3ad ae0;
            }
        }
        ge-1/0/1 {
            ether-options {
                802.3ad ae1;
            }
        }
        ge-1/0/2 {
            ether-options {
                802.3ad ae1;
            }
        }
        ge-1/0/3 {
            ether-options {
                802.3ad ae1;
            }
        }
        ae0 {
            native-vlan-id 111;
            unit 0 {
                family ethernet-switching {
                    interface-mode trunk;
                    vlan {
                        members Server_VLAN111;
                    }
                }
            }
        }
        ae1 {
            unit 0 {
                family ethernet-switching {
                    interface-mode trunk;
                    vlan {
                        members [ Legacy_VLAN10 Server_VLAN111 ];
                    }
                }
            }
        }
        irb {
            unit 1 {
                family inet {
                    address 10.1.1.11/24;
                }
            }
            unit 10 {
                family inet {
                    address 10.2.1.254/24;
                }
            }
            unit 111 {
                family inet {
                    address 10.1.111.254/24;
                }
            }
    }
    routing-options {
        static {
            route 0.0.0.0/0 next-hop 10.2.1.1;
        }
    }
    protocols {
        lldp {
            interface all;
        }
        lldp-med {
            interface all;
        }
        igmp-snooping {
            vlan default;
        }
    }
    virtual-chassis {
        member 0 {
            mastership-priority 255;
        }
        member 1 {
            mastership-priority 250;
        }
    }
    vlans {
        Legacy_VLAN10 {
            vlan-id 10;
            l3-interface irb.10;
        Server_VLAN111 {
            vlan-id 111;
            l3-interface irb.111;
        }
        default {
            vlan-id 1;
            l3-interface irb.1;
        }
    }
    

    A Test VM with an IP address on the 10.1.111.0/24 Subnet, attached to vSwitch0, can ping everything on the network just fine. (Two other switches in a closet are on 10.1.1.12 and 10.1.1.13) Including the host its running on at 10.1.111.6.

     

    If I move the same VM to vSwitch1 I can ping 10.1.1.13, but not 10.1.1.12. I can ping out to google dns at 8.8.8.8 but I can't ping my firewall at 10.2.1.1, and it also can't ping its own host any longer.

     

    Any insight anyone can offer would be appreciated. If more info is needed let me know!

     

    Thanks



  • 2.  RE: EX4300 & VMware LAG Issue

    Posted 01-29-2017 04:51

    If you have vlan 111 set as the native vlan-id, do not add it to the member list of vlans.  If you only have a single VLAN, then just make it an access-port.  If you have multiple ports, then just add the non-native VLANs as members.  What you are telling the switch to do is to tag outbound frames with tag 111, and to accept either 111-tagged frames or untagged frames and assign them to vlan 111.

     

    Ron



  • 3.  RE: EX4300 & VMware LAG Issue
    Best Answer

    Posted 01-29-2017 05:42

    Upon further investigation it appears the issue may actually lie with VMware. The only devices having issues with VLAN tagging and etherchannel on the EX4300s are the VMware hosts. 

     

    Going to close this and open a case with them.



  • 4.  RE: EX4300 & VMware LAG Issue

    Posted 07-11-2019 05:10

    Hi ,

     

    I am have similar troubles as you  mentioned in your post, using vmware 6.7 ... what was the problem in your case, please?

     

    TIA and best regards

     

    juan