Routing

Expand all | Collapse all

vMX version above 20.1R1 just deteect as "olive" only?

Jump to Best Answer
  • 1.  vMX version above 20.1R1 just deteect as "olive" only?

    Posted 12-19-2020 11:40

    Hi all,

    I'm testing vMX version 20.1R2 and above. But it look like that version above not same like below version 20.1R1. Also the size of image VCP is too many different between both version. Any one know is it version 20.1R2 and above need something to tweak so it can be use like other vMX?

    Thanks and appreciate nay feedback



  • 2.  RE: vMX version above 20.1R1 just deteect as "olive" only?

     
    Posted 12-19-2020 11:49

    Hi kronicklez,

    In general, Juniper is optimizing the file size regularly. E.g. 20.1 has a size of 5.7 GB, and 20.2 is reduced to 1.2 GB. There shouldn't be any reason to tweak anything, 20.2 can be used the same way as 20.1. There is nothing mentioned in the release notes as well. So no reason to worry about the file size.



    ------------------------------
    ------------------------------
    If my answer provides the solution, please mark my post as "Best Answer".
    If you think my answer helps, please "Recommend" my post.
    ------------------------------



  • 3.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 12-19-2020 12:09

    Hi,

    The issue when i use vmx version 20.2 also 20.3 it just detect as olive only. So when do command show chassis routing engine it throw the error. I'm test it using EVE-NG & PNET. Same output.

    Thanks




  • 4.  RE: vMX version above 20.1R1 just deteect as "olive" only?

     
    Posted 12-19-2020 12:23

    Hi,

    are you using EVE-NG Community or Professional Edition?



    ------------------------------
    ------------------------------
    If my answer provides the solution, please mark my post as "Best Answer".
    If you think my answer helps, please "Recommend" my post.
    ------------------------------



  • 5.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 12-19-2020 12:39

    Hi,

    I'm using EVE community. By the way it should not issue whether use community or pro version because below version 20.1 and below can work on community version.

    Thanks




  • 6.  RE: vMX version above 20.1R1 just deteect as "olive" only?

     
    Posted 12-19-2020 12:44

    Hi,

    starting with JUNOS 20.1 you need EVE-NG PRO, as Ubuntu 18.04.3 LTS is a requirement for this. EVE-NG Community works with Ubuntu 16.04.
    So you can use everything up to and including JUNOS 19.4 with the Community Edition. Starting with 20.1, only EVE-NG Pro works.

    You can find the requirements here:
    https://www.juniper.net/documentation/en_US/vmx/topics/reference/general/vmx-hw-sw-minimums.html

    • For Junos OS 20.1R1 and later releases:

      • Ubuntu 18.04.3 LTS

      • Linux 4.15.0-70-generic



    ------------------------------
    ------------------------------
    If my answer provides the solution, please mark my post as "Best Answer".
    If you think my answer helps, please "Recommend" my post.
    ------------------------------



  • 7.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 12-19-2020 22:21

    Hi,

    I'm no issue on 20.1 but the issue on 20.2 and 20.3 only. By the way i'm used Ubuntu 18 (PNETLAB). So it should not have an issue. Anyone here also can test version 20.2 and 20.3 on EVE?

    Thanks




  • 8.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 27 days ago

    Hi all,

    Below is the output. I'm using Ubuntu 18. Any one here has try?

    root> show version
    Model: olive
    Junos: 20.3R1.8
    JUNOS OS Kernel 64-bit [20200908.87c9d89_builder_stable_11]
    JUNOS OS libs [20200908.87c9d89_builder_stable_11]

    root> show chassis routing-engine
    error: Unrecognized command (chassis-control)




  • 9.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 15 days ago
    Hi all,

    Just to update. I'm change using .ova but it still detect as Olive on VCP. Anyone here success to test version 20.2 and above.

    Thanks


  • 10.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 15 days ago
    Hi, I just powered up 20.2 and 20.3 on EVE - no issues - recognized as vMX.

    ------------------------------
    Christian Scholz
    Juniper Networks Ambassador | JNCIE-SEC #374
    Mail: chs@ip4.de
    Blog: jncie.eu
    ------------------------------



  • 11.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 15 days ago
    Hi,


    Can u share your qemu option setting on that EVE? May be that setting need be change so it will recognize UBUNTU 18.


    Thanks


  • 12.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 14 days ago
    Sure. I did not optimize this test at all so it's basically the default template:

    -machine type=pc-1.0,accel=kvm -serial mon:stdio -nographic


    BR
    Christian


    ------------------------------
    Christian Scholz
    Juniper Networks Ambassador | JNCIE-SEC #374
    Mail: chs@ip4.de
    Blog: jncie.eu
    ------------------------------



  • 13.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 14 days ago
    Hi Christian,

    Thanks for the output. It look like i need to upgrade my PNET version.

    Thanks again


  • 14.  RE: vMX version above 20.1R1 just deteect as "olive" only?
    Best Answer

    Posted 14 days ago
    You're welcome :)

    ------------------------------
    Christian Scholz
    Juniper Networks Ambassador | JNCIE-SEC #374
    Mail: chs@ip4.de
    Blog: jncie.eu | Twitter: @chsjuniper | YT-Channel: netchron
    ------------------------------



  • 15.  RE: vMX version above 20.1R1 just deteect as "olive" only?

    Posted 4 days ago
    Hi,

    Problem solved after i upgrade the kernel on UBUNTU 18. Now can see vmx version 20.4 not detect as olive.

    Thanks