Routing

Expand all | Collapse all

Problem with media converter on Junos 15.1R6.7

Jump to Best Answer
  • 1.  Problem with media converter on Junos 15.1R6.7

    Posted 09-05-2018 04:49

    Hello,

    We recently upgrade to Junos 15.1R6.7 version in our MX960 and an interface link change to DOWN. We didn't change the configuration, we just upgrade from version 12 to 15. The rest of the interfaces are UP.

     

    This link connects physically to a media converter from ethernet to fiber, and then connect through level 3 to another router. We solve this issue connecting a hub between our MX960 and the media converter.

     

    Any idea what is happening? Thanks.



  • 2.  RE: Problem with media converter on Junos 15.1R6.7

    Posted 09-05-2018 04:55

    Hello,


    @CICA wrote:

     

     This link connects physically to a media converter from ethernet to fiber, and then connect through level 3 to another router. We solve this issue connecting a hub between our MX960 and the media converter.

     

     If it is really a HUB (the device that operates in half-duplex/HD only as opposed to a switch that can operate in HD and/or FD per port) then Your link was somehow operating in HD before, and the upgrade restricted this possibility.

    Do You have "no-auto-negotiation" knob applied to this port? if yes then You might want to remove it + remove the HUB and re-test.

    HTH

    Thx

    Alex



  • 3.  RE: Problem with media converter on Junos 15.1R6.7

    Posted 09-05-2018 05:45

    It's not exactly a hub, it's a dumb switch.

    Diagrama1.jpeg

    Without the switch, the link is DOWN. Everything was UP before the upgrade.

     

    The interface configuration is:

    ge-1/0/3 {
    enable;
    speed 100m;
    mtu 9192;
    link-mode full-duplex;
    unit 0 {
    family inet {
    address X.X.X.X/30 {
    broadcast X.X.X.X;
    }
    }
    }
    }

     

    Thanks!



  • 4.  RE: Problem with media converter on Junos 15.1R6.7
    Best Answer

     
    Posted 09-05-2018 15:09

    Try turning off auto-neg on the port in addition to the settings you have for 100 full explicit and see if the link will come up.

     

    Also what is the card on the MX can the optic from the media convertor just be put directly into the sfp slot?

     



  • 5.  RE: Problem with media converter on Junos 15.1R6.7

    Posted 09-11-2018 09:59

    It works! Thanks!