Routing

Expand all | Collapse all

SRX 550 - OSPF Adjacency Stuck in ExStart State

  • 1.  SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-26-2018 20:35

    I have a clustered SRX 550 pair.  They are uplinked to a pair of fabriced Brocade VDX 6740s.  Uplinked from there is a Brocade NetIron CER.  

     

    I've configured OSPF on each device and made sure they are in the same area.  I've also added interfaces to the area and added network statements.  The firewall and router are both staying in the ExStart State like this:

    ===========================================================================

    root@SRX> show ospf neighbor
    Address          Interface        State        ID                    Pri        Dead
    192.168.1.1     reth0.0           ExStart    192.168.1.1     1           36

    ===========================================================================

    SSH@CER#show ip ospf neighbor
    Number of Neighbors is 1, in FULL state 0

    Port      Address            Pri       State Neigh       Address              Neigh ID               Ev Opt      Cnt
    v99      192.168.1.1     128      EXST/BDR          192.168.1.6       192.168.1.6          15382       0

     =========================================================================

    I know that MTU size tends to cause this problem so I've checked all MTU settings.  Some were different but I forced them all to be 1548.  So that is no longer an issue. 

     

    Any other ideas?



  • 2.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-26-2018 23:58

    SRX is in which mode packet mode or Flow mode?

     

    If it is in flow mode, have you allow host-inbound-system protocols ospf for reth.0?

     

    If still it is stuck in ExStart, can you change from reth0 to ge-x/x/x to trouble it further?

     

    Also paste your configuration to understand it better.



  • 3.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-27-2018 09:57

    set security zones security-zone untrust screen untrust-screen
    set security zones security-zone untrust host-inbound-traffic system-services ping
    set security zones security-zone untrust host-inbound-traffic system-services traceroute
    set security zones security-zone untrust host-inbound-traffic protocols ospf
    set security zones security-zone untrust interfaces reth0.0 host-inbound-traffic system-services ping
    set security zones security-zone untrust interfaces reth0.0 host-inbound-traffic system-services traceroute
    set security zones security-zone untrust interfaces reth0.0 host-inbound-traffic protocols ospf

    I have indeed added ospf as a protocol on both the interface and the zone itself.



  • 4.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-27-2018 10:01
    set version 12.3X48-D25.3
    set groups node0 system host-name DC-CFW-01
    set groups node0 interfaces fxp0 unit 0 family inet address 10.251.200.5/16
    set groups node1 system host-name DC-CFW-02
    set groups node1 interfaces fxp0 unit 0 family inet address 10.251.200.6/16
    set apply-groups "${node}"
    set system host-name DC-NJ-CFW
    set system root-authentication encrypted-password "$1$NBfm/zUG$fBrtCik0lNc35pZ6EZBQK."
    set system services ssh
    set system services telnet
    set system services xnm-clear-text
    set system services web-management http
    set system services web-management https system-generated-certificate
    set system services web-management https interface fxp0.0
    set system syslog archive size 100k
    set system syslog archive files 3
    set system syslog user * any emergency
    set system syslog file messages any critical
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands error
    set system max-configurations-on-flash 5
    set system max-configuration-rollbacks 5
    set system license autoupdate url https://ae1.juniper.net/junos/key_retrieval
    set chassis cluster reth-count 5
    set chassis cluster redundancy-group 0 node 0 priority 100
    set chassis cluster redundancy-group 0 node 1 priority 1
    set chassis cluster redundancy-group 1 node 0 priority 100
    set chassis cluster redundancy-group 1 node 1 priority 1
    set chassis cluster redundancy-group 1 interface-monitor ge-0/0/4 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-0/0/5 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-0/0/6 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-0/0/7 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-9/0/4 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-9/0/5 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-9/0/6 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-9/0/7 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-0/0/8 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-0/0/9 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-9/0/8 weight 255
    set chassis cluster redundancy-group 1 interface-monitor ge-9/0/9 weight 255
    set security screen ids-option untrust-screen icmp ping-death
    set security screen ids-option untrust-screen ip source-route-option
    set security screen ids-option untrust-screen ip tear-drop
    set security screen ids-option untrust-screen tcp syn-flood alarm-threshold 1024
    set security screen ids-option untrust-screen tcp syn-flood attack-threshold 200
    set security screen ids-option untrust-screen tcp syn-flood source-threshold 1024
    set security screen ids-option untrust-screen tcp syn-flood destination-threshold 2048
    set security screen ids-option untrust-screen tcp syn-flood timeout 20
    set security screen ids-option untrust-screen tcp land
    set security policies from-zone trust to-zone untrust policy trust-to-untrust match source-address any
    set security policies from-zone trust to-zone untrust policy trust-to-untrust match destination-address any
    set security policies from-zone trust to-zone untrust policy trust-to-untrust match application any
    set security policies from-zone trust to-zone untrust policy trust-to-untrust then permit
    set security policies from-zone untrust to-zone trust policy 1 match source-address any
    set security policies from-zone untrust to-zone trust policy 1 match destination-address any
    set security policies from-zone untrust to-zone trust policy 1 match application any
    set security policies from-zone untrust to-zone trust policy 1 then deny
    set security zones security-zone trust host-inbound-traffic system-services all
    set security zones security-zone trust host-inbound-traffic protocols all
    set security zones security-zone trust interfaces reth1.0
    set security zones security-zone untrust screen untrust-screen
    set security zones security-zone untrust host-inbound-traffic system-services ping
    set security zones security-zone untrust host-inbound-traffic system-services traceroute
    set security zones security-zone untrust host-inbound-traffic protocols ospf
    set security zones security-zone untrust interfaces reth0.0 host-inbound-traffic system-services ping
    set security zones security-zone untrust interfaces reth0.0 host-inbound-traffic system-services traceroute
    set security zones security-zone untrust interfaces reth0.0 host-inbound-traffic protocols ospf
    set security zones security-zone planet-data interfaces reth2.0
    set interfaces ge-0/0/4 gigether-options redundant-parent reth0
    set interfaces ge-0/0/5 gigether-options redundant-parent reth0
    set interfaces ge-0/0/6 gigether-options redundant-parent reth1
    set interfaces ge-0/0/7 gigether-options redundant-parent reth1
    set interfaces ge-0/0/8 gigether-options redundant-parent reth2
    set interfaces ge-0/0/9 gigether-options redundant-parent reth2
    set interfaces ge-9/0/4 gigether-options redundant-parent reth0
    set interfaces ge-9/0/5 gigether-options redundant-parent reth0
    set interfaces ge-9/0/6 gigether-options redundant-parent reth1
    set interfaces ge-9/0/7 gigether-options redundant-parent reth1
    set interfaces ge-9/0/8 gigether-options redundant-parent reth2
    set interfaces ge-9/0/9 gigether-options redundant-parent reth2
    set interfaces fab0 fabric-options member-interfaces ge-0/0/2
    set interfaces fab0 fabric-options member-interfaces ge-0/0/3
    set interfaces fab1 fabric-options member-interfaces ge-9/0/2
    set interfaces fab1 fabric-options member-interfaces ge-9/0/3
    set interfaces fxp0 unit 0 family inet
    set interfaces lo0 unit 0 family inet address 2.2.2.2/24
    set interfaces reth0 description UNTRUST
    set interfaces reth0 mtu 1522
    set interfaces reth0 redundant-ether-options redundancy-group 1
    set interfaces reth0 redundant-ether-options lacp passive
    set interfaces reth0 unit 0 family inet address 192.168.1.6/29
    set interfaces reth1 description TRUST
    set interfaces reth1 redundant-ether-options redundancy-group 1
    set interfaces reth1 redundant-ether-options lacp passive
    set interfaces reth1 unit 0 family inet
    set routing-options router-id 192.168.1.6
    set protocols ospf export EXPORT-OSPF
    set protocols ospf area 0.0.0.20 area-range 192.168.1.0/29
    set protocols ospf area 0.0.0.20 interface reth0.0
    set protocols ospf area 0.0.0.20 interface lo0.0
    set protocols stp
    set policy-options prefix-list EXPORT-OSPF 1.1.1.0/24
    set policy-options prefix-list EXPORT-OSPF 2.2.2.0/24
    set policy-options prefix-list EXPORT-OSPF 192.168.1.0/29
    set policy-options policy-statement EXPORT-OSPF term acceptDefault1 from protocol direct
    set policy-options policy-statement EXPORT-OSPF term acceptDefault1 from prefix-list EXPORT-OSPF
    set policy-options policy-statement EXPORT-OSPF term acceptDefault1 then accept
    set policy-options policy-statement EXPORT-OSPF term acceptStatic1 from protocol static
    set policy-options policy-statement EXPORT-OSPF term acceptStatic1 from prefix-list EXPORT-OSPF
    set policy-options policy-statement EXPORT-OSPF term acceptStatic1 then accept
    set policy-options policy-statement EXPORT-OSPF then reject


  • 5.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-27-2018 23:02
    Can you pl remove area-range knob as same network is being advertized via reth0 as well. 2nd, which physical interfaces are connected between SRX550 and remote devices forming OSPF? What is the status of the command show chassis cluster status during OSPF process? Last, can you pl configure the OSPF trace-options as follows: set protocols ospf traceoptions file ospf-log set protocols ospf traceoptions file files 5 size 10k set protocols ospf traceoptions flag all commit and quit ********** clear ospf neighbor show log ospf-log (capture this file and paste it here to troubleshoot it further).


  • 6.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 08-01-2018 18:43
    show log ospf-log
    Aug  2 08:59:55 trace_on: Tracing to "/var/log/ospf-log" started
    Aug  2 08:59:55.841376 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:35
    Aug  2 08:59:55.841603 background dispatch running job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.841646 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:35
    Aug  2 08:59:55.841707 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:35
    Aug  2 08:59:55.841765 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:35
    Aug  2 08:59:55.841821 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:35
    Aug  2 08:59:55.841861 OSPF restart signaling: set L bit in hellos sent on interface lo0.0.
    Aug  2 08:59:55.841889 OSPF restart signaling: set L bit in hellos sent on interface reth0.0.
    Aug  2 08:59:55.841917 OSPF sent Hello 192.168.1.6 -> 224.0.0.5 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 08:59:55.841940   Version 2, length 48, ID 192.168.1.6, area 0.0.0.20
    Aug  2 08:59:55.841963   mask 255.255.255.248, hello_ivl 10, opts 0x12, prio 128
    Aug  2 08:59:55.841983   dead_ivl 40, DR 192.168.1.6, BDR 192.168.1.1
    Aug  2 08:59:55.842002   neighbor 192.168.1.1
    Aug  2 08:59:55.842028 OSPF restart signaling: Add LLS data for Hello packet on interface reth0.0.
    Aug  2 08:59:55.842069 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:35
    Aug  2 08:59:55.842113 task_job_delete: delete background job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.842144 background dispatch completed job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.842373 IFL ge-9/0/9.0 iflchange 0x0
    Aug  2 08:59:55.842465 IFL ge-9/0/8.0 iflchange 0x0
    Aug  2 08:59:55.842555 IFL ge-9/0/7.0 iflchange 0x0
    Aug  2 08:59:55.842643 IFL ge-9/0/6.0 iflchange 0x0
    Aug  2 08:59:55.842765 IFL ge-9/0/5.0 iflchange 0x0
    Aug  2 08:59:55.842854 IFL ge-9/0/4.0 iflchange 0x0
    Aug  2 08:59:55.842943 IFL ge-9/0/3.0 iflchange 0x0
    Aug  2 08:59:55.843036 IFL ge-9/0/2.0 iflchange 0x0
    Aug  2 08:59:55.843130 IFL fab1.0 iflchange 0x0
    Aug  2 08:59:55.843222 IFL ge-0/0/9.0 iflchange 0x0
    Aug  2 08:59:55.843310 IFL ge-0/0/8.0 iflchange 0x0
    Aug  2 08:59:55.843397 IFL ge-0/0/7.0 iflchange 0x0
    Aug  2 08:59:55.843485 IFL ge-0/0/6.0 iflchange 0x0
    Aug  2 08:59:55.843575 IFL ge-0/0/5.0 iflchange 0x0
    Aug  2 08:59:55.843663 IFL ge-0/0/4.0 iflchange 0x0
    Aug  2 08:59:55.843752 IFL ge-0/0/3.0 iflchange 0x0
    Aug  2 08:59:55.843840 IFL ge-0/0/2.0 iflchange 0x0
    Aug  2 08:59:55.843933 IFL fab0.0 iflchange 0x0
    Aug  2 08:59:55.844037 IFL reth2.0 iflchange 0x0
    Aug  2 08:59:55.844135 IFL reth1.0 iflchange 0x0
    Aug  2 08:59:55.844231 IFL reth0.0 iflchange 0x0
    Aug  2 08:59:55.844314 IFL lo0.16385 iflchange 0x0
    Aug  2 08:59:55.844369 IFL lo0.16384 iflchange 0x0
    Aug  2 08:59:55.844440 IFL lo0.0 iflchange 0x0
    Aug  2 08:59:55.844534 IFL fxp2.0 iflchange 0x0
    Aug  2 08:59:55.844616 IFL fxp1.0 iflchange 0x0
    Aug  2 08:59:55.844689 IFL fxp0.0 iflchange 0x0
    Aug  2 08:59:55.844982 IFL fxp0.0 addr (10.251.200.5) ifachange 0x0
    Aug  2 08:59:55.845447 IFL lo0.0 addr (2.2.2.2) ifachange 0x0
    Aug  2 08:59:55.845816 IFL reth0.0 addr (192.168.1.6) ifachange 0x0
    Aug  2 08:59:55.847671 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.847732 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.847781 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.847809 ppmd_ospf_intf_auth_key_select : interface lo0.0
    Aug  2 08:59:55.847855 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.847911 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.847960 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.847988  No OSPF authentication key active (now : 0)
    Aug  2 08:59:55.848057 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848117 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848165 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.848192 OSPF updated PPM interface IFL 66, addr 2.2.2.2, area 0.0.0.20, ID 0.0.0.0, rtbl idx 0
    Aug  2 08:59:55.848249 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848305 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848352 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.848379 ppmd_ospf_intf_auth_key_select : interface reth0.0
    Aug  2 08:59:55.848424 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848479 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848527 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.848557  No OSPF authentication key active (now : 0)
    Aug  2 08:59:55.848612 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848669 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848717 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.848745 OSPF updated PPM interface IFL 67, addr 192.168.1.6, area 0.0.0.20, ID 0.0.0.0, rtbl idx 0
    Aug  2 08:59:55.848798 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848854 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.848903 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.848931 OSPF neighbor 192.168.1.1 (IFL 67, area 0.0.0.20, rtbl idx 0) set, 40 0
    Aug  2 08:59:55.848993 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.849055 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.849103 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.849131 OSPF programmed periodic xmit from 192.168.1.6 to 224.0.0.5 (IFL 67, area 0.0.0.20, ID 0.0.0.0, rtbl idx 0) interval 10 0
    Aug  2 08:59:55.849217 background dispatch running job Interface event for task OSPF
    Aug  2 08:59:55.849248 Interface lo0.0 area 0.0.0.20 event NeighborChange
    Aug  2 08:59:55.849281 task_job_create_background: create prio 1 job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.849310 Interface lo0.0 (2.2.2.2) area 0.0.0.20 state changed from DR to DR
    Aug  2 08:59:55.849337 OSPF DR is 192.168.1.6, BDR is 0.0.0.0
    Aug  2 08:59:55.849364 Interface reth0.0 area 0.0.0.20 event NeighborChange
    Aug  2 08:59:55.849392 Interface reth0.0 (192.168.1.6) area 0.0.0.20 state changed from DR to DR
    Aug  2 08:59:55.849419 OSPF DR is 192.168.1.6, BDR is 192.168.1.1
    Aug  2 08:59:55.849441 OSPF Interface event job processed 2 events.
    Aug  2 08:59:55.849460 OSPF Interface event job deleted.
    Aug  2 08:59:55.849482 task_job_delete: delete background job Interface event for task OSPF
    Aug  2 08:59:55.849506 background dispatch completed job Interface event for task OSPF
    Aug  2 08:59:55.849596 background dispatch running job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.849625 OSPF restart signaling: set L bit in hellos sent on interface lo0.0.
    Aug  2 08:59:55.849648 OSPF restart signaling: set L bit in hellos sent on interface reth0.0.
    Aug  2 08:59:55.849674 OSPF sent Hello 192.168.1.6 -> 224.0.0.5 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 08:59:55.849697   Version 2, length 48, ID 192.168.1.6, area 0.0.0.20
    Aug  2 08:59:55.849719   mask 255.255.255.248, hello_ivl 10, opts 0x12, prio 128
    Aug  2 08:59:55.849740   dead_ivl 40, DR 192.168.1.6, BDR 192.168.1.1
    Aug  2 08:59:55.849779   neighbor 192.168.1.1
    Aug  2 08:59:55.849802 OSPF restart signaling: Add LLS data for Hello packet on interface reth0.0.
    Aug  2 08:59:55.849841 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:35
    Aug  2 08:59:55.849889 task_job_delete: delete background job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.849919 background dispatch completed job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.850019 rt_flash_update_callback: flash OSPF (inet.0) start
    Aug  2 08:59:55.850711 Starting flash processing for topology default
    Aug  2 08:59:55.850751 Context-Id is inactive in MPLS and will be deleted from OSPF
    Aug  2 08:59:55.850783 Context-Id is inactive in MPLS and will be deleted from OSPF
    Aug  2 08:59:55.850828 Context-Id is inactive in MPLS and will be deleted from OSPF
    Aug  2 08:59:55.850874 Context-Id is inactive in MPLS and will be deleted from OSPF
    Aug  2 08:59:55.850903 Context-Id is inactive in MPLS and will be deleted from OSPF
    Aug  2 08:59:55.850931 Context-Id is inactive in MPLS and will be deleted from OSPF
    Aug  2 08:59:55.850958 OSPF:  multicast address 224.0.0.5/32, route ignored
    Aug  2 08:59:55.850985  Redist elapsed time 0.000243s
    Aug  2 08:59:55.851006    Processed 7 routes
    Aug  2 08:59:55.851024 Finished flash processing for topology default
    Aug  2 08:59:55.851055 rt_flash_update_callback: flash OSPF (inet.0) done
    Aug  2 08:59:55.851319 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.851378 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:55.851428 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:55
    Aug  2 08:59:55.851456 OSPF programmed periodic xmit from 192.168.1.6 to 224.0.0.5 (IFL 67, area 0.0.0.20, ID 0.0.0.0, rtbl idx 0) interval 10 0
    Aug  2 08:59:55.883237 ospf_set_lsdb_state: Router LSA 192.168.1.6 adv-rtr 192.168.1.6 state GEN_PENDING->QUIET
    Aug  2 08:59:55.883316 OSPF built router LSA, area 0.0.0.20, link count 3
    Aug  2 08:59:55.883381 task_timer_reset: reset OSPF_LSA gen
    Aug  2 08:59:55.883425 task_timer_uset: timer OSPF_LSA gen <Touched Processing> set to offset 46:13 at 9:46:08
    Aug  2 08:59:55.883452 LSA Router 192.168.1.6 192.168.1.6 not refreshed as there in no changein LSA body. LSA refresh time 00:46:13
    Aug  2 08:59:56.034604 task_job_create_background: create prio 2 job Route recalc timer for task OSPF
    Aug  2 08:59:56.034697 background dispatch running job Route recalc timer for task OSPF
    Aug  2 08:59:56.034728 Starting full SPF refresh for topology default
    Aug  2 08:59:56.034785 SPF starting for area 0.0.0.20
    Aug  2 08:59:56.034820   OSPF add LSA Router (192.168.1.6, 192.168.1.6) distance 0 to SPF list
    Aug  2 08:59:56.034846 SPF finished for area 0.0.0.20
    Aug  2 08:59:56.034879  SPF elapsed time 0.000094s
    Aug  2 08:59:56.034906 SPF add stubs starting for area 0.0.0.20
    Aug  2 08:59:56.034941     IP Nexthop #1 (null):192.168.1.6 (lo0.0) added
    Aug  2 08:59:56.034975   Adding stub route 2.2.2.2/32
    Aug  2 08:59:56.035007     IP Route added with cost 0
    Aug  2 08:59:56.035040     IP Nexthop #1 (null):192.168.1.6 (lo0.0) added
    Aug  2 08:59:56.035069   Adding stub route 2.2.2.0/24
    Aug  2 08:59:56.035096     IP Route added with cost 0
    Aug  2 08:59:56.035127     IP Nexthop #1 (null):192.168.1.6 (reth0.0) added
    Aug  2 08:59:56.035156   Adding stub route 38.87.38.0/29
    Aug  2 08:59:56.035183     IP Route added with cost 1
    Aug  2 08:59:56.035205 SPF add stubs finished for area 0.0.0.20
    Aug  2 08:59:56.035229  Stub elapsed time 0.000324s
    Aug  2 08:59:56.035255 SPF add inter area starting for area 0.0.0.20
    Aug  2 08:59:56.035277 SPF add inter area Summary starting for area 0.0.0.20
    Aug  2 08:59:56.035298 SPF add inter area Summary finished for area 0.0.0.20
    Aug  2 08:59:56.035319 SPF add inter area ASBRSum starting for area 0.0.0.20
    Aug  2 08:59:56.035340 SPF add inter area ASBRSum finished for area 0.0.0.20
    Aug  2 08:59:56.035360 SPF add inter area finished for area 0.0.0.20
    Aug  2 08:59:56.035415  Interarea elapsed time 0.000157s
    Aug  2 08:59:56.035439 SPF add external starting
    Aug  2 08:59:56.035466 SPF add external finished
    Aug  2 08:59:56.035491  External elapsed time 0.000050s
    Aug  2 08:59:56.035512 SPF add NSSA starting
    Aug  2 08:59:56.035537 SPF add NSSA finished
    Aug  2 08:59:56.035561  NSSA elapsed time 0.000048s
    Aug  2 08:59:56.035583 SPF post spf cleanup starting
    Aug  2 08:59:56.035634   Route 2.2.2.0/24 has been refreshed
    Aug  2 08:59:56.035664   Considering autosummary for 2.2.2.0/24, summary possible=1
    Aug  2 08:59:56.035689   Considering NSSA autosummary for 2.2.2.0/24, summary not possible
    Aug  2 08:59:56.035731   Route 2.2.2.2/32 has been refreshed
    Aug  2 08:59:56.035760   Considering autosummary for 2.2.2.2/32, summary possible=1
    Aug  2 08:59:56.035784   Considering NSSA autosummary for 2.2.2.2/32, summary not possible
    Aug  2 08:59:56.035820   Manual summary 38.87.38.0/29, area 0.0.0.20, route 38.87.38.0/29, metric 16777215->1
    Aug  2 08:59:56.035856   Route 38.87.38.0/29 has been refreshed
    Aug  2 08:59:56.035883   Considering autosummary for 38.87.38.0/29, summary possible=1
    Aug  2 08:59:56.035907   Considering NSSA autosummary for 38.87.38.0/29, summary not possible
    Aug  2 08:59:56.035940 SPF post spf cleanup finished
    Aug  2 08:59:56.035970  Cleanup elapsed time 0.000385s
    Aug  2 08:59:56.035993    Total elapsed time 0.001268s
    Aug  2 08:59:56.036015 Finished full SPF refresh for topology default
    Aug  2 08:59:56.036040 task_job_delete: delete background job Route recalc timer for task OSPF
    Aug  2 08:59:56.036077 background dispatch completed job Route recalc timer for task OSPF
    Aug  2 08:59:56.521668 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.521750 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.521808 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:56
    Aug  2 08:59:56.521848 Received OSPF packet of type and wire_length 1, 48
    Aug  2 08:59:56.521878 OSPF rcvd Hello 192.168.1.1 -> 224.0.0.5 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 08:59:56.521928   Version 2, length 48, ID 192.168.1.1, area 0.0.0.20
    Aug  2 08:59:56.521951   checksum 0x0, authtype 0
    Aug  2 08:59:56.521973   mask 255.255.255.248, hello_ivl 10, opts 0x2, prio 1
    Aug  2 08:59:56.521994   dead_ivl 40, DR 192.168.1.6, BDR 192.168.1.1
    Aug  2 08:59:56.522014   neighbor 192.168.1.6
    Aug  2 08:59:56.522046 OSPF restart signaling: Received hello with LR bit set from nbr ip=192.168.1.1 id=192.168.1.1. Set oob-resync capabilty 0.
    Aug  2 08:59:56.522085 OSPF restart signaling:Save_packet length 48 :
    Aug  2 08:59:56.522126 task_job_create_background: create prio 1 job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.522178 background dispatch running job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.522226 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:36
    Aug  2 08:59:56.522275 task_job_delete: delete background job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.522323 background dispatch completed job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.522571 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.522635 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 08:59:56.522685 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:01:56
    Aug  2 08:59:56.522714 OSPF neighbor 192.168.1.1 (IFL 67, area 0.0.0.20, rtbl idx 0) set, 40 0
    Aug  2 08:59:57.335683 OSPF resend last DBD to 192.168.1.1
    Aug  2 08:59:57.335790 task_timer_uset: timer OSPF_Global xmit timer <Touched> set to interval 0.040000 jitter 10 at 8:59:57
    Aug  2 08:59:57.335821 task_timer_expire_immediately: timer OSPF_Global xmit timer set to expire now
    Aug  2 08:59:57.335844 OSPF retransmitting DBD to 192.168.1.1
    Aug  2 08:59:57.335884 OSPF sent DbD 192.168.1.6 -> 192.168.1.1 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 08:59:57.335952   Version 2, length 32, ID 192.168.1.6, area 0.0.0.20
    Aug  2 08:59:57.335978   options 0x52, i 1, m 1, ms 1, r 0, seq 0x26502402, mtu 1508
    Aug  2 08:59:57.336000 OSPF restart signaling: Add LLS data for DbD packet on interface reth0.0.
    Aug  2 08:59:57.336043 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:37
    Aug  2 08:59:57.336094 task_timer_reset: reset OSPF_DBD rexmit
    Aug  2 08:59:57.336127 task_timer_set_oneshot_latest: timer OSPF_DBD rexmit interval set to 4.881794
    Aug  2 08:59:57.372658 task_timer_reset: reset OSPF_Global xmit timer
    Aug  2 09:00:02.219216 OSPF resend last DBD to 192.168.1.1
    Aug  2 09:00:02.219323 task_timer_uset: timer OSPF_Global xmit timer <Touched> set to interval 0.040000 jitter 10 at 9:00:02
    Aug  2 09:00:02.219354 task_timer_expire_immediately: timer OSPF_Global xmit timer set to expire now
    Aug  2 09:00:02.219375 OSPF retransmitting DBD to 192.168.1.1
    Aug  2 09:00:02.219415 OSPF sent DbD 192.168.1.6 -> 192.168.1.1 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 09:00:02.219440   Version 2, length 32, ID 192.168.1.6, area 0.0.0.20
    Aug  2 09:00:02.219463   options 0x52, i 1, m 1, ms 1, r 0, seq 0x26502402, mtu 1508
    Aug  2 09:00:02.219485 OSPF restart signaling: Add LLS data for DbD packet on interface reth0.0.
    Aug  2 09:00:02.219529 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:42
    Aug  2 09:00:02.219581 task_timer_reset: reset OSPF_DBD rexmit
    Aug  2 09:00:02.219611 task_timer_set_oneshot_latest: timer OSPF_DBD rexmit interval set to 4.731876
    Aug  2 09:00:02.258206 task_timer_reset: reset OSPF_Global xmit timer
    Aug  2 09:00:03.149445 OSPF neighbor 192.168.1.1 (realm ospf-v2 reth0.0 area 0.0.0.20) state changed from ExStart to Down due to KillNbr (event reason: command to clear a neighbor was issued) (nbr helped: 0)
    Aug  2 09:00:03.149604 RPD_OSPF_NBRDOWN: OSPF neighbor 192.168.1.1 (realm ospf-v2 reth0.0 area 0.0.0.20) state changed from ExStart to Down due to KillNbr (event reason: command to clear a neighbor was issued)
    Aug  2 09:00:03.149683 task_job_create_background: create prio 4 job Interface event for task OSPF
    Aug  2 09:00:03.149708 OSPF Interface event job created at restart phase 0.
    Aug  2 09:00:03.149746 task_job_create_background: create prio 1 job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.149785 task_timer_delete: OSPF_DBD rexmit <Touched>
    Aug  2 09:00:03.149815 OSPF 192.168.1.1 DBD cleanup complete
    Aug  2 09:00:03.149845 task_timer_delete: OSPF_Grace timer <>
    Aug  2 09:00:03.149876 task_timer_delete: OSPF_Neighbor rexmit <>
    Aug  2 09:00:03.149901 task_timer_delete: OSPF_resync timeout <>
    Aug  2 09:00:03.149925 task_timer_delete: OSPF_resync timeout <>
    Aug  2 09:00:03.150022 background dispatch running job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.150072 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:43
    Aug  2 09:00:03.150136 task_job_delete: delete background job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.150168 background dispatch completed job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.150212 background dispatch running job Interface event for task OSPF
    Aug  2 09:00:03.150241 Interface reth0.0 area 0.0.0.20 event NeighborChange
    Aug  2 09:00:03.150656 task_job_create_background: create prio 1 job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.150689 Interface reth0.0 (192.168.1.6) area 0.0.0.20 state changed from DR to DR
    Aug  2 09:00:03.150717 OSPF DR is 192.168.1.6, BDR is 0.0.0.0
    Aug  2 09:00:03.150747 ospf_set_lsdb_state: Router LSA 192.168.1.6 adv-rtr 192.168.1.6 state QUIET->GEN_PENDING
    Aug  2 09:00:03.150775 task_timer_reset: reset OSPF_LSA gen
    Aug  2 09:00:03.150807 task_timer_uset: timer OSPF_LSA gen <Touched> set to offset 0.050000 at 9:00:03
    Aug  2 09:00:03.150831 OSPF trigger router LSA 0x13b80e8 build for area 0.0.0.20 lsa-id 192.168.1.6
    Aug  2 09:00:03.150874 ospf_trigger_build_telink_lsas : No peer found
    Aug  2 09:00:03.150901 OSPF Interface event job processed 1 events.
    Aug  2 09:00:03.150921 OSPF Interface event job deleted.
    Aug  2 09:00:03.150942 task_job_delete: delete background job Interface event for task OSPF
    Aug  2 09:00:03.150967 background dispatch completed job Interface event for task OSPF
    Aug  2 09:00:03.151010 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.151069 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.151119 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:02:03
    Aug  2 09:00:03.151148 OSPF neighbor 192.168.1.1 (IFL 67, area 0.0.0.20, rtbl idx 0) deleted
    Aug  2 09:00:03.151201 background dispatch running job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.151231 OSPF restart signaling: set L bit in hellos sent on interface reth0.0.
    Aug  2 09:00:03.152386 OSPF sent Hello 192.168.1.6 -> 224.0.0.5 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 09:00:03.152416   Version 2, length 44, ID 192.168.1.6, area 0.0.0.20
    Aug  2 09:00:03.152440   mask 255.255.255.248, hello_ivl 10, opts 0x12, prio 128
    Aug  2 09:00:03.152460   dead_ivl 40, DR 192.168.1.6, BDR 0.0.0.0
    Aug  2 09:00:03.152482 OSPF restart signaling: Add LLS data for Hello packet on interface reth0.0.
    Aug  2 09:00:03.152524 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:43
    Aug  2 09:00:03.152573 task_job_delete: delete background job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.152604 background dispatch completed job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.154668 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.154729 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:03.154781 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:02:03
    Aug  2 09:00:03.154826 OSPF programmed periodic xmit from 192.168.1.6 to 224.0.0.5 (IFL 67, area 0.0.0.20, ID 0.0.0.0, rtbl idx 0) interval 10 0
    Aug  2 09:00:03.201308 ospf_set_lsdb_state: Router LSA 192.168.1.6 adv-rtr 192.168.1.6 state GEN_PENDING->QUIET
    Aug  2 09:00:03.201354 OSPF built router LSA, area 0.0.0.20, link count 3
    Aug  2 09:00:03.201384 Clear inverse links started for area 0.0.0.20 Router lsa id 192.168.1.6 adv rtr 192.168.1.6
    Aug  2 09:00:03.201409 Clear inverse links finished for area 0.0.0.20 Router lsa id 192.168.1.6 adv rtr 192.168.1.6
    Aug  2 09:00:03.201434 task_timer_reset: reset OSPF_LSA gen
    Aug  2 09:00:03.201465 task_timer_uset: timer OSPF_LSA gen <Touched Processing> set to offset 50:00 at 9:50:03
    Aug  2 09:00:03.201496 LSA Router 192.168.1.6 192.168.1.6 flood state Idle -> Idle, new LSA
    Aug  2 09:00:03.201524 task_timer_reset: reset OSPF_LSA age
    Aug  2 09:00:03.201550 task_timer_set_oneshot_latest: timer OSPF_LSA age interval set to 1:00:00
    Aug  2 09:00:03.201580 LSA analysis started for area 0.0.0.20 Router lsa id 192.168.1.6 adv rtr 192.168.1.6
    Aug  2 09:00:03.201604 LSA analysis finished for area 0.0.0.20 Router lsa id 192.168.1.6 adv rtr 192.168.1.6
    Aug  2 09:00:03.201627 Setup inverse links started for area 0.0.0.20 Router lsa id 192.168.1.6 adv rtr 192.168.1.6
    Aug  2 09:00:03.201650 Setup inverse links finished for area 0.0.0.20 Router lsa id 192.168.1.6 adv rtr 192.168.1.6
    Aug  2 09:00:03.201675 LSA Router 192.168.1.6 192.168.1.6 flood state Idle -> Standby send, flooding
    Aug  2 09:00:03.201697 Updating LSA Router 192.168.1.6 192.168.1.6 (flood state Standby send)
    Aug  2 09:00:03.201720 LSA Router 192.168.1.6 192.168.1.6 flood state Standby send -> Wait nbr ack, not queued
    Aug  2 09:00:03.201742 OSPF flooding restarted, depth 1, rexmit 0
    Aug  2 09:00:03.201767 task_job_create_background: create prio 3 job OSPF flood for task OSPF
    Aug  2 09:00:03.201815 background dispatch running job OSPF flood for task OSPF
    Aug  2 09:00:03.201842 task_timer_reset: reset OSPF_Flood timer
    Aug  2 09:00:03.201889 OSPF LSA Router 192.168.1.6 192.168.1.6 on no lo0.0 area 0.0.0.20 rexmit lists, no flood
    Aug  2 09:00:03.201916 OSPF LSA Router 192.168.1.6 192.168.1.6 on no reth0.0 area 0.0.0.20 rexmit lists, no flood
    Aug  2 09:00:03.201940 LSA Router 192.168.1.6 192.168.1.6 flood state Wait nbr ack -> Idle, not queued
    Aug  2 09:00:03.201964 task_job_delete: delete background job OSPF flood for task OSPF
    Aug  2 09:00:03.201999 background dispatch completed job OSPF flood for task OSPF
    Aug  2 09:00:04.822477 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.822596 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.822651 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:02:04
    Aug  2 09:00:04.822691 Received OSPF packet of type and wire_length 1, 48
    Aug  2 09:00:04.822720 OSPF rcvd Hello 192.168.1.1 -> 224.0.0.5 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 09:00:04.822743   Version 2, length 48, ID 192.168.1.1, area 0.0.0.20
    Aug  2 09:00:04.822763   checksum 0x0, authtype 0
    Aug  2 09:00:04.822784   mask 255.255.255.248, hello_ivl 10, opts 0x2, prio 1
    Aug  2 09:00:04.822805   dead_ivl 40, DR 192.168.1.1, BDR 0.0.0.0
    Aug  2 09:00:04.822824   neighbor 192.168.1.6
    Aug  2 09:00:04.822872 task_timer_ucreate: created timer OSPF_Neighbor rexmit  flags <>
    Aug  2 09:00:04.822904 task_timer_ucreate: created timer OSPF_resync timeout  flags <>
    Aug  2 09:00:04.822929 task_timer_ucreate: created timer OSPF_resync timeout  flags <>
    Aug  2 09:00:04.822957 task_timer_ucreate: created timer OSPF_Grace timer  flags <>
    Aug  2 09:00:04.822994 task_job_create_background: create prio 1 job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.823025 OSPF neighbor 192.168.1.1 (realm ospf-v2 reth0.0 area 0.0.0.20) state changed from Down to Init due to HelloRcvd (event reason: Hello message received) (nbr helped: 0)
    Aug  2 09:00:04.823057 OSPF restart signaling: Received hello with LR bit set from nbr ip=192.168.1.1 id=192.168.1.1. Set oob-resync capabilty 0.
    Aug  2 09:00:04.823116 OSPF neighbor 192.168.1.1 (realm ospf-v2 reth0.0 area 0.0.0.20) state changed from Init to ExStart due to 2WayRcvd (event reason: neighbor detected this router) (nbr helped: 0)
    Aug  2 09:00:04.823247 RPD_OSPF_NBRUP: OSPF neighbor 192.168.1.1 (realm ospf-v2 reth0.0 area 0.0.0.20) state changed from Init to ExStart due to 2WayRcvd (event reason: neighbor detected this router)
    Aug  2 09:00:04.823283 task_job_create_background: create prio 4 job Interface event for task OSPF
    Aug  2 09:00:04.823306 OSPF Interface event job created at restart phase 0.
    Aug  2 09:00:04.823336 1400 Max dbd packet
    Aug  2 09:00:04.823365 OSPF restart signaling: Send DBD with LR bit on to nbr ip=192.168.1.1 id=192.168.1.1.
    Aug  2 09:00:04.823413 task_timer_uset: timer OSPF_Global xmit timer <Touched> set to interval 0.040000 jitter 10 at 9:00:04
    Aug  2 09:00:04.823443 task_timer_expire_immediately: timer OSPF_Global xmit timer set to expire now
    Aug  2 09:00:04.823472 OSPF restart signaling:Save_packet length 48 :
    Aug  2 09:00:04.823517 task_timer_ucreate: created timer OSPF_DBD rexmit  flags <>
    Aug  2 09:00:04.823553 task_timer_reset: reset OSPF_DBD rexmit
    Aug  2 09:00:04.823583 task_timer_set_oneshot_latest: timer OSPF_DBD rexmit interval set to 4.854189
    Aug  2 09:00:04.823648 background dispatch running job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.823698 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:44
    Aug  2 09:00:04.823746 OSPF restart signaling: set L bit in hellos sent on interface reth0.0.
    Aug  2 09:00:04.823778 OSPF sent Hello 192.168.1.6 -> 224.0.0.5 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 09:00:04.823801   Version 2, length 48, ID 192.168.1.6, area 0.0.0.20
    Aug  2 09:00:04.823823   mask 255.255.255.248, hello_ivl 10, opts 0x12, prio 128
    Aug  2 09:00:04.823844   dead_ivl 40, DR 192.168.1.6, BDR 0.0.0.0
    Aug  2 09:00:04.823863   neighbor 192.168.1.1
    Aug  2 09:00:04.823886 OSPF restart signaling: Add LLS data for Hello packet on interface reth0.0.
    Aug  2 09:00:04.823953 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:44
    Aug  2 09:00:04.823999 OSPF sent DbD 192.168.1.6 -> 192.168.1.1 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 09:00:04.824024   Version 2, length 32, ID 192.168.1.6, area 0.0.0.20
    Aug  2 09:00:04.824047   options 0x52, i 1, m 1, ms 1, r 0, seq 0x2651c16e, mtu 1508
    Aug  2 09:00:04.824069 OSPF restart signaling: Add LLS data for DbD packet on interface reth0.0.
    Aug  2 09:00:04.824107 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:44
    Aug  2 09:00:04.824155 task_job_delete: delete background job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.824185 background dispatch completed job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.824228 background dispatch running job Interface event for task OSPF
    Aug  2 09:00:04.824257 Interface reth0.0 area 0.0.0.20 event NeighborChange
    Aug  2 09:00:04.824289 task_job_create_background: create prio 1 job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.824320 Interface reth0.0 (192.168.1.6) area 0.0.0.20 state changed from DR to DR
    Aug  2 09:00:04.824347 OSPF DR is 192.168.1.6, BDR is 0.0.0.0
    Aug  2 09:00:04.825175 OSPF Interface event job processed 1 events.
    Aug  2 09:00:04.825204 OSPF Interface event job deleted.
    Aug  2 09:00:04.825228 task_job_delete: delete background job Interface event for task OSPF
    Aug  2 09:00:04.825253 background dispatch completed job Interface event for task OSPF
    Aug  2 09:00:04.825298 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.825355 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.825408 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:02:04
    Aug  2 09:00:04.825439 OSPF neighbor 192.168.1.1 (IFL 67, area 0.0.0.20, rtbl idx 0) set, 40 0
    Aug  2 09:00:04.825506 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.825564 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.825613 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:02:04
    Aug  2 09:00:04.825641 OSPF programmed periodic xmit from 192.168.1.6 to 224.0.0.5 (IFL 67, area 0.0.0.20, ID 0.0.0.0, rtbl idx 0) interval 10 0
    Aug  2 09:00:04.825696 background dispatch running job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.825724 OSPF restart signaling: set L bit in hellos sent on interface reth0.0.
    Aug  2 09:00:04.825752 OSPF sent Hello 192.168.1.6 -> 224.0.0.5 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 09:00:04.825776   Version 2, length 48, ID 192.168.1.6, area 0.0.0.20
    Aug  2 09:00:04.825797   mask 255.255.255.248, hello_ivl 10, opts 0x12, prio 128
    Aug  2 09:00:04.825818   dead_ivl 40, DR 192.168.1.6, BDR 0.0.0.0
    Aug  2 09:00:04.825837   neighbor 192.168.1.1
    Aug  2 09:00:04.825858 OSPF restart signaling: Add LLS data for Hello packet on interface reth0.0.
    Aug  2 09:00:04.825898 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:44
    Aug  2 09:00:04.825947 task_job_delete: delete background job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.825987 background dispatch completed job OSPF PPM processing for task OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.826509 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.826570 task_process_events: recv ready for OSPF I/O./var/run/ppmd_control
    Aug  2 09:00:04.826619 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Hold <Touched> set to offset 2:00 at 9:02:04
    Aug  2 09:00:04.826647 OSPF programmed periodic xmit from 192.168.1.6 to 224.0.0.5 (IFL 67, area 0.0.0.20, ID 0.0.0.0, rtbl idx 0) interval 10 0
    Aug  2 09:00:04.864422 task_timer_reset: reset OSPF_Global xmit timer
    Aug  2 09:00:09.678739 OSPF resend last DBD to 192.168.1.1
    Aug  2 09:00:09.678988 task_timer_uset: timer OSPF_Global xmit timer <Touched> set to interval 0.040000 jitter 10 at 9:00:09
    Aug  2 09:00:09.679019 task_timer_expire_immediately: timer OSPF_Global xmit timer set to expire now
    Aug  2 09:00:09.679041 OSPF retransmitting DBD to 192.168.1.1
    Aug  2 09:00:09.679080 OSPF sent DbD 192.168.1.6 -> 192.168.1.1 (reth0.0 IFL 67 area 0.0.0.20)
    Aug  2 09:00:09.679104   Version 2, length 32, ID 192.168.1.6, area 0.0.0.20
    Aug  2 09:00:09.679128   options 0x52, i 1, m 1, ms 1, r 0, seq 0x2651c16e, mtu 1508
    Aug  2 09:00:09.679150 OSPF restart signaling: Add LLS data for DbD packet on interface reth0.0.
    Aug  2 09:00:09.679193 task_timer_uset: timer OSPF I/O./var/run/ppmd_control_PPM Keepalive <Touched> set to offset 40 at 9:00:49
    Aug  2 09:00:09.679247 task_timer_reset: reset OSPF_DBD rexmit
    Aug  2 09:00:09.679278 task_timer_set_oneshot_latest: timer OSPF_DBD rexmit interval set to 4.947050
    Aug  2 09:00:09.718754 task_timer_reset: reset OSPF_Global xmit timer

    Ok 

    •  show chassis cluster status
      Monitor Failure codes:
          CS  Cold Sync monitoring        FL  Fabric Connection monitoring
          GR  GRES monitoring             HW  Hardware monitoring
          IF  Interface monitoring        IP  IP monitoring
          LB  Loopback monitoring         MB  Mbuf monitoring
          NH  Nexthop monitoring          NP  NPC monitoring
          SP  SPU monitoring              SM  Schedule monitoring
          CF  Config Sync monitoring
      
      Cluster ID: 1
      Node   Priority Status         Preempt Manual   Monitor-failures
      
      Redundancy group: 0 , Failover count: 1
      node0  100      primary        no      no       None
      node1  1        secondary      no      no       None
      
      Redundancy group: 1 , Failover count: 1
      node0  0        primary        no      no       IF
      node1  0        secondary      no      no       IF
      


  • 7.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 08-01-2018 19:11

    Hi,

    It looks like both devices are not receiving the DBD packets from the neighbor. SRX traceoptions shows that it is sending DBD packets (mtu 1508) multiple times but not receiving any DBD packets from the neighbor.  DBD packets are unicast packets.

    Are you able to ping SRX to Brocade and Brocade to SRX? Also check the ARP entry for the neighbor ip.

    ping 192.168.1.1 source 192.168.1.6

    show arp no-resolve

    monitor traffic interface reth0.0 no-resolve detail matching "proto 89"



  • 8.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 08-01-2018 20:34

    @Nellikka

    @Nellikka wrote:

    SRX traceoptions shows that it is sending DBD packets (mtu 1508) multiple times but not receiving any DBD packets from the neighbor.  DBD packets are unicast packets.


    @That may be a problem.  I have all the ports from SRX to VDX switch (L2) to CER set to MTU 1526.  Why is OSPF on the SRX still sending out DBD packets @ mtu 1508?  

    The VDXs don't even support mtu that low.  The lowest they will go is 1522.

    set interfaces reth0 description UNTRUST
    set interfaces reth0 mtu 1526
    set interfaces reth0 redundant-ether-options redundancy-group 1
    set interfaces reth0 redundant-ether-options lacp passive
    set interfaces reth0 unit 0 family inet address 192.168.1.6/29

    I am able to ping from SRX to CER and CER to SRX without issue.  There are ARP entries for each other.



  • 9.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-27-2018 01:44
    Spoiler
    depending on encapsulation type and possible amount of vlan headers junos sometimes have a different actual MTU than displayed

    try the value corrected by -8, -4, +4, +8 on one side of the link

    pls tell me if sucessfull

    regards

    alexander

     depending on encapsulation type and possible amount of vlan headers junos sometimes have a diffrent actual MTU than displayed

    try the value corercted by -8, -4, +4, +8 on one side of the link

    pls tell me if sucessfull

    regards

    alexander



  • 10.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-27-2018 09:55

    So I've tried all of these values.  Three of them stop neighbor relationships altogether and 1 of them has the relationship state as '2Way'.



  • 11.  RE: SRX 550 - OSPF Adjacency Stuck in ExStart State

    Posted 07-29-2018 02:06

    Hello,

    Do You have a CoPP filter on Brocade side ?

    If yes have You allowed subnet 192.168.1.0/29 is this filter?

    OSPF DBD exchange is unicast, not multicast.

    HTH

    Thx

    Alex