Routing

Expand all | Collapse all

L3 MPLS it not working with LDP but works with RSVP

Jump to Best Answer
  • 1.  L3 MPLS it not working with LDP but works with RSVP

    Posted 08-23-2018 14:28

    Hello Dears,

    I have the simplest topology

    Lo0 2.2.2.2 MX2 --------MX3 Lo0 3.3.3.3

    And very straighforward configuration which is working if I configure L3 MPLS with RSVP+OSPF TE.

    However if I replace RSVP with LDP it is not working.

    I don't see any bgpl3 routes however I see in hidden route

     

    root@MX3# show |display set
    set version 14.1R4.8
    set system host-name MX3
    set system root-authentication encrypted-password "$1$iheeRDcg$VoBoNwO3Ae6/hHII8mQdE/"
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces ge-0/0/1 unit 0 family inet address 23.0.0.3/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 3.3.3.3/24
    set routing-options autonomous-system 1
    set protocols mpls label-switched-path MX3-MX2 to 23.0.0.2
    set protocols mpls interface ge-0/0/1.0
    set protocols bgp group INTERNAL-PEERS type internal
    set protocols bgp group INTERNAL-PEERS family inet-vpn unicast
    set protocols bgp group INTERNAL-PEERS neighbor 23.0.0.2
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0 neighbor 23.0.0.2
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface all
    set protocols ldp session 23.0.0.2
    set protocols lldp interface all
    set policy-options policy-statement EXPORT term 1 from protocol direct
    set policy-options policy-statement EXPORT term 1 then community add COM-EXPORT
    set policy-options policy-statement EXPORT term 1 then accept
    set policy-options policy-statement EXPORT term 2 then reject
    set policy-options policy-statement IMPORT term 1 from protocol bgp
    set policy-options policy-statement IMPORT term 1 from community COM-IMPORT
    set policy-options policy-statement IMPORT term 1 then accept
    set policy-options policy-statement IMPORT term 2 then reject
    set policy-options community COM-EXPORT members target:2:2
    set policy-options community COM-IMPORT members target:1:1
    set routing-instances VRF instance-type vrf
    set routing-instances VRF interface lo0.0
    set routing-instances VRF route-distinguisher 3:3
    set routing-instances VRF vrf-import IMPORT
    set routing-instances VRF vrf-export EXPORT
    set routing-instances VRF vrf-table-label
    
    root@MX3# run show route
    
    inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    23.0.0.0/24        *[Direct/0] 00:16:32
                        > via ge-0/0/1.0
    23.0.0.3/32        *[Local/0] 00:16:33
                          Local via ge-0/0/1.0
    224.0.0.5/32       *[OSPF/10] 00:17:51, metric 1
                          MultiRecv
    
    VRF.inet.0: 3 destinations, 3 routes (2 active, 0 holddown, 1 hidden)
    + = Active Route, - = Last Active, * = Both
    
    3.3.3.0/24         *[Direct/0] 00:17:47
                        > via lo0.0
    3.3.3.3/32         *[Local/0] 00:17:47
                          Local via lo0.0
    
    mpls.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    0                  *[MPLS/0] 00:17:50, metric 1
                          to table inet.0
    0(S=0)             *[MPLS/0] 00:17:02, metric 1
                          to table mpls.0
    1                  *[MPLS/0] 00:17:50, metric 1
                          Receive
    2                  *[MPLS/0] 00:17:50, metric 1
                          to table inet6.0
    2(S=0)             *[MPLS/0] 00:17:02, metric 1
                          to table mpls.0
    13                 *[MPLS/0] 00:17:50, metric 1
                          Receive
    16                 *[VPN/0] 00:17:50
                          to table VRF.inet.0, Pop
    
    bgp.l3vpn.0: 1 destinations, 1 routes (0 active, 0 holddown, 1 hidden)
    
    [edit]
    root@MX3#
    

    As I mentioned in hidden route I see route which I should see in bgp.l3vpn route

    root@MX3# run show route hidden
    
    inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
    
    VRF.inet.0: 3 destinations, 3 routes (2 active, 0 holddown, 1 hidden)
    + = Active Route, - = Last Active, * = Both
    
    2.2.2.0/24          [BGP/170] 00:15:43, localpref 100, from 23.0.0.2
                          AS path: I, validation-state: unverified
                          Unusable
    
    mpls.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    
    bgp.l3vpn.0: 1 destinations, 1 routes (0 active, 0 holddown, 1 hidden)
    + = Active Route, - = Last Active, * = Both
    
    2:2:2.2.2.0/24
                        [BGP/170] 00:15:43, localpref 100, from 23.0.0.2
                          AS path: I, validation-state: unverified
                          Unusable
    
    [edit]
    root@MX3#
    


  • 2.  RE: L3 MPLS it not working with LDP but works with RSVP

    Posted 08-23-2018 21:24

    This is expected with this config. Try to reconfigure bgp session to use lo0.0 addresses, i.e. 2.2.2.2 <----> 3.3.3.3. 

     



  • 3.  RE: L3 MPLS it not working with LDP but works with RSVP
    Best Answer

    Posted 08-23-2018 21:27

    there should be /32 address of next hop in inet.3 so bgp.l3vpn.0 can use it as next hop. 

    With ldp it is /24 of p2p but with rsvp when you configure to 23.0.0.2, it is install 23.0.0.2/32 in inet.3 vit this lsp. 

     

    P.S. also change mask on lo0.0 to /32 



  • 4.  RE: L3 MPLS it not working with LDP but works with RSVP

    Posted 08-23-2018 23:30

    If works now!!!
    I put lo0.0 loobbacks in main routing table on MX2 & MX3 and created new ones loO.2 on MX2 and loO.3 on MX3.

    Afterwards crated iBGP session between them based on loopbacks and everything started to work.

    Thank you very much!!!