Routing

Expand all | Collapse all

LDP over IPv4/IPv6

Jump to Best Answer
  • 1.  LDP over IPv4/IPv6

    Posted 02-01-2018 01:11

    Hello 

     

    My backbone is dual stack over IPv4 & IPv6. And IPv4 is running on MPLS/LDP.

    Now I hope that IPv6 can run onMPLS/LDP. After refer to the document as follow. I still can't do it successfuly.

    Do I miss something to set up ?

      

    https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/configuring-ldp-native-ipv6-support.html

     

    Thanks

    Cloud


    #IPv6
    #ldp


  • 2.  RE: LDP over IPv4/IPv6

    Posted 02-01-2018 02:11
    Can you paste your LDP configuration? And show version output?

    [edit]
    root@PE1_re# run show ldp neighbor
    Address Interface Label space ID Hold time
    fe80::5668:a3ff:fe1a:37e0 ge-0/0/3.0 172.16.0.22:0 10
    10.0.0.1 ge-0/0/3.0 172.16.0.22:0 14

    [edit]
    root@PE1_re#

    [edit]
    root@PE1_re#

    [edit]
    root@PE1_re# show interfaces lo0
    unit 0 {
    family inet {
    address 172.16.0.11/32;
    }
    family iso {
    address 49.0000.0172.0016.0011.00;
    }
    family inet6 {
    address 2000::172:16:0:11/128;
    }
    }

    [edit]
    root@PE1_re# show protocols ldp
    interface ge-0/0/3.0;
    interface ge-0/0/4.0;
    interface lo0.0;
    family {
    inet6;
    inet;
    }

    [edit]
    root@PE1_re# show interfaces ge-0/0/3.0
    family inet {
    address 10.0.0.0/31;
    }
    family iso;
    family inet6 {
    address 2001::10:0:0:0/127;
    }
    family mpls;

    [edit]
    root@PE1_re#

    [edit]
    root@PE1_re# run show ldp database
    Input label database, 172.16.0.11:0--172.16.0.22:0
    Labels received: 2
    Label Prefix
    299872 172.16.0.11/32
    3 172.16.0.22/32
    3 abcd::128:49:167:96/128
    299872 abcd::128:49:168:1/128

    Output label database, 172.16.0.11:0--172.16.0.22:0
    Labels advertised: 2
    Label Prefix
    3 172.16.0.11/32
    299936 172.16.0.22/32
    299936 abcd::128:49:167:96/128
    3 abcd::128:49:168:1/128

    [edit]
    root@PE1_re#


  • 3.  RE: LDP over IPv4/IPv6

    Posted 02-01-2018 02:30
      |   view attached

    Hello Kingsman

     

    Thanks for your reply. As attachment is my configuration.

    If I remove IPv6 on LDP, the LDP session over IPv4 will be normal as follow.

     

    > show ldp neighbor

    Address                             Interface       Label space ID     Hold time

    212.18.144.8                       lo0.0           212.18.144.8:0      36

    212.18.144.46                      rlt0.0          212.18.144.8:0      11

     

    > show ldp session

      Address                           State       Connection  Hold time  Adv. Mode

    212.18.144.8                       Operational Open          22         DU

     

    > show ldp database

    Input label database, 212.18.144.6:0--212.18.144.8:0

    Labels received: 2

      Label     Prefix

    299936      212.18.144.6/32

          3      212.18.144.8/32

     

    Output label database, 212.18.144.6:0--212.18.144.8:0

    Labels advertised: 2

      Label     Prefix

          3      212.18.144.6/32

    299936      212.18.144.8/32

    Attachment(s)

    rtf
    LDP.rtf   5K 1 version


  • 4.  RE: LDP over IPv4/IPv6

    Posted 02-01-2018 03:07
    Can you enable ldp traceoptions and check what does it show?


  • 5.  RE: LDP over IPv4/IPv6

    Posted 02-04-2018 18:37

    Hi Kingsman

     

    Sorry to reply so late.

     

    As enabled traceoption, I only saw some log as below. 

    Should I enable "family iso " ? 

     

    Feb  2 10:16:15 trace_on: Tracing to "/var/log/ldp" started

    Feb  2 10:18:55.130410 RPD_LDP_NBRDOWN: LDP neighbor 212.18.144.8 (lo0.0) is down

    Feb  2 10:18:55.133500 RPD_LDP_NBRDOWN: LDP neighbor 212.18.144.46 (rlt0.0) is down

    Feb  2 10:18:55.133791 RPD_LDP_SESSIONDOWN: LDP session 212.18.144.8 is down, reason: all adjacencies down

    Feb  2 10:18:55.188162 RPD_LDP_NBRUP: LDP neighbor 212.18.144.46 (rlt0.0) is up

    Feb  5 11:04:30.007105 RPD_LDP_NBRDOWN: LDP neighbor 212.18.144.46 (rlt0.0) is down

    Feb  5 11:04:30.243589 RPD_LDP_NBRUP: LDP neighbor 212.18.144.46 (rlt0.0) is up

    Feb  5 11:04:40.801526 RPD_LDP_NBRDOWN: LDP neighbor 212.18.144.46 (rlt0.0) is down

    Feb  5 11:04:44.243599 RPD_LDP_NBRUP: LDP neighbor 212.18.144.46 (rlt0.0) is up



  • 6.  RE: LDP over IPv4/IPv6
    Best Answer

    Posted 02-04-2018 22:09

    Hi,

     

    Sorry, but had few questions to clarify:

     

    1. As I understand your core interfaces are on rlt- right? What IGP protocol you are running here? Do you have the corresponding IGP session up? If you are using ISIS as the IGP, you need to enable family iso as well.

    2. Do you see IPV6 neighbourship up on rlt-?

    3. The documentation link which you shared initially also talks about enabling "deaggregate" and "transport-preference", have you played it with that and see if that helps?

    4. Here is the example of a working configuration:

     

    https://www.juniper.net/documentation/en_US/junos/topics/example/example-configuring-ldp-native-ipv6-support.html

     

    Thanks



  • 7.  RE: LDP over IPv4/IPv6

    Posted 02-04-2018 22:34

    Hi,

     

    Because I tested on the same router. Therefore,I used logcial system for establising.

     

    My backbone used OSPF3 as IGP for IPv6 and the neoghbor of OSPF is up.

    > show ospf3 neighbor
    ID Interface State Pri Dead
    212.18.144.8 rlt0.0 Full 128 30
    Neighbor-address fe80::3a4f:490f:fc00:13e

     

    As refered your document, "deaggregate" is not working , but "transport-preference ipv4" seems be working.

    I don't know why it is working ?

     

    I ever supposed my firewall filter on loopback that denied connection of LDP, but it wasn't working even removing all filter. 

     

    > show ldp database
    Input label database, 212.18.144.6:0--212.18.144.8:0
    Labels received: 2
    Label Prefix
    299968 212.18.144.6/32
    3 212.18.144.8/32
    3 2001:df1:3100:0:212:18:144:8/128

    Output label database, 212.18.144.6:0--212.18.144.8:0
    Labels advertised: 2
    Label Prefix
    3 212.18.144.6/32
    299968 212.18.144.8/32
    3 2001:df1:3100:0:212:18:144:6/128



  • 8.  RE: LDP over IPv4/IPv6

    Posted 02-04-2018 22:41
    Well, it should have taken ipv4 by-default but glad to know that after hardcoding the transport address, it worked for you.


  • 9.  RE: LDP over IPv4/IPv6

    Posted 02-04-2018 22:56

    Hi,

    As I understand from the documentation, by default the transport mode is IPV6. You need to explicitly configure transport-preference as IPV4 if you want TCP session for IPV6 over IPV4 transport.

     

    You can configure the address family as inet for IPv4 or inet6 for IPv6, or both. If the family address is not configured, then the default address of family inet is enabled. When both IPv4 and IPv6 are configured, you can use the transport-preference statement to configure the prefered transport to be either IPv4 or IPv6. Based on the preference, LDP attempts to establish a TCP connection using IPv4 or IPv6. By default, IPv6 is selected. The dual-transport statement allows Junos OS LDP to establish the TCP connection over IPv4 with IPv4 neighbors, and over IPv6 with IPv6 neighbors as a single-stack LSR. The inet-lsr-id and inet6-lsr-id IDs are the two LSR IDs that have to be configured to establish an LDP session over IPv4 and IPv6 TCP transport. These two IDs should be non-zero and must be configured with different values.

     

    https://www.juniper.net/documentation/en_US/junos/topics/concept/ldp-native-ipv6-support-overview.html

     

    Thanks



  • 10.  RE: LDP over IPv4/IPv6

    Posted 02-04-2018 23:31

    Hi,

     

    I meant with the transport-address and Just to add for the people who read this thread.

     

    It can work without setting the transport-preference as well. just need to make sure that your transport address is reachable.

     

    [edit]
    root@TEST_re# show protocols ldp
    interface ge-0/0/3.0;
    interface ge-0/0/4.0;
    interface lo0.0;
    family {
    inet6;
    inet;
    }

    [edit]
    root@PE1_re#

    [edit]
    root@PE1_re# run show ldp session
    Address State Connection Hold time Adv. Mode
    172.16.0.1 Operational Open 29 DU
    2000::172:16:0:22 Operational Open 28 DU

    [edit]
    root@TEST_re

     

    Input label database, 172.16.0.11:0--172.16.0.22:0
    Labels received: 8
    Label Prefix
    300928 172.16.0.1/32
    300944 172.16.0.2/32
    301024 172.16.0.11/32
    3 172.16.0.22/32
    300960 172.16.0.33/32
    300976 172.16.0.44/32
    300992 172.16.0.201/32
    301008 172.16.0.202/32
    301024 2000::172:16:0:11/128
    3 2000::172:16:0:22/128

    Output label database, 172.16.0.11:0--172.16.0.22:0
    Labels advertised: 8
    Label Prefix
    301056 172.16.0.1/32
    301072 172.16.0.2/32
    3 172.16.0.11/32
    301152 172.16.0.22/32
    301088 172.16.0.33/32
    301104 172.16.0.44/32
    301120 172.16.0.201/32
    301136 172.16.0.202/32
    3 2000::172:16:0:11/128
    301152 2000::172:16:0:22/128

    [edit]
    root@TEST_re#

     

    [edit]
    root@TEST_re# run show ldp neighbor detail
    Address Interface Label space ID Hold time
    10.0.0.1 ge-0/0/3.0 172.16.0.22:0 13
    Transport address: 172.16.0.22, Transport preference: IPv6, Configuration sequence: 19
    Up for 00:05:59
    fe80::5668:a3ff:fe1a:37e0 ge-0/0/3.0 172.16.0.22:0 11
    Transport address: 2000::172:16:0:22, Transport preference: IPv6, Configuration sequence: 19
    Up for 00:06:01
    10.0.0.3 ge-0/0/4.0 172.16.0.1:0 14
    Transport address: 172.16.0.1, Configuration sequence: 1
    Up for 00:06:00

    [edit]
    root@TEST_re# 
    root@TEST_re# run show route table inet6.0 2000::172:16:0:22

    inet6.0: 11 destinations, 14 routes (11 active, 1 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    2000::172:16:0:22/128
    *[LDP/9] 00:06:02, metric 1
    > to fe80::5668:a3ff:fe1a:37e0 via ge-0/0/3.0
    [IS-IS/18] 00:06:07, metric 10
    > to fe80::5668:a3ff:fe1a:37e0 via ge-0/0/3.0

    [edit]
    root@TEST_re#



  • 11.  RE: LDP over IPv4/IPv6

    Posted 02-04-2018 23:42

    Hi,

     

    I think my IPv4 filter will allow ldp going through successfully. So, it is working once "transport-preference ipv4" is done.

     

    The first thing what I need to do is checking my IPv6 filter and see what I need to correct.

     

    Thanks a lot !!