Routing

Expand all | Collapse all

No default route in stub area

Jump to Best Answer
  • 1.  No default route in stub area

    Posted 05-27-2014 11:16

    Dear friends, can't understand simple thing. Let's say I have 2 routers with simple conf:

    R1:

    set interfaces fe-0/0/0.0 family inet address 1.1.1.1/24

    set interfaces lo0.0 family inet address 100.1.1.1/32

    set protocols ospf area 0 interface lo0.0 passive

    set protocols ospf area 1 stub interface fe-0/0/0.0

    R2:

    set interfaces fe-0/0/0.0 family inet address 1.1.1.2/24

    set interfaces lo0.0 family inet address 200.2.2.2/32

    set protocols ospf area 1 stub interface lo0.0 passive

    set protocols ospf area 1 stub interface fe-0/0/0.0

     

    I can't get a default route 0/0 injected by R1 as ABR into stub area 1 on R2. What maybe wrong? Thanks in advance.



  • 2.  RE: No default route in stub area

    Posted 05-27-2014 11:24

    Hello,

     


    @danila.filin wrote:
    What maybe wrong? Thanks in advance.


    Documentation skills?

     

    http://www.juniper.net/techpubs/en_US/junos13.3/topics/topic-map/ospf-stub-and-not-so-stubby-areas.html

     

    default-metric—Configures the ABR to generate a default route with a specified metric into the stub area. This default route enables packet forwarding from the stub area to external destinations. You configure this option only on the ABR. The ABR does not automatically generate a default route when attached to a stub. You must explicitly configure this option to generate a default route.

     

    HTH

    Thanks
    Alex



  • 3.  RE: No default route in stub area

    Posted 05-27-2014 11:33

    Thanks in advance. Tommorow I will check that and kudo you.))

    Unfortunately haven't seen this in several books I read in last 2 weeks..



  • 4.  RE: No default route in stub area

    Posted 05-27-2014 13:20

    Hello,

     


    @danila.filin wrote:

     

    Unfortunately haven't seen this in several books I read in last 2 weeks..



    Not enough books, it seems 🙂

    OSPF "default-metric" is mentioned in:

    1/ JUNOS Enterprise Routing 2nd Ed, page 247,

    2/ JNCIP Study Guide, page 180

    3/ Juniper Networks Reference Guide JUNOS Routing Configuration and Architecture, section 8.4.15

    - and in several other books 

    HTH

    Thanks

    Alex



  • 5.  RE: No default route in stub area

    Posted 05-27-2014 23:56

    Unfortunately, still not helped! Could anyone of you, please, test my simple config and correct where I am wrong?

    How to get a default route on R2?

    Attachment(s)

    txt
    R2showospf.txt   1K 1 version
    txt
    R2.txt   1K 1 version
    txt
    R1showospf.txt   2K 1 version
    txt
    R1.txt   1K 1 version


  • 6.  RE: No default route in stub area

     
    Posted 05-28-2014 00:35

    this is because you don't have any adj with a router in area 0.

     

    on R1(ABR), you have only lo0 in area 0:

     

        ospf {
            area 0.0.0.0 {
                interface lo0.0 {
                    passive;

     

    if R1 would be peering with another router in area 0, then the default route will be generated.

     

     

     

    =====

    If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.



  • 7.  RE: No default route in stub area
    Best Answer

     
    Posted 05-28-2014 01:19

    Active backbone detection can be supressed through hidden: 

    set protocols ospf no-active-backbone   

     

    Best Regards,

    Krasi



  • 8.  RE: No default route in stub area

    Posted 05-28-2014 01:37

    Alleluia! No that works as expected. That was not obviosly at all, and not in books I was reading...

     

    Thank you all very much.



  • 9.  RE: No default route in stub area

    Posted 12-04-2017 20:09

    solved my problem by reading your sentence. Thanks!