Switching

Expand all | Collapse all

QFX3500, Ports with untagged vlan and tagges s-vlan (q-in-q)

  • 1.  QFX3500, Ports with untagged vlan and tagges s-vlan (q-in-q)

    Posted 12 days ago
    Hi!

    For some days now I struggle with QFX3500 on 14.1X53-D54.1.
    I got two into a VC and use LACP for 2-port aggregates.

    Scenario:
    Two servers (say ae24 and ae31) receive untagged frames and reach each other (which internal is vlan-id 160).
    Both servers also need vlan-id 40 which I tagged onto ae24 and ae31 under unit 0.
    VLAN-ID 40 is a stacked vlan, it contains a lot of C-VLANs. Call it a provider network if you like.

    My assumtion:
    Switch should read only SVLAN tag and forward frame to other members regardless of content or CVLAN presence.

    Actually the case:
    Untagged frames: work, traffic flowing
    VLAN 40 frames: work, traffic flowing
    CVLAN inside of VLAN 40: frames are dropped

    # vlans
    set vlans v40 vlan-id 40
    set vlans v160 vlan-id 160
    
    # create ae24 (/ ae31)
    set interfaces ae24 native-vlan-id 160
    set interfaces ae24 mtu 9200
    set interfaces ae24 aggregated-ether-options lacp active
    set interfaces ae24 aggregated-ether-options lacp periodic fast
    set interfaces ae24 aggregated-ether-options lacp force-up
    set interfaces ae24 aggregated-ether-options ethernet-switch-profile tag-protocol-id 0x8100
    set interfaces ae24 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae24 unit 0 family ethernet-switching vlan members 40
    set interfaces ae24 unit 0 family ethernet-switching vlan members 160
    set interfaces ae24 unit 0 family ethernet-switching storm-control default
    
    # slaves ae24 (/ ae31)
    set interfaces xe-0/0/24 ether-options 802.3ad ae24
    set interfaces xe-1/0/24 ether-options 802.3ad ae24
    ​

    I found a rant-post here:
    Juniper, ELS and QinQ

    I also tried to adjust my config like that but the issue seems to be, that I can not create unit 40 while also running an untagged network on unit 0 which is a must.

    The setup I desire is currently working on HP 5130 (vlan 160 untagged with qinq-tunnel as vlan 40).

    What do I need to make this work?

    Thank you in advance.


  • 2.  RE: QFX3500, Ports with untagged vlan and tagges s-vlan (q-in-q)

    Posted 12 days ago
    I moved on to this config:
        ae24 {
            flexible-vlan-tagging;
            native-vlan-id 160;
            mtu 9200;
            encapsulation extended-vlan-bridge;
            aggregated-ether-options {
                lacp {
                    active;
                    periodic fast;
                    force-up;
                }
                ethernet-switch-profile {
                    tag-protocol-id 0x8100;
                }
            }
            unit 0 {
                vlan-id 160;
            }
            unit 40 {
                vlan-id 40;
            }
        }​


    Also I pulled in an external vlan:

        ge-0/0/40 {
            flexible-vlan-tagging;
            mtu 9200;
            encapsulation extended-vlan-bridge;
            unit 40 {
                vlan-id-list 180;
                input-vlan-map push;
                output-vlan-map pop;
            }
        }


    If I dump bond0 on the server attached to ae24, I see incoming frames with 40/180 and I also send out using 40/180.
    The outgoing frames are never received outside of QFX.

    I also tried variations of input-vlan-map / output-vlan-map on ae 24 unit 40 but still broken...

    Kind regards




  • 3.  RE: QFX3500, Ports with untagged vlan and tagges s-vlan (q-in-q)

    Posted 11 days ago
    Looks like it hit this bug:
    https://www.spinics.net/lists/netdev/msg680920.html

    I expected tcpdump on the lowest interface to show me correct data - lesson learned.

    Will try another card, using bnx2x instead of qlcnic - I expect it to work.