Switching

Expand all | Collapse all

Unable to commit xSTP edge interface configuration

Jump to Best Answer
  • 1.  Unable to commit xSTP edge interface configuration

    Posted 07-01-2020 13:46

    Hi.

    I have a completly new ex3400 VC setup where I have issues to commit a configuration with rstp edge configuration set to a interface range.

    The stack consists of 7 x ex3400-48T running JunOS 18.2R3-S4.1.

    If I just take one random interface and issue the command set protocol rstp interface ge-6/0/1 edge and do a commit, the configuration is commited. But if instead do set protocol rstp interface AccessPort-BaseConfig edge and do a commit I get this error message:

     

    error: Unique id allocation failed for '//var/etc/stp_port.id' - no more free ids
    error: Failed to allocate unique port-id for xSTP - likely due to exceeding the number of user configurable STP ports which is 4095
    error: foreign file propagation (ffp) failed
    

    The interface range configuration looks like this:

    interfaces {
        interface-range AccessPort-BaseConfig {
            member-range ge-0/0/0 to ge-6/0/47;
            unit 0 {
                family ethernet-switching {
                    interface-mode access;
                    storm-control default;
                }
            }
        }
    

    This is working on at least two other setups running the smae JunOS version.I have tried to reboot the stack completly, with the same result.

     

    Any ideas?

     

    Best regards,
    Johan Christensson



  • 2.  RE: Unable to commit xSTP edge interface configuration
    Best Answer

     
    Posted 07-01-2020 14:34

    Hi Johan,

     

    This seem to be a known issue, you can find it below,

    https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1366903

     

    The best way to proceed will be changing the ranges to a minor range as the example provided on the PR,

    set interfaces interface-range  jtac-test1 member-range ge-0/0/0 to ge-6/0/47
    set interfaces interface-range jtac-test1 member-range ge-7/0/0 to ge-8/0/47
    set interfaces interface-range jtac-test2 member-range ge-7/0/0 to ge-8/0/47
    set interfaces interface-range jtac-test2 member-range ge-0/0/0 to ge-6/0/47

     

    Pleas try the workaround to double check.

    If this worked for you please mark as "Accepted Solution" so we can help others too 🙂

     

    Best Regards,

    Jeff



  • 3.  RE: Unable to commit xSTP edge interface configuration

     
    Posted 07-01-2020 17:09

    Hi Johan,

     

    Can you please try setting the member range as:

     

    set interfaces interface-range AccessPort-BaseConfig member-range ge-0/0/0 to ge-0/0/47

    set interfaces interface-range AccessPort-BaseConfig member-range ge-1/0/0 to ge-1/0/47

    set interfaces interface-range AccessPort-BaseConfig member-range ge-2/0/0 to ge-2/0/47

    set interfaces interface-range AccessPort-BaseConfig member-range ge-3/0/0 to ge-3/0/47

    set interfaces interface-range AccessPort-BaseConfig member-range ge-4/0/0 to ge-4/0/47

    set interfaces interface-range AccessPort-BaseConfig member-range ge-5/0/0 to ge-5/0/47

    set interfaces interface-range AccessPort-BaseConfig member-range ge-6/0/0 to ge-6/0/47

     

    Also, just to double confirm on the PR mentioned, what is the output for:

     

    show interfaces | display set | display inheritance | count



  • 4.  RE: Unable to commit xSTP edge interface configuration

    Posted 07-02-2020 01:37

    Hi all and thanks for the quick reply.

    After that I changed the interface-range to look like the below, the configuration was commited.

    interfaces {
        interface-range AccessPort-BaseConfig {
            member-range ge-0/0/0 to ge-0/0/47;
            member-range ge-1/0/0 to ge-1/0/47;
            member-range ge-2/0/0 to ge-2/0/47;
            member-range ge-3/0/0 to ge-3/0/47;
            member-range ge-4/0/0 to ge-4/0/47;
            member-range ge-5/0/0 to ge-5/0/47;
            member-range ge-6/0/0 to ge-6/0/47;
            unit 0 {
                family ethernet-switching {
                    interface-mode access;
                    storm-control default;
                }
            }
        }
    


  • 5.  RE: Unable to commit xSTP edge interface configuration

    Posted 07-01-2020 18:20

    Hi Johan,

     

    I believe separating the member ranges to work. This will ensure that the pool size is reduced. You can try splitting up the ports in the below range,

     ge-0/0/0 to ge-6/0/47;

     you can split it up and check if that helps.

     

    Please mark Accepted Solution if this helps you solve your query. Kudos are always appreciated!