Switching

Expand all | Collapse all

Why am I losing link on an ae interface across EX2200 switches in virtual chassis?

Jump to Best Answer
  • 1.  Why am I losing link on an ae interface across EX2200 switches in virtual chassis?

    Posted 12-20-2017 14:19

    Hi all,

     

    Trying to set up an aggregated interface using port 22 on each switch in a 2-switch VChassis. Before I tried setting up the ae interface, both links were up, and the interfaces were in regular L2 access mode. Upon setting up the ae0 interface and adding the ge-[#]/0/22 interfaces to it, I'm seeing that the links (L1) are now down between the switches (the second switch being a Cisco 3550.) 

     

    Do I have to do something further to bring the links up on the Juniper side?

     

    Some possibly helpful data below:

     

    admin@lab-ex2200-stack> show chassis hardware
    Hardware inventory:
    Item             Version  Part number  Serial number     Description
    Chassis                                CW021309xxxx      Virtual Chassis
    Routing Engine 0 REV 22   750-026468   CW021309xxxx      EX2200-24T-4G
    Routing Engine 1 REV 24   750-026468   CW021332xxxx      EX2200-24T-4G
    FPC 0            REV 22   750-026468   CW021309xxxx      EX2200-24T-4G
      CPU                     BUILTIN      BUILTIN           FPC CPU
      PIC 0                   BUILTIN      BUILTIN           24x 10/100/1000 Base-T
      PIC 1          REV 22   750-026468   CW021309xxxx      4x GE SFP
        Xcvr 2                NON-JNPR     P680T5L           SFP-SX
        Xcvr 3       a<       NON-JNPR     01120348          SFP-SX
      Power Supply 0                                         PS 100W AC
      Fan Tray                                               Fan Tray
    FPC 1            REV 24   750-026468   CW021332xxxx      EX2200-24T-4G
      CPU                     BUILTIN      BUILTIN           FPC CPU
      PIC 0                   BUILTIN      BUILTIN           24x 10/100/1000 Base-T
      PIC 1          REV 24   750-026468   CW021332xxxx      4x GE SFP
        Xcvr 2                NON-JNPR     P6A1MNY           SFP-SX
        Xcvr 3                NON-JNPR     P681NF2           SFP-SX
      Power Supply 0                                         PS 100W AC
      Fan Tray                                               Fan Tray
    
    admin@lab-ex2200-stack> show configuration interfaces ge-0/0/22
    ether-options {
        802.3ad ae0;
    }
    
    {master:0}
    admin@lab-ex2200-stack> show configuration interfaces ge-1/0/22
    ether-options {
        802.3ad ae0;
    }
    
    {master:0}
    admin@lab-ex2200-stack> show configuration interfaces ae0
    aggregated-ether-options {
        lacp {
            active;
        }
    }
    unit 0 {
        family ethernet-switching {
            port-mode access;
            vlan {
                members 3;
            }
        }
    }
    
    admin@lab-ex2200-stack> show interfaces ae0 extensive
    Physical interface: ae0, Enabled, Physical link is Down
      Interface index: 128, SNMP ifIndex: 551, Generation: 131
      Link-level type: Ethernet, MTU: 1514, Speed: Unspecified, BPDU Error: None,
      MAC-REWRITE Error: None, Loopback: Disabled, Source filtering: Disabled,
      Flow control: Disabled, Minimum links needed: 1, Minimum bandwidth needed: 0
      Device flags   : Present Running
      Interface flags: Hardware-Down SNMP-Traps Internal: 0x4000
      Current address: 54:e0:32:9a:04:c3, Hardware address: 54:e0:32:9a:04:c3
      Last flapped   : 2016-12-15 17:23:26 UTC (00:51:56 ago)
      Statistics last cleared: Never
      Traffic statistics:
       Input  bytes  :                    0                    0 bps
       Output bytes  :                    0                    0 bps
       Input  packets:                    0                    0 pps
       Output packets:                    0                    0 pps
       IPv6 transit statistics:
        Input  bytes  :                   0
        Output bytes  :                   0
        Input  packets:                   0
        Output packets:                   0
      Input errors:
        Errors: 0, Drops: 0, Framing errors: 0, Runts: 0, Giants: 0,
        Policed discards: 0, Resource errors: 0
      Output errors:
        Carrier transitions: 0, Errors: 0, Drops: 0, MTU errors: 0,
        Resource errors: 0
    
      Logical interface ae0.0 (Index 65) (SNMP ifIndex 607) (Generation 130)
        Flags: Hardware-Down Device-Down SNMP-Traps 0x4000 Encapsulation: ENET2
        Statistics        Packets        pps         Bytes          bps
        Bundle:
            Input :             0          0             0            0
            Output:             0          0             0            0
        Adaptive Statistics:
            Adaptive Adjusts:          0
            Adaptive Scans  :          0
            Adaptive Updates:          0
        Link:
          ge-0/0/22.0 <-- down
          ge-1/0/22.0 <-- down
        LACP info:        Role     System             System      Port    Port  Port
                                 priority          identifier  priority  number   key
          ge-0/0/22.0    Actor        127  54:e0:32:9a:04:c0       127       1     1
          ge-0/0/22.0  Partner          1  00:00:00:00:00:00         1       1     1
          ge-1/0/22.0    Actor        127  54:e0:32:9a:04:c0       127       3     1
          ge-1/0/22.0  Partner          1  00:00:00:00:00:00         1       3     1
        LACP Statistics:       LACP Rx     LACP Tx   Unknown Rx   Illegal Rx
          ge-0/0/22.0                0           0            0            0
          ge-1/0/22.0                0           0            0            0
        Marker Statistics:   Marker Rx     Resp Tx   Unknown Rx   Illegal Rx
          ge-0/0/22.0                0           0            0            0
          ge-1/0/22.0                0           0            0            0
        Protocol eth-switch, Generation: 148, Route table: 0
          Flags: Is-Primary
    
    -=-=-=-=-
    
    SW4-3550#show etherch summ
    Flags:  D - down        P - bundled in port-channel
            I - stand-alone s - suspended
            H - Hot-standby (LACP only)
            R - Layer3      S - Layer2
            U - in use      f - failed to allocate aggregator
    
            M - not in use, minimum links not met
            u - unsuitable for bundling
            w - waiting to be aggregated
            d - default port
    
    
    Number of channel-groups in use: 1
    Number of aggregators:           1
    
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+-----------------------------------------------
    1      Po1(SD)         LACP      Fa0/11(D)   Fa0/12(D)
    
    SW4-3550#sh runn int Fa0/11
    Building configuration...
    
    Current configuration : 113 bytes
    !
    interface FastEthernet0/11
     switchport access vlan 3
     switchport mode access
     channel-group 1 mode active
    end
    
    SW4-3550#sh runn int Fa0/12
    Building configuration...
    
    Current configuration : 113 bytes
    !
    interface FastEthernet0/12
     switchport access vlan 3
     switchport mode access
     channel-group 1 mode active
    end
    
    SW4-3550#sh runn int Po1
    Building configuration...
    
    Current configuration : 81 bytes
    !
    interface Port-channel1
     switchport access vlan 3
     switchport mode access
    end
    

     

     


    #AE
    #ex2200


  • 2.  RE: Why am I losing link on an ae interface across EX2200 switches in virtual chassis?

    Posted 12-21-2017 02:14

    Hi.

     

    You need to define the number of aggregated Ethernet interfaces to be created on the Juniper switch as well (not sure if you have it done):

     

    user@EX2200# set chassis aggregated-devices ethernet device-count 1
    user@EX2200# commit

    Setting the number to 1 allows to create interface ae0.

    The documentation for LAG link on EX series:

     

    https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/link-aggregation-cli.html

    The cabling and speed/duplex can be other culprits. Your post indicates the both links were up as "standalone" links. This should exclude cabling issues.  The vlan 3 does exist in VLAN DB of both switches as well.

    I would try to troubleshooting steps in following order:
    1) define count of aggregated links on EX2200 (see above) and commit

    2) manually define the speed on EX2200 LAG interface (ae0) and Cisco C3550 Po1 to 100Mb/s

    user@EX2200# set interfaces ae0 aggregated-ether-options link-speed 100m
    user@EX2200# commit
    user@C3550(config)# interface Port-channel1
    user@C3550(config-if)# speed 100

    This can however introduces issues (Cisco C3550 doesn't support MDIX, auto-negotiation might be required).

    Hope this helps a bit.

    Regards
    Luděk



  • 3.  RE: Why am I losing link on an ae interface across EX2200 switches in virtual chassis?
    Best Answer

    Posted 12-21-2017 16:48

    Thanks for the helpful reply, Luděk!

     

    I had created the 'ae' interfaces (ae0 - 7) beforehand, so that wasn't it.

     

    However, I went to set the ae0 interface to 100m as you suggested, and Junos carped at me about the underlying interfaces not being set to the same speed, so when I set the phy intf's to 100m and then the ae0 intf to 100m, the candidate config committed, and the links came up! No need to do anything on the Cisco side. Traffic now passing and everything green & clean. Would think auto-config on the Junos side would negotiate 100m, but I guess not (because of the aggregation, I'm guessing - as I said, the int's when not in the agg linked and came up fine at 100m.)



  • 4.  RE: Why am I losing link on an ae interface across EX2200 switches in virtual chassis?

     
    Posted 12-22-2017 01:08

    Hi Folks,

    Just 2 cents on this behavior…

     

    When configuring LAGs, consider the following guidelines:

     

    • The LAG must be configured on both sides of the link.
    • The interfaces on either side of the link must be set to the same speed.
    • You can configure and apply firewall filters on a LAG.
    • LACP can optionally be configured for link negotiation.

     

    https://www.juniper.net/documentation/en_US/junos12.1/topics/concept/interfaces-lag-overview.html