Switching

 View Only
last person joined: yesterday 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Q-in-Q configuration on EX2300

    Posted 09-28-2018 17:12

    Does anyone have a working qinq config they would mind sharing? I have followed direction on this link. I just need to pass tagged and untagged traffic for customer. I dont even need to setup lacp at first. https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/qinq-tunneling-ex-series-cli-els.html

    What ive tried:

    set vlans v1700 interface ge-0/1/0.1700
    set interfaces ge-0/1/0 flexible-vlan-tagging
    set interfaces ge-0/1/0 native-vlan-id 1700
    set interfaces ge-0/1/0 encapsulation extended-vlan-bridge
    set interfaces ge-0/1/0 unit 1700 vlan-id 1700

     

    set vlans v1700 interface ge-0/0/0.1700
    set interfaces ge-0/0/0 flexible-vlan-tagging
    set interfaces ge-0/0/0 encapsulation extended-vlan-bridge
    set interfaces ge-0/0/0 unit 1700 vlan-id-list 1-4094   -I have seen where you can only have 8 vlans here but I just want to allow any vlan for my customer
    set interfaces ge-0/0/0 native-vlan-id 150            -do I have to define a native for the customer interface
    set interfaces ge-0/0/0 unit 1700 input-vlan-map push
    set interfaces ge-0/0/0 unit 1700 output-vlan-map pop

     

    set interfaces ge-0/1/0 description Provider Uplink
    set interfaces ge-0/0/0 description Customer

     

    When I commit I get an error like this:

    [edit protocols rstp]

      'interface'

        XSTP : Interface ge-0/0/0.0 is not enabled for Ethernet Switching

    error: configuration check-out failed

     I have went and added "set interfaces ge-0/0/0 unit 0 family ethernet-switching" as I have seen recommended and get:

    [edit interfaces ge-0/0/0]

      'unit 0'

         VLAN-ID must be specified on tagged ethernet interfaces

    error: configuration check-out failed

     



  • 2.  RE: Q-in-Q configuration on EX2300

     
    Posted 09-29-2018 19:30


  • 3.  RE: Q-in-Q configuration on EX2300

    Posted 07-23-2019 07:05

    ok so I have a config in place and committed but I see traffic coming in but none going out. Not even broadcast from cpe.

    Customer handoff:

    interfaces {

        ge-0/0/0 {

            ge-0/0/0 {
    flexible-vlan-tagging;
    native-vlan-id 450;
    mtu 9216;
    encapsulation extended-vlan-bridge;
    unit 450 {
    vlan-id-list 1-4094;
    input-vlan-map push;
    output-vlan-map pop;

    Uplink to core:

    ge-0/1/1 {             

            description Uplink;
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation extended-vlan-bridge;
    unit 11 {
    vlan-id 11;
    }
    unit 450 {
    vlan-id 450;
    }

     

     

    svlan {
    interface ge-0/1/1.450;
    interface ge-0/0/0.450;
    }
    }

     

    Tried this on ge-0/0/0 and still no traffic and unable to pull dhcp address off cpe

    ether-options {

                  ethernet-switch-profile {

                   tag-protocol-id 0x88a8;



  • 4.  RE: Q-in-Q configuration on EX2300

     
    Posted 07-23-2019 08:14

    Hi hamm11,

     

    You need the TPID on the core facing side, and try to modify it to 0x8100.  Also, can you try to change the unit to other than the 450 (native-vlan)? 

     

    Customer hand-off port:
    ========================
    interfaces {
    ge-0/0/0 {
    flexible-vlan-tagging;
    native-vlan-id 450;
    mtu 9216;
    encapsulation extended-vlan-bridge;
    unit 0 {
    vlan-id-list 1-4094;
    input-vlan-map push;
    output-vlan-map pop;

     

     

    Uplink to core:
    ========================
    ge-0/1/1 {
    description Uplink;
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation extended-vlan-bridge;
    ether-options {
    ethernet-switch-profile {
    tag-protocol-id 0x8100;
    }
    unit 11 {
    vlan-id 11;
    }
    unit 450 {
    vlan-id 450;
    }

     

    Hope this helps.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 5.  RE: Q-in-Q configuration on EX2300

    Posted 07-23-2019 13:57

    I tried putting the TPID on the core facing interface and even tried the native vlan as 1 and still do not seem to be passing the tag. Customer is running EIGRP and when i do a traffic monitor all I see is EIGRP hello messages trying to get back to their metwork.

     

    Showing this in the logs (may be something):

    Jul 23 19:58:03 GTS_Test-2300 dc-pfe: LBCM-L2,pfe_bcm_l2_ing_vlanid_list_xlat_remove(),1307:ING vlan-xlat counter detach failed for ifl idx(554), key_type(9), match-vid(1:4096), vlan-token(5) error(Feature unavailable)
    Jul 23 19:58:03 GTS_Test-2300 dc-pfe: Attempt to free NULL pointer from pc:0x839b00
    Jul 23 19:58:03 GTS_Test-2300 dc-pfe: LBCM-L2,pfe_bcm_l2_evt_entry_unset(),2428:Egress vlan-xlat counter detach failed for(unit 0 hw-token:5, outer-inner(4095:0) port_class:0) (error-msg: Internal error)
    Jul 23 19:58:03 GTS_Test-2300 dc-pfe: LBCM-L2,pfe_bcm_l2_ing_vlanid_list_xlat_program(),945:ING vlan-xlat counter attach failed for ifl idx(570), key_type(9), match-vid(1:4096), vlan-token(5) error(Feature unavailable)
    Jul 23 19:58:03 GTS_Test-2300 dc-pfe: BRCM_COS_HALP(brcm_cos_cn_pfc_disable:686): Failed to set pfc rx using bcm_port_control_set for port 3
    Jul 23 19:58:03 GTS_Test-2300 fpc0 LBCM-L2,pfe_bcm_l2_ing_vlanid_list_xlat_remove(),1307:ING vlan-xlat counter detach failed for ifl idx(554), key_type(9), match-vid(1:4096), vlan-token(5) error(Feature unavailable)
    Jul 23 19:58:03 GTS_Test-2300 fpc0 Attempt to free NULL pointer from pc:0x839b00
    Jul 23 19:58:03 GTS_Test-2300 fpc0 LBCM-L2,pfe_bcm_l2_evt_entry_unset(),2428:Egress vlan-xlat counter detach failed for(unit 0 hw-token:5, outer-inner(4095:0) port_class:0) (error-msg: Internal error)
    Jul 23 19:58:03 GTS_Test-2300 fpc0 LBCM-L2,pfe_bcm_l2_ing_vlanid_list_xlat_program(),945:ING vlan-xlat counter attach failed for ifl idx(570), key_type(9), match-vid(1:4096), vlan-token(5) error(Feature unavailable)

     

     

     



  • 6.  RE: Q-in-Q configuration on EX2300

    Posted 07-23-2019 16:05

    Here is a config that works for me. Have a couple of EX2300 with ELS. One at the customers and one in our office.

    It's strange to me that under vlans you don't see a vlan-id but it is working.

    Model: ex2300-24t
    Junos: 15.1X53-D58.3

    ge-0/0/22 {
    description "Customer Port";
    flexible-vlan-tagging;
    native-vlan-id 104;
    mtu 9216;
    encapsulation extended-vlan-bridge;
    unit 104 {
    vlan-id-list 1-4094;
    input-vlan-map push;
    output-vlan-map pop;
    family ethernet-switching {
    storm-control default;
    }
    }
    }

    ge-0/1/0 {
    ether-options {
    802.3ad ae0;
    }
    }
    ge-0/1/1 {
    ether-options {
    802.3ad ae0;
    }
    }


    ae0 {
    description "Uplink-Lag";
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation extended-vlan-bridge;
    aggregated-ether-options {
    lacp {
    active;
    }
    }
    unit 96 {
    vlan-id 96;
    }
    unit 104 {
    vlan-id 104;
    }
    unit 200 {
    vlan-id 200;
    }
    }

    vlans {
    Vlan_104 {
    description "Customer QinQ"
    interface ae0.104;
    interface ge-0/0/22.104;
    }
    }
    Vlan_96 {
    description "Customer Internet access";
    vlan-id 96;
    interface ae0.96;
    interface ge-0/0/0.96;
    }
    default {
    description "Our Management vlan"
    vlan-id 200;
    interface ae0.200;
    l3-interface irb.200;
    }
    }



  • 7.  RE: Q-in-Q configuration on EX2300

    Posted 07-23-2019 18:54

    Testdog,

    Thanks for the example.

    Is 

    family ethernet-switching {
    storm-control default;

    defined some where else in the config for storm control?

    I see in my packet capture dhcp discovers off one of the customers access ports but not still not pulling an ip address. Going to keep digging.

     



  • 8.  RE: Q-in-Q configuration on EX2300

    Posted 07-23-2019 18:57

    nevermind the 

    family ethernet-switching {
    storm-control default;

    is a default port setting that we had removed.  i did add it back. odd we are not working



  • 9.  RE: Q-in-Q configuration on EX2300

    Posted 07-23-2019 19:00

    i am running latest recommended Junos: 18.1R3-S4.2 but surely not much different



  • 10.  RE: Q-in-Q configuration on EX2300

    Posted 07-26-2019 05:29

    It is a code issue. The config above like my example and testdog is working when I run JUNOS 15.1X53-D58.3 Kernel 32-bit JNPR-11.0-20180119.e26d166_buil that I had factory on a switch. I upgrade to the v18 I listed above and it breaks. Going try try the next up (not jtac recommended) and see if it has been fixed in it before I open TAC case.