Switching

Expand all | Collapse all

Connecting EX4600 to an EX4300 via 40GbE DAC -- NO VCP

Jump to Best Answer
  • 1.  Connecting EX4600 to an EX4300 via 40GbE DAC -- NO VCP

    Posted 05-15-2018 15:43

    Hello!

    So I have searched and have not quite found a solution to my issue here since I DO NOT want an Virtual Chassis .. and there is no VLAN

     

    Issue:

    I have 2x EX4300's (v13.2) (Switch1 and Switch2) connected to each other via a 40GbE DAC ... The ports are set as "access" with auto-negotiate disabled.  They were configured via J-Web and show green as they are connected  (Admin UP .. Link UP)

     

    I have 1x EX4600 (v18.1) connected to Switch2 via a 40GbE DAC and plugged into port 24 on the 4600.   It shows Admin UP .. but Link Down.  I cannot for the life of me figure this out as to how the get the link UP.

     

    The JWeb on 4300 shows "orange" for the connection meaning it recognizes that something is there, but no link.

     

    Any advice would be super appreciated!!!  Thanks

     

    Here is the config for port 24 on the 4600:

    et-0/0/24 {
        mtu 9216;
        ether-options {
            no-auto-negotiation;
            flow-control;
        }
        unit 0 {
            family ethernet-switching {
                interface-mode access;
                inner-vlan {
                    members all;
                }
                storm-control default;
            }
        }
    }
    xe-0/0/24:0 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    xe-0/0/24:1 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    xe-0/0/24:2 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    xe-0/0/24:3 {
        unit 0 {
            family ethernet-switching {
                storm-control default;
            }
        }
    }
    

     



  • 2.  RE: Connecting EX4600 to an EX4300 via 40GbE DAC -- NO VCP

     
    Posted 05-15-2018 17:01

    Is the port on the EX4300 configured to be a virtual chassis uplink?

    show virtual-chassis vc-port

     

    If so, delete it. 

    request virtual-chassis vc-port delete pic-slot 1 port x

     

     



  • 3.  RE: Connecting EX4600 to an EX4300 via 40GbE DAC -- NO VCP

    Posted 05-16-2018 10:57

    Hi

    Thanks for the response ... Neither the 4300 nor the 4600 have VC enabled ... both are disabled.



  • 4.  RE: Connecting EX4600 to an EX4300 via 40GbE DAC -- NO VCP
    Best Answer

     
    Posted 05-16-2018 12:25

    To be clear, even if you've disabled (or not even configured) virtual-chassis in your config, ports will remain virtual chassis uplinks if configured that way. If you've confirmed with the show vc-ports command that they are not vc-ports then I would delete the two et interfaces on both ends and configure as below as a quick test, adding the no-autonegotiation only to the EX4300. There is a autonegotiation bug in at least one of the 14.1X53 versions when connecting to qfx/ex4600, it may also be in 13.x.

     

    EX4300:

    et-0/1/x {                              
        ether-options {
            no-auto-negotiation;
        }
        unit 0 {
            family ethernet-switching;
        }
    }
    

    EX4600:

    et-0/0/24 {                              
        unit 0 {
            family ethernet-switching;
        }
    }
    

     



  • 5.  RE: Connecting EX4600 to an EX4300 via 40GbE DAC -- NO VCP

    Posted 05-16-2018 14:38

    I love you!  That was it!  Thanks so much, you're the best!



  • 6.  RE: Connecting EX4600 to an EX4300 via 40GbE DAC -- NO VCP

     
    Posted 05-16-2018 14:39

    Heart