Switching

Expand all | Collapse all

XSTP : Interface ge-0/0/44 is not enabled for Ethernet Switching

Jump to Best Answer
  • 1.  XSTP : Interface ge-0/0/44 is not enabled for Ethernet Switching

    Posted 03-13-2020 07:02

    Hi,

    We have Model: ex4300-48p Junos: 18.1R3-S6.1

    While i am changing interface range i am getting below error. please suggest, how to fix

     

    SWITCH# run show configuration |display set |match interface-range
    set interfaces interface-range SERVER-PORTS member-range ge-0/0/12 to ge-0/0/45
    set interfaces interface-range SERVER-PORTS unit 0 family ethernet-switching interface-mode access
    set interfaces interface-range ALL-RSTP-ENABLE member-range ge-0/0/12 to ge-0/0/45


    {master:0}[edit]
    SWITCH# delete interfaces interface-range SERVER-PORTS member-range ge-0/0/12 to ge-0/0/45

    {master:0}[edit]
    SWITCH# set interfaces interface-range SERVER-PORTS member-range ge-0/0/12 to ge-0/0/43

    {master:0}[edit]
    SWITCH# commit check
    [edit protocols rstp]
    'interface'
    XSTP : Interface ge-0/0/44 is not enabled for Ethernet Switching
    error: configuration check-out failed

     

    --> Once this error get clear i will push below config

    set interfaces ge-0/0/44 unit 0 family inet no-redirects
    set interfaces ge-0/0/44 unit 0 family inet address 10.12.17.3/30
    set protocols ospf area 0.0.0.0 interface ge-0/0/44.0


    #EthernetSwitching


  • 2.  RE: XSTP : Interface ge-0/0/44 is not enabled for Ethernet Switching

     
    Posted 03-13-2020 07:38

    Interface ge-0/0/44 is configured to participate in rstp under protocols rstp, either by explicit reference or via interface all. If you want to change it to a layer 3 interface you need to remove it from rstp.



  • 3.  RE: XSTP : Interface ge-0/0/44 is not enabled for Ethernet Switching
    Best Answer

    Posted 03-13-2020 09:11

    Hi Target,

     

    yes, the problem is that you have configured the interface for spanning tree, but the interface is not a family "ethernet-switching" interface, it is a "family inet" interface  and this are mutually exclusive and it will not allow you to have 'rstp' or any other flavor of spanning tree to the interface, hence the commit error

     

    try checking the configuration and delete the statements of all the interfaces that may be needed to avoid the error.

    # show protocols | display set | match stp

     

    Cheers,

     

    Benjamin

     



  • 4.  RE: XSTP : Interface ge-0/0/44 is not enabled for Ethernet Switching

     
    Posted 03-13-2020 09:19

    @Target - if you want both xSTP and L3 on this interface, configure an IRB (family ethernet-switching add interface) and then create irb.xx, instead of you current config of L3 on the physical interface (family inet).