Switching

Expand all | Collapse all

Troubleshooting error message

  • 1.  Troubleshooting error message

    Posted 04-10-2017 07:34

    I have two EX4300 switchs in a stack. When I first got them I had them lincked usinging optic calbles, they are now using the standard stackign cabels, and only xe-0/2/2-3 & 1/2/2-3 are configured. So I was suporsed to see the error below shoing a failed connnecion:

     

    Apr 10 09:16:23 pfex: Link 51 FAILED
    Apr 10 09:16:23 pfex: [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 1 of Pic 2
    Apr 10 09:16:23 fpc0 Link 51 FAILED
    Apr 10 09:16:23 fpc0 [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 1 of Pic 2
    Apr 10 09:16:24 fpc1 Link 50 FAILED
    Apr 10 09:16:24 fpc1 [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 0 of Pic 2
    Apr 10 09:16:24 fpc1 Link 51 FAILED
    Apr 10 09:16:24 fpc1 [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 1 of Pic 2
    Apr 10 09:16:24 pfex: Link 50 FAILED
    Apr 10 09:16:24 pfex: [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 0 of Pic 2
    

    The slots look fine

    > show chassis pic fpc-slot 0 pic-slot 2
    FPC slot 0, PIC slot 2 information:
      Type                             4x 1G/10G SFP/SFP+
      State                            Online
      PIC version                  3.2
      Uptime                         56 days, 20 hours, 24 minutes, 38 seconds
    
    PIC port information:
                             Fiber                    Xcvr vendor       Wave-    Xcvr
      Port Cable type        type  Xcvr vendor        part number       length   Firmware
      3    10GBASE AOC 10M   n/a   JUNIPER-FINISAR    FCBG110SD1C10-J1  1024 nm  0.0
    
    > show chassis pic fpc-slot 1 pic-slot 2
    FPC slot 1, PIC slot 2 information:
      Type                             4x 1G/10G SFP/SFP+
      State                            Online
      PIC version                  3.2
      Uptime                         56 days, 20 hours, 24 minutes, 38 seconds
    
    PIC port information:
                             Fiber                    Xcvr vendor       Wave-    Xcvr
      Port Cable type        type  Xcvr vendor        part number       length   Firmware
      3    10GBASE AOC 10M   n/a   JUNIPER-FINISAR    FCBG110SD1C10-J1  1024 nm  0.0
    

    I also confirmed that the ports wer no longer used as vc-ports and were unconfigured. 

    > show configuration interfaces xe-0/2/1 | display inheritance
    
    {master:0}
    > show configuration interfaces xe-1/2/0 | display inheritance
    
    {master:0}
    
    > show virtual-chassis vc-port
    fpc0:
    --------------------------------------------------------------------------
    Interface   Type              Trunk  Status       Speed        Neighbor
    or                             ID                 (mbps)       ID  Interface
    PIC / Port
    1/0         Configured          6    Up           40000        1   vcp-255/1/1
    1/1         Configured          6    Up           40000        1   vcp-255/1/0
    1/3         Configured               Absent
    1/2         Configured               Absent
    
    fpc1:
    --------------------------------------------------------------------------
    Interface   Type              Trunk  Status       Speed        Neighbor
    or                             ID                 (mbps)       ID  Interface
    PIC / Port
    1/0         Configured          6    Up           40000        0   vcp-255/1/1
    1/1         Configured          6    Up           40000        0   vcp-255/1/0
    1/2         Configured               Absent
    1/3         Configured               Absent
    

    I am open to any additional guidance on where to look next for the source of these errors.



  • 2.  RE: Troubleshooting error message

     
    Posted 04-16-2017 07:20

    You seem to have done all the necessary configuration items.  I assume you have already tried removing and reseating the DAC connection to reset it.

     

    I suspect a hardware issue.

     

    Can you try rotating the cable to another port and try using a different optic in these ports.  This will see if the issue follows the cable or stays with the port.



  • 3.  RE: Troubleshooting error message

     
    Posted 04-21-2017 05:50

    Oddly, I have started getting the exact same message on an interface that has no SFP inserted. Juniper advised it was harmless and to filter the message. This is the only switch I have that does this. Upgrading to 14.1X53-D42.3 (or the reboot) resolved it.



  • 4.  RE: Troubleshooting error message

    Posted 04-26-2017 21:44

    Apr 10 09:16:23 pfex: [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 1 of Pic 2
    Apr 10 09:16:23 fpc0 Link 51 FAILED
    Apr 10 09:16:23 fpc0 [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 1 of Pic 2
    Apr 10 09:16:24 fpc1 Link 50 FAILED
    Apr 10 09:16:24 fpc1 [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 0 of Pic 2
    Apr 10 09:16:24 fpc1 Link 51 FAILED
    Apr 10 09:16:24 fpc1 [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 1 of Pic 2
    Apr 10 09:16:24 pfex: Link 50 FAILED
    Apr 10 09:16:24 pfex: [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 0 of Pic 2

     

    These messages can be ignored. We have seen situation where these messages come without an optics plugged in.



  • 5.  RE: Troubleshooting error message

     
    Posted 04-29-2017 02:42

    Is there a PR on this yet then?

     

    I don't see one in a search of the public PR database.  



  • 6.  RE: Troubleshooting error message

    Posted 05-04-2017 21:13

    HI

    By any chance is this LX10?


    This SFP LX10 is not qualified on EX4300.

    Example


    IC 2          REV 04   611-044925   MY3713480373      4x 1G/10G SFP/SFP+
        Xcvr 0       REV 01   740-011614   AC0804S00QL       SFP-LX10          <<<<<<<<<<<<<<<<<<<<<<<<<<<<<  SFP module could be installed normal

    May 31 12:48:08  EX43-73.206 pfex: [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 3 of Pic 2
    May 31 12:48:08  EX43-73.206 pfex: [EX-BCM PIC] ex_bcm_pic_periodic_raw: Error in Optic periodic functionfor pic slot 2
    May 31 12:48:09  EX43-73.206 pfex: [EX-BCM PIC] ex_bcm_pic_optics_periodic: Failed to read eeprom of Optic 3 of Pic 2


    Thanks

    Partha