Switching

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  show system switchover command missing in 11.1R1

    Posted 04-14-2011 00:43

    I'm setting up a pair of new EX4500es in a VC. Attempted to configure GRES, but the status command that used to work in earlier versions, and that is clearly documented in the Junos OS 11.1 High Availability Configuration Guide, does not work:

     

     

    {master:0}
    root@cs1-osl2> show configuration chassis redundancy 
    graceful-switchover;
    
    {master:0}
    root@cs1-osl2> show system switchover
                               ^
    syntax error, expecting <command>.

     

     

    Any idea how to check if GRES is working properly or not?

     

    Tore


    #ex4500
    #GRES
    #VC
    #11.1R1


  • 2.  RE: show system switchover command missing in 11.1R1

    Posted 04-14-2011 00:56

    I don't have 4500, only 4200 but this worked on later releases. Currently have only 10.0 to test and "check" command isn't showing notice or timer that graceful switchover could be done.

     

    request chassis routing-engine master switch check

    and

    request chassis routing-engine master switch



  • 3.  RE: show system switchover command missing in 11.1R1

    Posted 04-14-2011 01:14

    Humm..

     

     

    root@cs1-osl2> request chassis routing-engine master switch check 
    
    {master:0}
    root@cs1-osl2> 

     

    The switch command works but I don't know if GRES does what it supposed to do or not.

     

    Tore



  • 4.  RE: show system switchover command missing in 11.1R1
    Best Answer

    Posted 04-14-2011 01:31

    Hi,

     

    http://www.juniper.net/techpubs/en_US/junos9.5/topics/task/verification/virtual-chassis-gres-verifying.html

    you should connect to backup switch (your master is now 0, so request session member 1 <= backup). And then issue command show system switchover. I was not able to issue that command on master. Same as you.

     

     

    {master:0}
    user@switch> request session member 1

     

     

     

     

     



  • 5.  RE: show system switchover command missing in 11.1R1

    Posted 04-14-2011 01:36

    Thank you! I did the command on the switch holding the RE role. Looks good from the backup's point of view:

     

     

    {backup:0}
    root@cs1-osl2> show system switchover 
    Graceful switchover: On
    Configuration database: Ready
    Kernel database: Ready
    Peer state: Steady State

     

    Tore

     



  • 6.  RE: show system switchover command missing in 11.1R1

    Posted 05-06-2011 04:15

    To verify graceful Routing Engine switchover is configured, on the backup Routing Engine (re1) issue the show system switchover command. The output should be similar to the following example. The Graceful switchover field state must be On.
    {backup}

    user@host> show system switchover

    Graceful switchover: On
    Configuration database: Ready
    Kernel database: Ready
    Peer state: Steady State