Switching

Expand all | Collapse all

EX2300 not completing ZTP process

Jump to Best Answer
  • 1.  EX2300 not completing ZTP process

    Posted 06-01-2018 20:34
    Hello all,
    I have a working Cent OS server that is giving out dhcp and is also acting as a ftp server. ZTP works as it should on EX-2200 switches but something is off when I try to perform the same process on s EX-2300. Has anyone experienced anything similar? Only thing I can think of is the Software difference. Any info on this is greatly appreciated.

    I manually changed the date and time on the switch but I am still getting a error:

    Auto Image Upgrade: Tried [2] attempts to fetch "file_name".txt file from s erver x.x.x.x through vme. Summary: "Failed to change directory.". To ret ry [4] times.

    and it seems to see the server

    Auto Image Upgrade: DHCP Options for client interface vme.0 ConfigFile: /configs/ex2300/file_name.txt ImageFile: /image/ex2300/junos-arm-32-15.1X53-D58.3.tgz Gateway: x.x.x.x DHCP Server:

    x.x.x.x File Server: x.x.x.x Options state: All options set

    Auto Image Upgrade: Active on client interface: vme.0

    Auto Image Upgrade: Interface:: "vme"

    Auto Image Upgrade: Server:: "x.x.x.x"

    Auto Image Upgrade: Image File:: "junos-arm-32-15.1X53-D58.3.tgz"

    Auto Image Upgrade: Server File:: "file_name.txt"

    Auto Image Upgrade: Gateway:: "x.x.x.x"

    Auto Image Upgrade: Protocol:: "ftp"

    Its very strange as my ZTP server works with ex-2200.

    Any ideas on why this would happen? Do I need a Network Director in order for this to work? I spent 3 hours with JTAC on the phone with no solution, just trying to figure out if it is possible to do without Network Director.


  • 2.  RE: EX2300 not completing ZTP process

    Posted 10-19-2018 14:44

    Try removing or adding the leading / in the ZTP_OPTION.config-file-name and/or ZTP_OPTION.image-file-name path of your dhcpd.conf file. That fixed my issue for EX2300. For some reason EX2300 handle the directory path differently. 

     

    I was able to get ZTP working after I changed the path. 

    -Matt

     



  • 3.  RE: EX2300 not completing ZTP process

    Posted 10-19-2018 14:47
    I will give it a try. Appreciate the advice.


  • 4.  RE: EX2300 not completing ZTP process
    Best Answer

    Posted 10-19-2018 15:04

    eg:

    host test {
    hardware ethernet xx:xx:xx:xx:xx:xx;
    fixed-address 10.x.x,x;
    option host-name "test";
    option option-150 10.x.x.x;
    option routers 10.x.x,x;
    option subnet-mask 255.255.255.0;
    option ZTP_OPTION.transfer-mode "ftp";
    option ZTP_OPTION.config-file-name "test.conf";
    option ZTP_OPTION.image-file-name "junos-arm-32-15.1X53-D59.3.tgz";
    }

     

    VS.

     

    host test {
    hardware ethernet xx:xx:xx:xx:xx:xx;
    fixed-address 10.x.x,x;
    option host-name "test";
    option option-150 10.x.x.x;
    option routers 10.x.x,x;
    option subnet-mask 255.255.255.0;
    option ZTP_OPTION.transfer-mode "ftp";
    option ZTP_OPTION.config-file-name "/test.conf";
    option ZTP_OPTION.image-file-name "/junos-arm-32-15.1X53-D59.3.tgz";
    }



  • 5.  RE: EX2300 not completing ZTP process

    Posted 10-19-2018 15:18
    I will double check my config and let you know.

    Thanks,
    Mark