Switching

Expand all | Collapse all

Using Interface Range with Aggregated Ethernet Options (lacp active) doesn't work

Jump to Best Answer
  • 1.  Using Interface Range with Aggregated Ethernet Options (lacp active) doesn't work

    Posted 06-24-2010 02:39

    Hi

     

    I try to set up interface range to define all my LACP to mode "active".

     

    But it seems doesn't working...

     

    here is the simple base config:

     

    interface-range AGGREGATS_LACP_ACTIVE_TRUNKS {
        member ge-6/0/15;
    }

    -> This is working

     

     

    But when I try to put this config:

     

    [edit interfaces interface-range AGGREGATS_LACP_ACTIVE_TRUNKS]
    +    aggregated-ether-options {
    +        lacp {
    +            active;
    +        }
    +    }

     

    I get this error...

    commit
    error: [ interfaces interface-range AGGREGATS_LACP_ACTIVE_TRUNKS aggregated-ether-options] not accepted, as interface-range 'AGGREGATS_LACP_ACTIVE_TRUNKS' has interface 'ge-6/0/15'
    error: copy of interface-range hierarchy failed
    error: interface-ranges expansion failed

     

     

    On the ge-6/0/15, I have configure nothing at all ....

     

    When I've a lott to this KB: (http://www.juniper.net/techpubs/en_US/junos10.1/topics/reference/configuration-statement/interfaces-interfaces-ex-series.html), I see that the aggregated-ether-options isn't listed in the available command...

     

     

     

    So, supported or not, to use interface range with aggregated-ether-options?

     

    Regards

     

     



  • 2.  RE: Using Interface Range with Aggregated Ethernet Options (lacp active) doesn't work
    Best Answer

    Posted 06-29-2010 05:41

    Hi,

     

    unfortunately interface-range does ont support LAG interfaces as of now. There is an Enhancement Request for this.

     

    Kind Regards

    Michael Pergament

     

    If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.



  • 3.  RE: Using Interface Range with Aggregated Ethernet Options (lacp active) doesn't work

    Posted 07-27-2010 06:42

    Hi All,

     

    if you have a case where you need to configure many interfaces where the range does not work, you can use the steps below:

     

    - Go to shell (start shell user root)

    - sh

    # rm set-file.txt; for i in "1" "2" "10"; do echo "set interfaces ge-0/0/$i unit 0 family ethernet-switching vlan members Vlan10" >> set-file.txt; done
    # cat set-file.txt
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members Vlan10
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members Vlan10
    set interfaces ge-0/0/10 unit 0 family ethernet-switching vlan members Vlan10

     

    Then jump into the cli -> edit and load the file:

     

    lab@EX-4# load set set-file.txt
    load complete

    [edit]
    lab@EX-4# show interfaces ge-0/0/1
    description INT1;
    unit 0 {
        family ethernet-switching {
            vlan {
                members Vlan10;
            }
        }
    }

    You can change the above with different set lines.



  • 4.  RE: Using Interface Range with Aggregated Ethernet Options (lacp active) doesn't work

    Posted 01-02-2019 12:22

    Going on nine years now, and it still isn't implemented.

     

    😕