Switching

Expand all | Collapse all

EX4200, bind router MAC to second IP in RVI

Jump to Best Answer
  • 1.  EX4200, bind router MAC to second IP in RVI

    Posted 11-22-2018 07:21

    Hello,

    EX4200 VC.

    I need to bind router MAC to second IP address in a RVI. I have tried to 

    set interfaces vlan unit 6 family inet address 192.168.4.1/24 arp 192.168.4.5 mac 2c:6b:f5:80:aa:01 publish

    but with router MAC is not working. If I change MAC to other than router's works.

    How to do it?

    I need to receive packets sent to 192.168.4.5 but not install as direct route.

     

    Thanks!

    Javier.



  • 2.  RE: EX4200, bind router MAC to second IP in RVI

    Posted 11-26-2018 07:13

    It's like an ARP Proxy but for only one IP...



  • 3.  RE: EX4200, bind router MAC to second IP in RVI
    Best Answer

    Posted 12-01-2018 11:13

    Solved! by adding second ip as RVI and a firewall filter to math second ip and change routing-instance.

     

    set interfaces vlan unit 62 family inet filter input vlan-62
    set interfaces vlan unit 62 family inet address 192.168.4.1/24
    set interfaces vlan unit 62 family inet address 192.168.4.5/24

     

    set firewall family inet filter vlan-62 term nat from destination-prefix-list SRVI-list
    set firewall family inet filter vlan-62 term nat then routing-instance vr-srvi

     

    set policy-options prefix-list SRVI-list 192.168.4.5/32

     

    set routing-instances vr-srvi instance-type virtual-router
    set routing-instances vr-srvi interface vlan.14
    set routing-instances vr-srvi routing-options static route 0.0.0.0/0 next-hop 10.2.1.1

     

    192.168.4.5 is second IP.

    At next hop I route to desired target.