Switching

Expand all | Collapse all

configuration check-out failed

Jump to Best Answer
  • 1.  configuration check-out failed

     
    Posted 06-18-2019 21:45

    Hi all,

    Any  idea why it says "configuration check-out failed"

     

    #deactivate class-of-service drop-profiles extreme-queue-save

    {master:0}[edit]
    ex# show | compare
    [edit class-of-service drop-profiles]
    ! inactive: extreme-queue-save { ... }

    {master:0}[edit]
    ex# commit confirmed 2
    [edit class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp drop-profile]
    'drop-profile extreme-queue-save'
    drop profile undefined: extreme-queue-save
    error: configuration check-out failed -------->?

    {master:0}[edit]
    ex# show | compare
    [edit class-of-service drop-profiles]
    ! inactive: extreme-queue-save { ... }

    {master:0}[edit]
    ex#

     

    Tm 



  • 2.  RE: configuration check-out failed

     
    Posted 06-18-2019 21:54

    @Arix, there seems to be a case of incorrect profile name being deactivated.  Please copy the profile name from the configuration "show configuration class-of-service" that you want to deactivate.

     

    Hope this helps.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).

     



  • 3.  RE: configuration check-out failed

     
    Posted 06-18-2019 22:01

    The configuration check out is failing because you have applied that drop profile to the schedulers in the class of service already and now you are trying to deactivate the drop profile itself hence the checkout is failing.

     



  • 4.  RE: configuration check-out failed

    Posted 06-18-2019 22:05
    Hi Arix,

    Please delete the drop profile called under the schedulers sched-best-effort first before deactivating the drop profile config extreme-queue-save

    Also remove the configs where you have called the drop profile extreme-queue-save

    Try this and see if it helps :

    delete class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp drop-profile
    deactivate class-of-service drop-profiles extreme-queue-save
    commit


    Regards,
    Jibu


  • 5.  RE: configuration check-out failed

     
    Posted 06-19-2019 03:08

    Please try first deactivating the class-of-service statement where drop-profile is called then deactivate drop-profile definition 

     

    deactivate class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp drop-profile
    deactivate class-of-service drop-profiles extreme-queue-save
    commit

     

    thank you

    prabin



  • 6.  RE: configuration check-out failed

     
    Posted 06-19-2019 04:14

    Hi all,

    raviky and jibut are right. it is in both sched-best-effort and sched-high-priority under schedulers stanza....I will do and to see what happens....



  • 7.  RE: configuration check-out failed

     
    Posted 06-19-2019 17:24

    Hi there,

    Again I have an error when committing the deactivated drop-profiles. See below pls. Any idea.

     


    # deactivate class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp drop-profile extreme-queue-save
    ^
    syntax error, expecting ';', [Enter], or '|'.

    # deactivate class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp drop-profile

    # deactivate class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp drop-profile

    # deactivate class-of-service drop-profiles

    # show | compare
    [edit class-of-service]
    ! inactive: drop-profiles { ... }
    [edit class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp]
    ! inactive: drop-profile extreme-queue-save;
    [edit class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp]
    ! inactive: drop-profile extreme-queue-save;

    # commit confirmed
    [edit class-of-service schedulers sched-best-effort]
    'drop-profile-map loss-priority high protocol tcp'
    Missing mandatory statement: 'drop-profile'
    [edit class-of-service schedulers sched-high-priority]
    'drop-profile-map loss-priority high protocol tcp'
    Missing mandatory statement: 'drop-profile'
    error: commit failed: (missing mandatory statements)

    ------------------------------

    > show configuration class-of-service | display set | match "(drop-profiles|extreme)"
    set class-of-service drop-profiles extreme-queue-save interpolate fill-level 85
    set class-of-service drop-profiles extreme-queue-save interpolate fill-level 97
    set class-of-service drop-profiles extreme-queue-save interpolate drop-probability 0
    set class-of-service drop-profiles extreme-queue-save interpolate drop-probability 80
    set class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp drop-profile extreme-queue-save
    set class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp drop-profile extreme-queue-save

     



  • 8.  RE: configuration check-out failed

    Posted 06-19-2019 18:23
    Hi

    You can either try the below config to make the commit successful

    1.

    Deactivate class-of-service drop-profiles extreme-queue-save
    Deactivate class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp
    Deactivate class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp
    Commit

    2. Deactivate class-of-service drop-profiles extreme-queue-save
    Delete class-of-service schedulers sched-best-effort drop-profile-map
    Delete class-of-service schedulers sched-high-priority drop-profile-map
    Commit

    Let me know if it helps ..



    Regards,
    Jibu


  • 9.  RE: configuration check-out failed

     
    Posted 06-19-2019 18:26

    @Arix,

     

    If you leave "drop-profile-map" in scheduler configuration, then it will look for a drop-profile as mandatory.  If you want to deactivate the drop-profile, need to remove drop-profile map as well and redefine the scheduler with loss-priority and buffer-size and if required transmit-rate.   That will allow you to deactivate the drop-profiles.

     

    Ex:

    delete class-of-service schedulers sched-best-effort drop-profile-map (Or deactivate)
    set class-of-service schedulers sched-best-effort priority high buffer-size percent 40

    deactivate class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp drop-profile
    deactivate class-of-service drop-profiles

     

    Hope this helps.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 10.  RE: configuration check-out failed

     
    Posted 06-19-2019 20:46

    Thanks for reply,

    Can I ask about what can be seeing as impact when deactivating it as box in live environment.?



  • 11.  RE: configuration check-out failed

    Posted 06-19-2019 20:54

    ideally, deactivating the drop profile should not cause any impact.  

     

     



  • 12.  RE: configuration check-out failed

     
    Posted 06-19-2019 21:11

    Again missing mandatory statements occured. Frusrating really!!!!

     

    # deactivate class-of-service schedulers sched-best-effort drop-profile-map
    error: syntax error, expecting <flag-value> or <attribute-value>: drop-profile-map


    # deactivate class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp drop-profile

    # deactivate class-of-service drop-profiles


    # commit check
    [edit class-of-service schedulers sched-high-priority]
    'drop-profile-map loss-priority high protocol tcp'
    Missing mandatory statement: 'drop-profile'
    error: configuration check-out failed: (missing mandatory statements)

     



  • 13.  RE: configuration check-out failed

    Posted 06-19-2019 21:14

    HI ,

     

    did you try any of the below ?

     

    1.

    Deactivate class-of-service drop-profiles extreme-queue-save
    Deactivate class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp
    Deactivate class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp
    Commit

    2. Deactivate class-of-service drop-profiles extreme-queue-save
    Delete class-of-service schedulers sched-best-effort drop-profile-map
    Delete class-of-service schedulers sched-high-priority drop-profile-map
    Commit



  • 14.  RE: configuration check-out failed

     
    Posted 06-19-2019 21:51

    The first one I tried:

    #load set terminal
    [Type ^D at a new line to end input]
    Deactivate class-of-service drop-profiles extreme-queue-save
    Deactivate class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp
    Deactivate class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp
    terminal:1:(0) unknown command: Deactivate
    terminal:2:(0) unknown command: Deactivate
    terminal:3:(0) unknown command: Deactivate
    load complete

    #show | compare ----Nothing comes...

     



  • 15.  RE: configuration check-out failed

    Posted 06-19-2019 21:56
    Hi Arix,

    It seems that the “D” in deactivate is in caps and hence its not taking it. Could you please make is in small

    Updated the command list as shown below :

    1.

    deactivate class-of-service drop-profiles extreme-queue-save
    deactivate class-of-service schedulers sched-best-effort drop-profile-map loss-priority high protocol tcp
    deactivate class-of-service schedulers sched-high-priority drop-profile-map loss-priority high protocol tcp
    commit


    or try the below

    2. deactivate class-of-service drop-profiles extreme-queue-save
    delete class-of-service schedulers sched-best-effort drop-profile-map
    delete class-of-service schedulers sched-high-priority drop-profile-map
    commit


    Regards,
    Jibu


  • 16.  RE: configuration check-out failed
    Best Answer

    Posted 06-20-2019 01:42

    Hello Arix,

     

    You are getting 'error: configuration check-out failed' becuase you have deactivate the 'drop-profile' under class of service whereas this drop profile was mapped with the scheduler.

     

    I have ran the same profile on my box, please find the below solution to fix the same.

    Example:

     

    # show class-of-service drop-profiles extreme-queue-save
    fill-level 10 drop-probability 50;

     

    # show class-of-service schedulers H-10-scheduler drop-profile-map loss-priority high protocol tcp drop-profile
    drop-profile extreme-queue-save

     

    Now, I deactivate the drop-profile

     

    # deactivate class-of-service drop-profiles extreme-queue-save

     

    # commit check
    re1:
    [edit class-of-service schedulers H-10-scheduler drop-profile-map loss-priority high protocol tcp drop-profile]
    'drop-profile extreme-queue-save'
    drop profile undefined: extreme-queue-save
    error: configuration check-out failed

     

    Solution:

     

    # deactivate class-of-service schedulers H-10-scheduler drop-profile-map loss-priority high protocol tcp

    {master}[edit]
    labroot@gerrard-re1# commit check
    re1:
    configuration check succeeds
    re0:
    configuration check succeeds

     

     

    Regards,

    Akash

     

    "Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too"

     



  • 17.  RE: configuration check-out failed

     
    Posted 06-20-2019 21:19

    Hi Akash, 

    Your approach worked...

    Much appreciated...

     

    thx

    Ar.