Switching

Expand all | Collapse all

LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16

Jump to Best Answer
  • 1.  LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16

    Posted 03-18-2019 11:41

    Hello,

     

    Hardware and software in question:

    Juniper:

    hardware: EX4300-48MP (multigigabit)

    Junos ver: 18.3R1.9

     

    Cisco:

    Hardware: Catalyst 4300X-16 port in virtual stack (VSS) that consists of two units

    Ios ver: 15.0(1r)SG10

     

    Issue:

     

    I've setup LAG 10g interfaces (4 ports) but when I enable ports on both sides, on juniper all ports are no longer accessible. Weird part(s):

    - the management interface is inaccessible event though it shows in junos cli  "up" status. All 4 10g ports are also showing up status and indicator led on the hardware is showing active/green light.

    - On Cisco side is the same story. All 4 ports are showing connected, including ether-channel and also, indicator led on the hardware is showing active/green light.

     

    Relevant ports configuration on Juniper:

    ============================

    xe-0/2/0 {
    ether-options {
    802.3ad ae1;
    }
    }
    xe-0/2/1 {
    ether-options {
    802.3ad ae1;
    }
    }
    xe-0/2/2 {
    ether-options {
    802.3ad ae1;
    }
    }
    xe-0/2/3 {
    ether-options {
    802.3ad ae1;
    }
    }
    ae1 {
    description "LAG to Cisco";
    aggregated-ether-options {
    lacp {
    active;

    ================================================

     

    Relevant Cisco configuration:

    ================================================

    interface Port-channel111
    description HR SRV RM
    switchport
    switchport mode trunk

    !

    interface TenGigabitEthernet1/1/5
    description HR Jun4300 Link 1
    switchport mode trunk
    channel-group 111 mode active
    !
    interface TenGigabitEthernet1/1/6
    description HR Jun4300 Link 2
    switchport mode trunk
    channel-group 111 mode active

    !

    interface TenGigabitEthernet2/1/13
    description HR Jun4300 Link 3
    switchport mode trunk
    channel-group 111 mode active
    !
    interface TenGigabitEthernet2/1/14
    description HR Jun4300 Link 4
    switchport mode trunk
    channel-group 111 mode active

    ============================================================

     

    Any suggestion would be greatly appreciated.



  • 2.  RE: LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16

    Posted 03-18-2019 12:45

    I think you have missed to define your ae1 interface as a switchport with tagged vlans - at least your configuration doesn't show.

     

    Something like this to allow all vlans on the trunk:

     

    set interfaces ae1.0 family ethernet-swithing interface-mode trunk

    set interfaces ae1.0 family ethernet-swithing vlan members all

     

    Let us know if this resolves your issue.

     



  • 3.  RE: LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16

    Posted 03-19-2019 03:58

    Hi Jonas and thank you for the reply.

     

    It is defined but in my haste, I neglected to copy entire config for the interface:


    =======================

    ae1 {
    description "LAG to Cisco";
    aggregated-ether-options {
    lacp {
    active;
    }
    }
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members [ default all ];
    }

    ======================

     

    Please note: Single link without aggregation, works fine and traffic flows between switches.

     

    Regards,

    T



  • 4.  RE: LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16

    Posted 03-19-2019 04:05

    I suspect that you definition of both vlan members default and all makes an error. I will suggest to remove vlan default:

     

    delete interfaces ae1.0 family ethernet-switching vlan members defaults

     

     

    If it still doesn't work, please provide the following output from the Juniper switch. You can obfuscate vlan names if needed.

     

    show ethernet-switching interface ae1

    show spanning-tree interface ae1

    show ethernet-switching table interface ae1.0



  • 5.  RE: LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16

    Posted 03-19-2019 05:15
      |   view attached


    I've attached the command output and sorry for formatting which is not that great.

     

    Thank you!

     

    T

    Attachment(s)

    pdf
    config.pdf   56K 1 version


  • 6.  RE: LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16
    Best Answer

    Posted 03-19-2019 07:24

    Everything looks OK as mac addresses are learned on the different vlans and STP is forwarding.

     

    Another guess from here: is your management of the EX switch placed on the default vlan? If yes, then you need to define native-vlan on ae1 as Cisco per default sends vlan 1 untagged via trunk links and juniper puts a tag on everything.

     

    Native vlan is configured like this:

    set interfaces ae1 native-vlan-id 1

     

    If this is a wrong guess, please test if you can configure a random access port with VLAN2 (vlan tag 20) and see if you can see the mac address of your test host on the Cisco switches. 'show mac-address table vlan 20 | i Po111' or similar - my Cisco-foo is very rusty 🙂

     

     



  • 7.  RE: LAG from EX4300MP to Cisco VSS (2) Catalyst 4300X-16

    Posted 03-19-2019 09:45

    Spot on! defining native vlan1 on interface ae1 was the key!

     

    I've been working with cisco gear for over 20 years and twice already I have tried to move to Juniper. I like everything about Juniper's hardware and cli.

    Issue that I have with Juniper is not so good and knowledgable salespeople and support is kind of iffy - I've spent a few hours with Juniper's support looking into this issue and gave up as tech was a bit to inexperienced and I knew solution is as always, very simple  -  You sir, have proved that!</rant>

     

    I don't know much about juniper equipment, especially this new line - it makes no sense to me why management interface would be affected by default vlan definition on ae1 link when different physical cables are used... Time to get some books.

     

    I owe you a beer or two so if you are in Toronto area, let me know.

     

    Regards,

     

    T