Switching

Expand all | Collapse all

Enable SSH to interface EX2200

Jump to Best Answer
  • 1.  Enable SSH to interface EX2200

    Posted 02-16-2018 18:06

    My one goal is to be able to plug an RJ45 to this switch, manually set my IP, and SSH to the device.  That being said, this is my first junOS device, and I'm simply learning on it.

     

    I just purchased an EX2200 and wiped it clean.  Plugged in via CON port, i've set the following:

     

    set system host-name "switchHostname"
    set system services ssh
    set system services ssh root-login allow
    set interfaces me0 unit 0 family inet address 192.168.1.1/24
    set routing-options static route 0.0.0.0/0 next-hop 192.168.1.254
    commit

    I then set ge-0/0/2 up to the IP id like to use for my laptop

    set interfaces ge-0/0/2 unit 0 family inet address 192.168.1.5/24
    delete interfaces ge-0/0/0 unit 0 family ethernet-switching

    Perform a commit, and no arguments on the device.  However, when attempting to SSH to 192.168.1.1, I am getting a No route to host.  I've attempted to follow a few guides, but mostly I'm going for an extremly basic setup, so they are either too complex, or too specific to an environment.  ANy help is massively appreciated!

     



  • 2.  RE: Enable SSH to interface EX2200
    Best Answer

     
    Posted 02-16-2018 18:52

    Hi,

     

    You need to assign IP address to your laptop as well say 192.168.1.6/24 and gateway as 192.168.1.5. Please try to ssh once you configure the IP on laptop.

     

    Regards,
    Rahul



  • 3.  RE: Enable SSH to interface EX2200

    Posted 02-16-2018 19:12

    On laptop did (plugged into ge-0/0/2):

     

    ifconfig eth0 192.168.1.6 netmask 255.255.255.0
    route add default gateway 192.168.1.5

    I thought, and this may be the base of my confusion, when you set the inet address for an interface (such as ge-0/0/2), that was what the connected device should utilize.  It appears that that is actually the Juniper's IP it can be accessed from.  Is that correct?

     

    Regardless, it worked. thanks for the help!

     

     



  • 4.  RE: Enable SSH to interface EX2200

     
    Posted 02-17-2018 05:26

    When you set the ip address on the ME port you must connect to the ME port.  This interface is isolated from the main revenue ports so you cannot reach it from any other path.

     

    When ip addresses are configured on any other port they can be reached from any transit port.  But the interface has to be physically link up for the address to be active and able to connect to it.

     

    When ip addresses are assigned to virtual ports like the vlan or irb interfaces these will only become link up/up when at least one physical interface in the same vlan is link up on the switch.