Switching

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  EX200 to HP Procurve 3400CL trunk LACP problem

    Posted 04-23-2015 03:52

    PROBLEM:

    1. If both trunk UTP cable connected, I can't ping gateway but can if only 1 utp cable connected

     

    INFO:

    -gateway 10.0.0.1

    -connection like this

    JUNIPER EX2200 -> HP Procurve 3400CL -> Gateway

    -trunk ports in HP 21-24

    in EX2200 44-47

     

    CONFIG:
    HP3400CL# sh run
    Running configuration:
    ; J4905A Configuration Editor; Created on release #M.10.102
    hostname "HP3400CL"
    interface 1
       no lacp
    exit
    interface 21
       no lacp
    exit
    interface 22
       no lacp
    exit
    interface 23
       no lacp
    exit
    interface 24
       no lacp
    exit
    trunk 21-24 Trk1 LACP
    sntp server 202.65.114.202
    ip routing
    timesync sntp
    snmp-server community "public" Unrestricted
    vlan 1
       name "DEFAULT_VLAN"
       untagged 4-20,Trk1
       no ip address
       no untagged 1-3
       exit
    vlan 10
       name "MGMT"
       untagged 1
       ip address 10.0.0.153 255.255.255.0
       tagged Trk1
       exit
    vlan 20
       name "SVR"
       untagged 2
       ip address 10.0.20.2 255.255.255.0
       tagged Trk1
       exit
    vlan 30
       name "USR"
       untagged 3
       ip address 10.0.30.2 255.255.255.0
       tagged Trk1
       exit
    ip route 0.0.0.0 0.0.0.0 10.0.0.1
    spanning-tree
    spanning-tree protocol-version MSTP
    spanning-tree Trk1 priority 4
    spanning-tree priority 0
    ip ssh

    Juniper EX2200
    root@ex2200# show
    ## Last changed: 2015-04-23 10:24:06 WIT
    version 12.3R8.7;
    system {
        host-name ex2200;
        time-zone Asia/Jakarta;
        root-authentication {
            encrypted-password "$1$/kte9bci$yPafE05trOIqhTKWb0FyR."; ## SECRET-DATA
        }
        /* google dns */
        name-server {
            8.8.8.8;
            8.8.4.4;
        }
        services {
            ssh {
                rate-limit 15;
            }
        }
        syslog {
            user * {
                any emergency;
            }
            file messages {
                any notice;
                authorization info;
            }
            file interactive-commands {
                interactive-commands any;
            }
        }
        ntp;
    }
    chassis {
        alarm {
            management-ethernet {
                link-down ignore;
            }
        }
    }
    interfaces {
        ge-0/0/0 {
            unit 0 {
                family ethernet-switching {
                    vlan {
                        members MGMT;
                    }
                }
            }
        }
        ge-0/0/1 {
            unit 0 {
                family ethernet-switching {
                    vlan {
                        members SVR;
                    }
                }
            }
        }
        ge-0/0/2 {
            unit 0 {
                family ethernet-switching {
                    vlan {
                        members USR;
                    }
                }
            }
        }
        ge-0/0/44 {
            unit 0 {
                family ethernet-switching {
                    port-mode trunk;
                    vlan {
                        members all;
                    }
                    native-vlan-id 30;
                }
            }
        }
        ge-0/0/45 {
            unit 0 {
                family ethernet-switching {
                    port-mode trunk;
                    vlan {
                        members all;
                    }
                    native-vlan-id 30;
                }
            }
        }
        ge-0/0/46 {
            unit 0 {
                family ethernet-switching {
                    port-mode trunk;
                    vlan {
                        members all;
                    }
                    native-vlan-id 30;
                }
            }
        }
        ge-0/0/47 {
            unit 0 {
                family ethernet-switching {
                    port-mode trunk;
                    vlan {
                        members all;
                    }
                    native-vlan-id 30;
                }
            }
        }
        vlan {
            unit 0 {
                family inet;
            }
            unit 10 {
                family inet {
                    address 10.0.0.154/24;
                }
            }
        }
    }
    routing-options {
        static {
            route 0.0.0.0/0 next-hop 10.0.0.1;
        }
    }
    protocols {
        igmp-snooping {
            vlan all;
        }
        rstp;
        lldp {
            interface all;
        }
        lldp-med {
            interface all;
        }
    }
    ethernet-switching-options {
        storm-control {
            interface all;
        }
    }
    vlans {
        MGMT {
            vlan-id 10;
            l3-interface vlan.10;
        }
        SVR {
            vlan-id 20;
        }
        USR {
            vlan-id 30;
        }
        default {
            l3-interface vlan.0;
        }
    }


    #Procurve
    #trunk
    #HP
    #LACP


  • 2.  RE: EX200 to HP Procurve 3400CL trunk LACP problem
    Best Answer

     
    Posted 04-23-2015 14:10
    As I read correct you are having two trunk ports between the HP device and ten Juniper switch?
    With the same vlans on it ?? If ao you are creating a loop!!! That is why the Traffic stops flowing when you connect both utp cables between them.

    The way this Works is to build aan aggregated ethernet channel between the two switchen based on lacp
    http://kb.juniper.net/InfoCenter/index?page=content&id=KB22474

    To build an lacp link on an HP you must Google a bit




  • 3.  RE: EX200 to HP Procurve 3400CL trunk LACP problem

    Posted 04-23-2015 15:59

    Marc solution work for me.

    Now with 2 cable connected, I can still ping the gateway

     

    HP3400CL# sh run
    Running configuration:
    ; J4905A Configuration Editor; Created on release #M.10.102
    hostname “HP3400CL”
    interface 21
    no lacp
    exit
    interface 22
    no lacp
    exit
    interface 23
    no lacp
    exit
    interface 24
    no lacp
    exit
    trunk 21-24 Trk1 LACP
    ip routing
    snmp-server community “public” Unrestricted
    vlan 1
    name “DEFAULT_VLAN”
    untagged 4-20,Trk1
    ip address dhcp-bootp
    no untagged 1-3
    exit
    vlan 10
    name “MGMT”
    untagged 1
    ip address 10.0.0.153 255.255.255.0
    tagged Trk1
    exit
    vlan 20
    name “SVR”
    untagged 2
    tagged Trk1
    exit
    vlan 30
    name “USR”
    untagged 3
    tagged Trk1
    exit
    spanning-tree Trk1 priority 4

     
    Juniper EX2200
    root@ex2200# show
    ## Last changed: 2015-04-24 05:39:59 WIT
    version 12.3R8.7;
    system {
    host-name ex2200;
    time-zone Asia/Jakarta;
    root-authentication {
    encrypted-password “$1$/kte9bci$yPafE05trOIqhTKWb0FyR.”; ## SECRET-DATA
    }
    /* google dns */
    name-server {
    8.8.8.8;
    8.8.4.4;
    }
    services {
    ssh {
    rate-limit 15;
    }
    }
    syslog {
    user * {
    any emergency;
    }
    file messages {
                any notice;
    authorization info;
    }
    file interactive-commands {
    interactive-commands any;
    }
    }
    ntp;
    }
    chassis {
    aggregated-devices {
    ethernet {
    device-count 1;
    }
    }
    alarm {
    management-ethernet {
    link-down ignore;
    }
    }
    }
    interfaces {
    ge-0/0/0 {
            unit 0 {
    family ethernet-switching {
    vlan {
    members MGMT;
    }
    }
    }
    }
    ge-0/0/1 {
    unit 0 {
    family ethernet-switching {
    vlan {
    members SVR;
    }
    }
    }
    }
    ge-0/0/2 {
    unit 0 {
    family ethernet-switching {
    vlan {
    members USR;
    }
    }
    }
    }
        ge-0/0/44 {
    ether-options {
    802.3ad ae0;
    }
    }
    ge-0/0/45 {
    ether-options {
    802.3ad ae0;
    }
    }
    ge-0/0/46 {
    ether-options {
    802.3ad ae0;
    }
    }
    ge-0/0/47 {
    ether-options {
    802.3ad ae0;
    }
    }
        ae0 {
    aggregated-ether-options {
    minimum-links 1;
    link-speed 1g;
    lacp {
    passive;
    periodic fast;
    }
    }
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members all;
    }
    }
    }
    }
    me0 {
    unit 0 {
    family inet;
    }
    }
    vlan {
    unit 0 {
    family inet;
    }
    unit 10 {
    family inet {
    address 10.0.0.154/24;
    }
    }
    }
    }
    routing-options {
    static {
    route 0.0.0.0/0 next-hop 10.0.0.1;
    }
    }
    protocols {
    igmp-snooping {
    vlan all;
    }
    rstp;
    lldp {
    interface all;
    }
    lldp-med {
    interface all;
    }
    }
    ethernet-switching-options {
    storm-control {
    interface all;
    }
    }
    vlans {
    MGMT {
    vlan-id 10;
    l3-interface vlan.10;
    }
    SVR {
    vlan-id 20;
    }
    USR {
    vlan-id 30;
    }
    default {
    vlan-id 1;
    l3-interface vlan.0;
    }
    }