Switching

Expand all | Collapse all

QFX - ip helper - Requires explanation

  • 1.  QFX - ip helper - Requires explanation

    Posted 19 days ago

    Hi everybody,

     

    I do understand why a lot of people would prefer working on Cisco. I need my client to boot from my PXE server on another subnet and I spent my day searching how to do it ... With a Catalyst, I did it in 30 seconds:

    interface GigabitEthernet2/0.10
    encapsulation dot1Q 10
    ip address 192.168.1.250 255.255.255.0
    ip helper-address 192.168.2.100
    ip nat inside
    !
    interface GigabitEthernet2/0.20
    encapsulation dot1Q 20
    ip address 192.168.2.250 255.255.255.0
    ip nat inside

     

    With QFX ... ???

    root> show version
    fpc0:
    --------------------------------------------------------------------------
    Model: vqfx-10000

     

    {master:0}[edit forwarding-options]
    root# show
    storm-control-profiles default {
    all;
    }
    helpers {
    tftp {
    interface {
    em0 {
    server 192.168.2.100;
    }
    }
    }
    }

     

    Regards,

     

    Gueug


    #vqfx-10000
    #iphelper


  • 2.  Re: QFX - ip helper - Requires explanation

     
    Posted 10-29-2020 19:05

    Hi,

     

    Check this document, it has configuration for dhcp/bootp relay.

     

    Tim



  • 3.  Re: QFX - ip helper - Requires explanation

    Posted 10-29-2020 19:06

    Greetings, 

     

    Juniper actually have some good articles explaining how to configure a pxe boot with multiple dhcp servers. 

     

    See the next example that I have with me from previous scenarios;

     

    set forwarding-options dhcp-relay route-suppression destination

    set forwarding-options dhcp-relay overrides allow-snooped-clients

    set forwarding-options dhcp-relay overrides delete-binding-on-renegotiation  

     

    set forwarding-options dhcp-relay server-group DHCP-SERVERS 10.10.10.1

    set forwarding-options dhcp-relay server-group DHCP-SERVERS 10.10.10.3  PXE 

     

    set forwarding-options dhcp-rela active-server-group DHCP-SERVERS

    set forwarding-options dhcp-rela group DHCP-SERVERS interface irb.100

    set forwarding-options dhcp-rela group DHCP-SERVERS interface irb.200 

    set forwarding-options dhcp-rela group DHCP-SERVERS interface irb.300  

     

    set forwarding-options dhcp-relay forward-snoped-clients configured-interfaces    ---- > optional, only for mc-lag setting.              

     

    /////////// 

     

    Set forwarding-options dhcp-relay forward-snooped-clients all-interfaces ->>>MC-LAG setup>> enables the ICL to forward DHCP receiving a DHCP request/ack when state is not present with Relay software it will drop by default, when this knob is configured it will forward it.

     

    set forwarding-options dhcp-relay overrides allow-snooped-clients ->>>>> this will create state in DHCP relay wh (renew/inform) is received from Client for which state was not present

     

    set forwarding-options dhcp-relay route-suppression destination ->>>>> Suppress installation of destination rout the access-internal option are mutually exclusive; however, the access-internal  option also suppresses destination routes. 

     

    ref: 

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB29822&actp=METADATA  

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB30596    

     

    If this help you to resolve your query please mark as resolved! 

     

    Thank you,  

    Esteban Montes