Community Talk

 View Only


This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.

  • 1.  Juniper vlabs

    Posted 12-20-2019 07:13



    I apologise if it's not a correct forum for my problem.


    I'm learning for my jncis cert and I've tried vlabs to get some hands on labs experience. Labs are great but I'm having some serious problems trying to save/load my configurations from session to session.


    The main problem is every time I commit, my ssh connection hangs and I can't reconnect. So I generated tokens and used console connection to get access to devices. This works, I can change configuration and commit it. I can paste, but I can't copy text from console window. So I can't preserve my configs between sessions. I've tried using Add Allowed Network Prefixes to get direct access to devices from my local ssh client but it ends up like website ssh - after commiting ssh hangs and I can't reconnect to any of devices.


    Is there something I do wrong? How can I save/load my configs?

  • 2.  RE: Juniper vlabs

    Posted 12-20-2019 19:01

    Hi tkozyrski,


    I am not an expert and do not manage vlabs. I would like to add my 2 cents as a fellow community member.


    If there are a lot of lines to be loaded for commit; the device might hang instead try loading a few lines to every commit.

    The resources made available to you are virtual instances of the devices though very capable to the standards of a virtual machine are not as robust as physical devices ( Limited minimal resources are allocated for free hands-on).


    If even a line's long commit is hanging, then try below in the order:

    1. Different browser

    2. Use an onboard application to SSH instead of web-based SSH.

    3. If the issue persists, I suppose you need to write to them via email.



    Accept as Solution = cool ! (Will help other community members with similar queries to be redirected here)
    Accept as Solution+Kudo = You are a Star !





  • 3.  RE: Juniper vlabs

    Posted 12-23-2019 09:11



    What is the config  you are trying to load? make sure ssh is enabled otherwise you will lose access and if any RE protection filter is applied during your commit.


    one thing here: does it happen everytime when vlabs gives you access without your configuration?


    Thank you,