Junos OS

 View Only
last person joined: 16 hours ago 

Ask questions and share experiences about Junos OS.
  • 1.  Unable to upgrade a EX2200 switch

    Posted 12-12-2022 13:55
    HI,

    I have some old EX2200 switches that are EOL but extended support.  They are on 11 and 12 code. I am trying to upgrade them and running into all sorts of issues I have not had before.

    They boot, some boot to the backup partition.

    I can run request system reboot slice alternate media internal and sync them.

    Once back on matching builds on both partitions I try the upgrade again.

    I have tried with a USB stick and using WINSCP and pasting the code to the unit.

    I ran
    root# run request system storage cleanup 

    Then copied the code onto it.

    I run run request system software add 
    I have tried with force and no-copy and no-validate etc and combinations.

    I have also set them back to factory and even did a zeroize

    Some have upgraded but then boot to the backup so I cannot get the new code in a running state to then sync the partitions.

    Some just out right fail. I have gotten errors about a truncated or corrupt package etc.

    I have tried running from /var/tmp and from /var/tmp/usb

    I also tried to hop them from 11 or 12 to 13 or 14 or 15.

    I am at a loss why I cannot get the upgrade to go.

    Any help is greatly appreciated.

    ------------------------------
    TODD YOUNGBAUER
    ------------------------------


  • 2.  RE: Unable to upgrade a EX2200 switch

    Posted 12-12-2022 15:54
    I found a post form Steve after a better search and found I may not be able to take these past JUNOS 12.3R12-S21

    I have one at that code rev.

    I will do the others and hold off unless I get other info.  I did not check the doc because there was a 15 code download under the EX2200 category, so I thought I could.

    Thanks

    ------------------------------
    TODD YOUNGBAUER
    ------------------------------



  • 3.  RE: Unable to upgrade a EX2200 switch

    Posted 12-12-2022 19:47
    Yes, the recommendation is to keep the ex2200 at the 12.3 level unless a feature in 15 is needed.
    https://supportportal.juniper.net/s/article/Junos-Software-Versions-Suggested-Releases-to-Consider-and-Evaluate?language=en_US

    The details of the limited memory issues with upgrading past 12 are listed here.
    https://supportportal.juniper.net/s/article/12-3R12-Recommended-Release-for-EX2200-and-EX2200-C

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 4.  RE: Unable to upgrade a EX2200 switch

     
    Posted 12-13-2022 04:49
    While it is recommended to keep it at 12.3R12, I would highly recommend upgrading it to the latest SR though (S21 I believe atm), as there are a number of important bugfixes and updates in these.