Junos OS

 View Only
last person joined: 21 hours ago 

Ask questions and share experiences about Junos OS.
  • 1.  QFX3500 stuck in VC mode and QFX3500 and QFX3600 "request system snapshot partition" creates no snapshot.

    Posted 26 days ago
    Hi guys

    I am getting clueless after three days on and off trying to create a snapshot onto a USB stick on a QFX3500-48S4Q.
    I even tried it on two 3600's with the same result. 

    We have a customer that received two old 2013 QFX3500-48S4Q units that are stuck in VC mode, we tried so many things to solve this without succes. 
    • Reinstalling the software with jinstall-qfx-3-15.1R7.9-domestic-signed.tgz did not solve the issue.
    • We have no install-media.img to install on a USB stick
    • request system zeroize did not work.
    • change hostname and reboot no result
    • remove VC files from folder no result
    • install Jinstall-qfx-3 image from the loader causes a kernel crash after validation step 20/20  
    Hence we try to make a USB snapshot from a unit in our lab that has no issues.

    But even the snapshot cannot be created, we tried 3 different USB sticks (one 8GB usb 2.0 and two 4GB usb 2.0) that we can actually format on the switch but the command "request system snapshot partition" command works but after 15 secs we get the cli again and there seems to be no snapshot created. (see attached logs and images)

    We do see that extra partitions are created but we see no Junos being installed on the USB.

    root@:RE:0% diff /var/tmp/before_USB.txt /var/tmp/after_USB.txt
    28a29,38
    > da1
    > da1s1
    > da1s1a
    > da1s1c
    > da1s1f
    > da1s2
    > da1s3
    > da1s3c
    > da1s3d
    > da1s3e

    We see the below issue on the two QFX3500 units, the unit it's sub-systems are not running.  Hence we want to try to boot these with a USB snapshot of our lab unit. 

    root@W4732-C> show chassis alarms
    error: the alarm-control subsystem is not running
    root@W4732-C> show chassis fpc
    error: the chassis-control subsystem is not running

    root@W4732-C> show version
    Hostname: W4732-C
    Model: qfx3500
    Junos: 15.1R7.9
    JUNOS Base OS boot [15.1R7.9]
    JUNOS Base OS Software Suite [15.1R7.9]
    JUNOS Kernel Software Suite [15.1R7.9]
    JUNOS Crypto Software Suite [15.1R7.9]
    JUNOS Online Documentation [15.1R7.9]
    JUNOS Enterprise Software Suite [15.1R7.9]
    JUNOS Routing Software Suite [15.1R7.9]
    JUNOS py-base-xlr [15.1R7.9]

    root@W4732-C>

    Looking forward to suggestions,


    Thanks,
    Tim

    ------------------------------
    TIM TEENSTRA
    ------------------------------


  • 2.  RE: QFX3500 stuck in VC mode and QFX3500 and QFX3600 "request system snapshot partition" creates no snapshot.

    Posted 23 days ago
    Morning Tim,

    As I know the directory should exist before you attach the USB to it:

    mount_msdosfs /dev/da1s1 /mnt 

    We copy the active partition to USB with these commands:

    request system snapshot partition
    request system snapshot slice alternate

    See juniper guide below:
    https://www.juniper.net/documentation/en_US/junos/topics/example/request-system-snapshot-scenarios.html


    ------------------------------
    BALAZS KISS
    ------------------------------



  • 3.  RE: QFX3500 stuck in VC mode and QFX3500 and QFX3600 "request system snapshot partition" creates no snapshot.

    Posted 23 days ago
    Hi

    Thank you for the reply.

    In order to create a snapshot on the EX series and the Juniper notes it does not say you need to mount the USB before you create a snapshot.
    https://www.juniper.net/documentation/us/en/software/junos/junos-install-upgrade/topics/ref/command/request-system-snapshot.html#request-system-snapshot-command__d8448e579

    https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/qfx-series-system-snapshot-boot-directory.html

    I remember I tried after mounting the USB stick and then a snapshot command will not even work. 
    The command I used to mount was different then yours also.
    root@:LC:0%
    root@:LC:0% mount -t msdosfs /dev/da1s1 /tmp/usb
    root@:LC:0% pwd
    /var/root
    root@:LC:0% cd /tmp/usb/
    root@:LC:0% pwd
    /tmp/usb
    root@:LC:0%

    With the EX series I just plugged in the USB stick and perform the command and it worked. 

    Now the command gets accepted and it writes something on the USB but only empty folders:


    root> request system snapshot partition 
    System may go unstable if module traces or syslog mesages are enabled during snapshot.
    It is recommended to disable all debug logging.
    Do you wish to continue? [yes,no] (no) yes 
    
    fpc0:
    --------------------------------------------------------------------------
    Clearing current label...
    Partitioning external media (da1) ...
    
    {master:0}
    root> 
    
    {master:0}
    root> show system snapshot 
    fpc0:
    --------------------------------------------------------------------------
    Doing the initial labeling...
    Information for snapshot on external (da1s1)
    Creation date: Nov 10 19:10:43 2022
    
    {master:0}
    root> 
    





    ------------------------------
    TIM TEENSTRA
    ------------------------------



  • 4.  RE: QFX3500 stuck in VC mode and QFX3500 and QFX3600 "request system snapshot partition" creates no snapshot.

    Posted 22 days ago

    Unfortunately Juniper didn't migrate all of their information to one site, it spreads on at least 2 sites, you need some luck to find what you are looking for :D
     
    If I would be you, first I try to convert virtual chassis to standalone, as the virtual chassis modify a lot of commands' behavior (for example prevent a zeroize from completing):

    configure
    delete virtual-chassis
    commit and-quit

    reboot

    than in shell logged in as root:

    cd /config/vchassis
    rm vc*
    exit

    reboot again

    After this you shouldn't have VC.



    ------------------------------
    BALAZS KISS
    ------------------------------



  • 5.  RE: QFX3500 stuck in VC mode and QFX3500 and QFX3600 "request system snapshot partition" creates no snapshot.

    Posted 20 days ago
    Hi Balasz

    Thanks for the reply.
    I have tried it again and it is not possible to use the Juniper command for the QFX3500 "request system snapshot partition" when the USB is mounted. 


    root> request system snapshot partition root-partition
    fpc0:
    --------------------------------------------------------------------------
    error: cannot partition da1: /dev/da1s1 is mounted on /tmp/usb

    {master:0}
    root> request system snapshot partition
    fpc0:
    --------------------------------------------------------------------------
    error: cannot partition da1: /dev/da1s1 is mounted on /tmp/usb

    {master:0}
    root>

    I was thinking if it logical that it might be possible to create a snapshot to the mounted USB but there does not seem to be a different command for that. 

    This is very frustrating that such a simple thing is not even working.     :( 



    ------------------------------
    TIM TEENSTRA
    ------------------------------