Routing

 View Only
last person joined: 14 hours ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  MX480 - Bridge domain with trunk and access interface

    This message was posted by a user wishing to remain anonymous
    Posted 03-20-2023 10:28
    This message was posted by a user wishing to remain anonymous

    Hi Team,

    I am looking to configure a bridge domain on MX480, to establish comms between a trunk port on the carrier side, and an access port on the internal side. 

    Internal side => Access port ge-2/0/1

    set interfaces ge-2/0/1 encapsulation ethernet-bridge
    set interfaces ge-2/0/1 unit 0 family bridge vlan-id 151

    External => VLAN tagged traffic
    set interfaces xe-0/0/5 flexible-vlan-tagging
    set interfaces xe-0/0/5 encapsulation flexible-ethernet-services
    set interfaces xe-0/0/5 unit 151 vlan-id 151
    set interfaces xe-0/0/5 unit 151 family bridge

    set bridge-domains BD-151 domain-type bridge
    set bridge-domains BD-151 vlan-id 151
    set bridge-domains BD-151 interface ge-2/0/1.0
    set bridge-domains BD-151 interface xe-0/0/5.151

    However, the commit fails with the below message.

    # commit check 
    re0: 
    error:  To configure family bridge on an interface , interface mode (access or trunk) should be specified
    error: configuration check-out failed

    If I manually set the interface to "access" then it complains about the BD which I believe is a Trio limitation.

    commit check 
    re0: 
    [edit bridge-domains BD-151 interface]
      'ge-2/0/1.0'
        Interface with 'interface-mode' is not allowed in a bridge-domain
    error: configuration check-out failed: (statements constraint check failed)

    Not sure what I am missing here. Can someone what's causing it and how to accomplish this L2 stitching on MX please?



  • 2.  RE: MX480 - Bridge domain with trunk and access interface

    Posted 03-20-2023 13:49

    Hi team,

    The issue got resolved on review after applying the missing line of configuration.

    set interfaces xe-0/0/5 unit 151 encapsulation vlan-bridge



    ------------------------------
    SOHAN SINGH
    ------------------------------