Junos OS

 View Only
last person joined: yesterday 

Ask questions and share experiences about Junos OS.
Expand all | Collapse all

I can't see the IP address of the VLAN ?!!

  • 1.  I can't see the IP address of the VLAN ?!!

    Posted 08-18-2022 17:48

    Hello,

    I'm new to Juniper Switches and I configured a VLAN with an IP address on Juniper Switch but I can't see the IP address when I type show configuration terse ??

    I'm connection this port to a Mikrotik router and I can't ping the Mikrotik with an IP on the same segment ?

    Last question Can I enable web interface on any Juniper Switch ?

    Best Regards



    ------------------------------
    IBRAHIM ABUJAMOUS
    ------------------------------


  • 2.  RE: I can't see the IP address of the VLAN ?!!

     
    Posted 08-18-2022 18:09
    Show configuration terse is not a valid command, do you mean show interfaces terse? Did you commit your changes? Posting a config and topology would help.


  • 3.  RE: I can't see the IP address of the VLAN ?!!

    Posted 08-18-2022 20:04
    As Ibrahim notes the command to see status of interfaces is
    show interfaces terse

    If the interface is an irb one, then at least one physical interface in that vlan will need to be in the up/up status for the irb layer 3 interface to come up/up.

    Jweb can be enabled on ex switches but with some models it does require installing the jweb application service for models
    EX2300/EX3400 & EX4300-MP & EX4650 & EX2300-MP
    https://support.juniper.net/support/downloads/?p=jweb

    Once installed you need to enable jweb under system
    set system services web-management https system-generated-certificate




    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 4.  RE: I can't see the IP address of the VLAN ?!!

    Posted 08-19-2022 05:00
    Hello @spuluka,

    Can you please help me in that what should I do to make the IP address of the VLAN appear ​in show interfaces terse ?


    I did it on Family , unit , init ?!!

    is this the right way ? 


    Best Regards

    ------------------------------
    IBRAHIM ABUJAMOUS
    ------------------------------



  • 5.  RE: I can't see the IP address of the VLAN ?!!

    Posted 08-19-2022 19:59
    Ibrahim,

    Please share your configuration for both the interface and the vlan
    and what model switch you are using

    Then the output of the show interface terse

    There are multiple ways to configure layer 3.  If you have multiple ports in the vlan and want a local layer 3 interface we generally use an irb or vlan interface depending on the switch model.  

    But if you have a single interface or sub interface facing the device and want the ip address there only we would use the physical interface and unit configuration.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 6.  RE: I can't see the IP address of the VLAN ?!!

    Posted 08-20-2022 04:58

    Hello @spuluka ,

    Here is the config

    set interfaces ge-0/0/0 unit 0 family ethernet-switching

    set interfaces ge-0/0/1 unit 0 family ethernet-switching

    set interfaces ge-0/0/2 unit 0 family ethernet-switching

    set interfaces ge-0/0/3 unit 0 family ethernet-switching

    set interfaces ge-0/0/4 unit 0 family ethernet-switching vlan members VLAN-40

    set interfaces ge-0/0/5 unit 0 family ethernet-switching vlan members VLAN-40

    set interfaces ge-0/0/6 unit 0 family ethernet-switching

    set interfaces ge-0/0/7 unit 0 family ethernet-switching

    set interfaces ge-0/0/8 unit 0 family ethernet-switching

    set interfaces ge-0/0/9 unit 0 family ethernet-switching

    set interfaces ge-0/0/10 unit 0 family ethernet-switching

    set interfaces ge-0/0/11 unit 0 family ethernet-switching

    set interfaces ge-0/0/12 unit 0 family ethernet-switching

    set interfaces ge-0/0/13 unit 0 family ethernet-switching

    set interfaces ge-0/0/14 unit 0 family ethernet-switching

    set interfaces ge-0/0/15 unit 0 family ethernet-switching

    set interfaces ge-0/0/16 unit 0 family ethernet-switching

    set interfaces ge-0/0/17 unit 0 family ethernet-switching

    set interfaces ge-0/0/18 unit 0 family ethernet-switching

    set interfaces ge-0/0/19 unit 0 family ethernet-switching

    set interfaces ge-0/0/20 unit 0 family ethernet-switching

    set interfaces ge-0/0/21 unit 0 family ethernet-switching

    set interfaces ge-0/0/22 unit 0 family ethernet-switching

    set interfaces ge-0/0/23 unit 0 family ethernet-switching

    set interfaces ge-0/0/24 unit 0 family ethernet-switching

    set interfaces xe-0/1/0 ether-options 802.3ad ae0

    set interfaces xe-0/1/1 ether-options 802.3ad ae0

    set interfaces ge-0/1/2 unit 0 family ethernet-switching

    set interfaces xe-0/1/2 unit 0 family ethernet-switching

    set interfaces ge-0/1/3 unit 0 family ethernet-switching

    set interfaces xe-0/1/3 unit 0 family ethernet-switching

    set interfaces ae0 aggregated-ether-options lacp active

    set interfaces ae0 unit 0 family ethernet-switching

    set interfaces irb unit 40 family inet address 192.168.40.100/24

    set interfaces me0 unit 0 family inet address X.X.X.X/24

    set interfaces vlan unit 0 family inet filter input mngthosts

    set interfaces vlan unit 40 family inet address 192.168.40.100/24

    set routing-options static route 0.0.0.0/0 next-hop X.X.X.X

    set protocols rstp

    set protocols lldp interface all

    set protocols lldp-med interface all

    set firewall family inet filter mngthosts term allowedhosts from source-address X.X.X.X/32

    set firewall family inet filter mngthosts term allowedhosts then accept

    set firewall family inet filter mngthosts term allow-icmp from source-address 0.0.0.0/0

    set firewall family inet filter mngthosts term allow-icmp from icmp-type echo-reply

    set firewall family inet filter mngthosts term allow-icmp from icmp-type echo-request

    set firewall family inet filter mngthosts term allow-icmp from icmp-type router-solicit

    set firewall family inet filter mngthosts term allow-icmp from icmp-type time-exceeded

    set firewall family inet filter mngthosts term allow-icmp from icmp-type unreachable

    set firewall family inet filter mngthosts term allow-icmp then accept

    set firewall family inet filter mngthosts term allowntp from source-address X.X.X.X/32

    set firewall family inet filter mngthosts term allowntp from protocol udp

    set firewall family inet filter mngthosts term allowntp from source-port 150

    set firewall family inet filter mngthosts term allowntp then accept

    set firewall family inet filter mngthosts term deny-rest then discard

    set firewall family inet filter mngthosts term hsrp from destination-address X.X.X.X/32

    set firewall family inet filter mngthosts term hsrp then accept

    set ethernet-switching-options mac-table-aging-time 2000

    set ethernet-switching-options storm-control interface all bandwidth 100

    set vlans VLAN-40 vlan-id 40

    set vlans VLAN-40 l3-interface vlan.40

    set vlans default l3-interface vlan.0

    set virtual-chassis preprovisioned

    set virtual-chassis no-split-detection

    set virtual-chassis member 0 role routing-engine

    set virtual-chassis member 0 serial-number XXXXXXXXXXXX

    set virtual-chassis member 1 role routing-engine

    set virtual-chassis member 1 serial-number XXXXXXXXXXXX

    set virtual-chassis vc-port



    The model and the version 

    Model: ex3300-24t
    JUNOS Base OS boot [12.3R12-S12]

    Thanks in advance 



    ------------------------------
    IBRAHIM ABUJAMOUS
    ------------------------------



  • 7.  RE: I can't see the IP address of the VLAN ?!!

     
    Posted 08-20-2022 07:11
    delete interfaces irb

    and recommit (irb interfaces are not valid on EX3300) and then post output of 'show interfaces terse'



  • 8.  RE: I can't see the IP address of the VLAN ?!!

    Posted 08-20-2022 07:18
    Hello @smicker,

    Can you please tell me the commands to do that ? it's a very critical Switch

    and I want to know why I can't ping myself ??​

    ------------------------------
    IBRAHIM ABUJAMOUS
    ------------------------------



  • 9.  RE: I can't see the IP address of the VLAN ?!!

     
    Posted 08-20-2022 09:35
    edit
    delete interfaces irb
    commit
    exit


  • 10.  RE: I can't see the IP address of the VLAN ?!!

    Posted 08-20-2022 09:49