Hi, can 10.10.10.1 ping 10.10.10.2? If not, check these things...
- Make sure you are connecting the vQFX PFE (vFP) and RE (vCP) using the em1 interfaces on both pfe and re
- Check "show chassis fpc" and you should see slot 0 Online/Testing
I'm using vQFX in EVE-NG. I'm assuming the setup is similar in GNS3, but I haven't used GNS3 in years.
This video I did may help. https://youtu.be/jZY5JhEoY9s
------------------------------
- Aaron
------------------------------
Original Message:
Sent: 03-28-2023 14:25
From: Jason-net
Subject: GNS3 QFX OSPF Adjacency not forming
I am using GNS3. I have 2 QFX devices configured for OSPF. I see their hello packets to each other on wireshark but the 2 QFX devices don't see each other it seems. They both show 0 received hello packets. Can you take a look at my configs and tell me if you see what I am missing?
Site A config
system {
host-name Site-A;
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
extensions {
providers {
juniper {
license-type juniper deployment-scope commercial;
}
chef {
license-type juniper deployment-scope commercial;
}
}
}
}
interfaces {
xe-0/0/0 {
description "host 1";
unit 0 {
family ethernet-switching {
vlan {
members VLAN10;
}
}
}
}
xe-0/0/1 {
description "uplink to site B";
mtu 9192;
unit 0 {
family inet {
address 10.10.10.1/30;
}
}
}
em1 {
unit 0 {
family inet {
address 169.254.0.2/24;
}
}
}
irb {
unit 10 {
family inet {
address 192.168.1.1/24;
}
}
}
}
forwarding-options {
storm-control-profiles default {
all;
}
}
protocols {
ospf {
area 0.0.0.0 {
interface xe-0/0/1.0;
}
}
igmp-snooping {
vlan default;
}
}
vlans {
VLAN10 {
vlan-id 10;
l3-interface irb.10;
}
default {
vlan-id 1;
}
}
Site B config
system {
host-name SITE-B;
login {
user vagrant {
uid 2000;
class super-user;
authentication {
}
}
}
services {
ssh {
root-login allow;
}
netconf {
ssh;
}
rest {
http {
port 8080;
}
enable-explorer;
}
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
extensions {
providers {
juniper {
license-type juniper deployment-scope commercial;
}
chef {
license-type juniper deployment-scope commercial;
}
}
}
}
interfaces {
xe-0/0/0 {
description "Host 1";
unit 0 {
family ethernet-switching {
vlan {
members VLAN20;
}
}
}
}
xe-0/0/1 {
description "Uplink to Site A";
mtu 9192;
unit 0 {
family inet {
address 10.10.10.2/30;
}
}
}
em0 {
unit 0 {
family inet {
dhcp;
}
}
}
em1 {
unit 0 {
family inet {
address 169.254.0.2/24;
}
}
}
irb {
unit 20 {
family inet {
address 192.168.2.1/24;
}
}
}
lo0 {
unit 0;
}
}
forwarding-options {
storm-control-profiles default {
all;
}
}
routing-options {
router-id 192.168.1.1;
}
protocols {
ospf {
area 0.0.0.0 {
interface xe-0/0/1.0;
}
}
igmp-snooping {
vlan default;
}
}
vlans {
VLAN20 {
vlan-id 20;
l3-interface irb.20;
}
default {
vlan-id 1;
}
}