I have already tested that style of config with the same result.
Original Message:
Sent: 03-31-2023 14:15
From: kth
Subject: EX4650 allow trunks to pass double tags
Oh ok, Documentation says "Some switching features, however, cannot be configured on logical interface unit 0. Features such as Q-in-Q tunneling require the logical interface to transmit VLAN-tagged frames."
Looks like the service provider style supports units other than 0. Can you try--
xe-0/0/0 {
description "to switch1";
flexible-vlan-tagging; mtu 1522; encapsulation flexible-ethernet-services; unit 101 { encapsulation vlan-bridge; vlan-id 101; }
unit 102 { encapsulation vlan-bridge; vlan-id 102; }
xe-0/0/1 {
description "to switch2";
flexible-vlan-tagging; mtu 1522; encapsulation flexible-ethernet-services; unit 101 { encapsulation vlan-bridge; vlan-id 101; }
unit 102 { encapsulation vlan-bridge; vlan-id 102; }
You can use 'load replace terminal' and paste in the above if it's an exact match, then Ctrl+D to exit. Or type the set commands by hand. Let me know how it goes!
------------------------------
Kyler H
Original Message:
Sent: 03-30-2023 15:21
From: Dan Graham
Subject: EX4650 allow trunks to pass double tags
No private vlans.
Here is the example switch1 and switch2 interface config.
interface GigabitEthernet0/0
description TO EX4650
switchport trunk allowed vlan 101, 102
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mtu 1504
!
interface GigabitEthernet0/1
description TO CUSTOMER A
switchport access vlan 101
switchport mode dot1q-tunnel
switchport nonegotiate
!
interface GigabitEthernet0/1
description TO CUSTOMER B
switchport access vlan 102
switchport mode dot1q-tunnel
switchport nonegotiate
Customer switch example on both sides would be:
interface GigabitEthernet0/1
switchport trunk allowed vlan 2,3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
------------------------------
Dan Graham
Original Message:
Sent: 03-30-2023 14:26
From: KYLER HAUSCHILDT
Subject: EX4650 allow trunks to pass double tags
Hey Dan,
Are switch 1 and switch 2 doing private VLANs (https://www.juniper.net/documentation/us/en/software/junos/multicast-l2/topics/topic-map/private-vlans.html) or regular VLAN tagging? If you can post the interface config from switch 1 & 2 that'd be helpful.
Thanks!
------------------------------
KYLER HAUSCHILDT
Original Message:
Sent: 03-29-2023 14:22
From: Dan Graham
Subject: EX4650 allow trunks to pass double tags
After further review, the above configuration is removing the inner tag. What needs adjusted to retain this?
Both tags are ether-type 0x8100.
------------------------------
Dan Graham
Original Message:
Sent: 03-24-2023 16:19
From: Dan Graham
Subject: EX4650 allow trunks to pass double tags
Example topology:
custA / custB > switch1 > EX4650 > switch2 > custA / custB
custA outer tag 101
custB outer tag 102
The EX4650 should allow any inner tag on both vlan 101 and 102.
Dot1Q tunnel is setup on switch1 and switch2. EX4650 just needs to bridge.
Standard trunk config doesnt allow the inner tags to pass. What is needed to make this function?
xe-0/0/0 {
description "to switch1";
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ custA custB ];
}
}
}
}
xe-0/0/1 {
description "to switch2";
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ custA custB ];
}
}
}
}
.......
custA {
vlan-id 101;
}
custB {
vlan-id 102;
}
------------------------------
Dan Graham
------------------------------