View Only
last person joined: 3 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  [EX3300] Console port partly defective

    Posted 12-20-2022 14:03
    Hi All,

    I really hope you can help me here.

    I have two EX3300 second hand switches. They're both OK, no problems there. One of the two has the EFL installed. I am using routing-instance=virtual-router so I need the EFL. Nothing fancy going on, no "real" VRF, no MPLS etc., just separate routing tables.

    The thing is that this switch may die sometime in the feature. For that I have a second unit which is also working great, but it does not have an EFL installed. I am fairly sure it's impossible to move the EFL from one switch to another, so I won't try to. This means I would not be able to run my virtual routing instances on the replacement switch, which is a real issue.

    Now I have access to a third EX3300 that also has an EFL installed. I can exchange my second unit to this one if I'd want to. Problem is that this unit has a defective serial port. There is valid data coming out of it (so I now the baudrate etc. are correct) but key presses are not received or registered. I'd really like to have this unit working, of course, one way or another.

    So this is what I already tried. I checked the console port very thoroughly, cleaned it too, but it doesn't help. The other unit works just fine with the same equipment. The LCD menu keys on the front are disabled, so no way to do a factory reset there. The management interfaces (me.0) are not configured (but also not explicitly shut down). I believe from the docs that if you don't configure them with an ip range/subnet, they're useless.

    Then I tried the following. Created a virtual chassis with another unit, where the working, "other" unit is designated as the "routing engine" and the faulty unit is to be a "line card". Configured this as usual, in the "good" unit, set virtual chassis mode to "preprovisioned" mode with the correct serial numbers included. The problematic unit already has a configuration (which I can't change...) and used to be part of a virtual chassis, where it was the second fpc, also RE, also preprovisioned.

    I was hoping that the new preprovisioned virtual chassis configuration, with two valid and connected units, both serial numbers corresponding to the units attached, would get me a new virtual circuit where I would be able to reach the defective unit via a "request session" command. It is almost certain that both units have different JunOS versions, so they will not be forming a fully operational virtual chassis, but I don't need that anyway, I just want to do a "request session member 1" and get the me.0 interface configured there.

    I succeeded there just partly. VC ports are correctly configured on both switches (10 Gbs sSFP+ ports using DAC cables)  and show virtual-chassis with several subcommands show that the faulty unit is seen by the working one. I can't check on the faulty unit of course. The faulty unit stays, however, in "NotPrsnt" state and the working unit won't allow me start a session to it. This remains for over 10 minutes (which I am aware of, is the normal "waiting" time for hot-adding a new member).

    My questions:
     - is there a chance this will work if both unit have exactly the same firmware? I can probably up/downgrade the working switch to the JunOS version of the faulty one.
    - is this going to work anyway, trying to move a unit from an existing virtual chassis into another? I seem to remember having it done one time,  like this, but I am not sure.
    - is there another way to get a configuration on me.0 without having to use the console port
    - is there a way to wipe the config (only the config, not zeroise per se) without having to use the console port nor LCD menu buttons? That may fix the VC issue.
    - is there another way to get the me.0 interface without having to resort to the console port of LCD menu buttons?

    I am very much obliged for any though on this matter!


    Erik Slagter

  • 2.  RE: [EX3300] Console port partly defective

    Posted 02-02-2023 20:16
    What a nightmare scenario.

    I would try to boot the non working device from a USB and do a format install of the internal drive.

    To get a bootable USB have a working EX in fully normal single switch no VC mode. 
    Then run a snapshot to a USB drive.
    Then copy the desired Junos install file to the USB

    Insert this in the powered off problem EX and it should boot from there as the first choice.
    Once booted do the format install from the USB to the internal drive

    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)

  • 3.  RE: [EX3300] Console port partly defective

    Posted 02-03-2023 08:39
    Hi Steve,

    Thanks for your thoughts. Where I am struggling is that the console doesn't accept anything or any key. So I guess booting from USB is out of the question, as far as I know you need to press a key for that to activate.

    In the end it is my own fault, because I should have set a management IP adress on the vm0 interface when I knew the console was broken. For now I have peace with the thought I will always have my logs full of "no license for..." messages, it still just works. I am now using another switch that doesn't have the license (I was lucky to be able to replace it at no cost).

    It would be nice if Juniper would be forthcoming here, as this switch type is no longer built or sold for some time and some $1000-$2000 is a tad too much for home/studying use.

    Erik Slagter

  • 4.  RE: [EX3300] Console port partly defective

    Posted 02-03-2023 08:41
    Sorry for not being clear enough.

    When you create the snapshot of the working EX this will have all the configuration of that device as a bootable image.
    So when the console defective switch boots to this image you then have the configured ip interfaces available to ssh and access the device.

    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)

  • 5.  RE: [EX3300] Console port partly defective

    Posted 02-03-2023 12:40
    Aha I understand what you mean. Never knew a snapshot on an external media could be used to bootstrap a switch? Are there any requirements for the external media or will the switch partition and format it itself?

    Can I also use this to revert to another JunOS version without having to rely on the dual root slice and including the configuration as well? See my other question, I was downgrading my EX3300 from an R15 version (latest and recommended), which has some serious bugs that make the switch crash and also corrupt the configuration partition, to the last recommended R12 version, which has always worked great for me. But when I do that, the switching doesn't activate, looks like the ether-switching-service crashes on startup. Maybe related maybe not, the switch also wants to log me on to a non-existing "master"/RE even though the switch has been zeroized and the VC config directory is empty. I've tried it several times now, but always end up the same way. If I could make a complete snapshot of the R15 version, at least, I could restore quickly, after trying an R12 version.

    Erik Slagter