Junos OS

 View Only
last person joined: 4 days ago 

Ask questions and share experiences about Junos OS.
  • 1.  EX2300 Switch can't load 'kernel' after Reset- Stuck in constant boot cycle.

    Posted 6 days ago
    Hello, can anyone please help?

    I recently tried to reset a EX2300 Switch back to default factory settings, and now it cannot load the 'kernel' and is stuck in a constant boot cycle.  I reset the switch by depressing the reset button on the front of the device while re-attaching the power.
    I was able to interrupt the boot cycle using Control "C", and tried the following options without success:

    • Booting in recovery mode
    • USB Boot - with recovery image

    I'm not sure I did the USB Boot part correctly, and maybe that's the reason it hasn't worked. I've tried several things using advice from the Juniper Site, but I'm no further forward.  I am currently presented with the following:

    => <INTERRUPT>
      Here, I can boot from the USB - "usbboot"
    If I enter "reboot", it takes me to another mode:

    loader> ?
    Available commands:
    boot boot a file or loaded kernel
    autoboot boot automatically after a delay
    help detailed help
    ? list commands
    show show variable(s)
    set set a variable
    unset unset a variable
    echo echo arguments
    read read input from the terminal
    more show contents of a file
    lsdev list all devices
    include read commands from a file
    ls list files
    load load a kernel or module
    load_geli load a geli key
    unload unload all modules
    lsmod list loaded modules
    install install software package
    heap show heap usage
    reboot reboot the system
    devinfo show U-Boot devices
    sysinfo show U-Boot system info
    ubenv show or import U-Boot env vars
    fdt flattened device tree handling

    I think I am doing something wrong, which is probably easily fixable. 

    Thanks for any advice!



  • 2.  RE: EX2300 Switch can't load 'kernel' after Reset- Stuck in constant boot cycle.

    Posted 5 days ago
    Had faced similar issue.
    install OS from the boot loader (via ftp).