Switching

 View Only
last person joined: 23 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  EX 2300 CPU usage above 70%

    Posted 04-06-2023 15:48

    Hello all,

    I receive a lot of alarms for CPU usage above 70% .

    I have this issue on two stacked EX 2300 switches:

    Model: ex2300-48p
    Junos: 20.4R3-S2.6
    Model: ex2300-48t
    Junos: 20.4R3-S2.6

    show system processes summary
    last pid: 62488;  load averages:  2.65,  2.96,  2.96  up 367+02:00:14    16:35:51
    230 processes: 4 running, 207 sleeping, 19 waiting
     
    Mem: 58M Active, 1357M Inact, 288M Wired, 32M Buf, 204M Free
    Swap:
     
      PID USERNAME PRI NICE   SIZE    RES STATE    TIME    WCPU COMMAND
    17074 root      20    0   982M   196M select 2367.4  31.98% fxpc{fxpc}
    17074 root     -52   r0   982M   196M select 791.3H  19.97% fxpc{fxpc}
    17531 root      27    0   284M 15632K RUN    686:57   9.96% ppmd
       11 root     155 ki31     0K    16K RUN    4230.7   8.98% idle
    17536 root      28    0   328M 34828K RUN     28.8H   6.98% l2cpd
       12 root     -72    -     0K   304K WAIT   125.0H   3.96% intr{swi1: netisr 0}
    17539 root      21    0   525M   144M select 155.9H   2.98% authd
    17524 root      21    0   334M 38180K select 284.4H   1.95% mib2d
       16 root     -16    -     0K    16K -      189.8H   1.95% rand_harvestq
    17523 root      21    0   294M 26696K select 193.1H   0.98% snmpd
    show chassis routing-engine
    Routing Engine status:
      Slot 0:
        Current state                  Master
        Temperature                 52 degrees C / 125 degrees F
        CPU temperature             52 degrees C / 125 degrees F
        DRAM                      1945 MB (2048 MB installed)
        Memory utilization          19 percent
        5 sec CPU utilization:
          User                      52 percent
          Background                 0 percent
          Kernel                    27 percent
          Interrupt                  5 percent
          Idle                      17 percent
        Model                          RE-EX2300-48T
        Serial ID                      BUILTIN
        Start time                     2022-04-04 14:35:38 EEST
        Uptime                         367 days, 2 hours, 1 minute, 9 seconds
        Last reboot reason             0x40000:Mac Reset
        Load averages:                 1 minute   5 minute  15 minute
                                           2.71       2.92       2.94
    Routing Engine status:
      Slot 1:
        Current state                  Backup
        Temperature                 41 degrees C / 105 degrees F
        CPU temperature             41 degrees C / 105 degrees F
        DRAM                      1945 MB
        Memory utilization          18 percent
        5 sec CPU utilization:
          User                      30 percent
          Background                 0 percent
          Kernel                    11 percent
          Interrupt                  1 percent
          Idle                      58 percent
        Model                          RE-EX2300-48P
        Serial ID                      BUILTIN
        Start time                     2022-04-04 14:35:35 EEST
        Uptime                         367 days, 2 hours, 1 minute, 8 seconds
        Last reboot reason             0x40000:Mac Reset
        Load averages:                 1 minute   5 minute  15 minute
                                           0.98       0.91       0.84

    Could you please share your experience or guidance regarding the topic?

    How can I identify what causes the issue?

    I tried to check the PR numbers and release notes for issues but I didn't find anything promising for Junos: 20.4R3-S2.6 and EX 2300.



  • 2.  RE: EX 2300 CPU usage above 70%

    Posted 05-01-2023 17:13

    I ran into a similar issue on a stack of 4400's. Eventually it brought the link down and we had to manually reboot the stack and clear an err'ed port on the upstream switch.

    I was told to replace optics on the uplinks, replace cabling, and check for excessive port flapping.

    I also found the upstream side of the connection had a high number of CRC errors. 

    I replaced the fiber jumpers in between and it seems to have calmed down.

    What are you running upstream? do you have a LAG running between upstream/downstream switches?  Can you run the following on your ae links?
    show interfaces xe-#/#/# extensive

    See if you have a high number of carrier transitions in the output. Also check on the upstream and downstream switches for high number of input/output errors on the connected trunk ports.



    ------------------------------
    TRAVIS POLASH
    ------------------------------



  • 3.  RE: EX 2300 CPU usage above 70%

    Posted 05-02-2023 06:29

    Are you by any chance using JunoSpace or another management tool? I've found they tend to do large amounts of bulk SNMP queries which sends the CPU usage sky high at times.



    ------------------------------
    Erik Slagter
    ------------------------------