Data Center

 View Only
last person joined: yesterday 

Ask questions and share experiences about Data Center Architecture and approaches.

EVPN VXLAN implementation test

  • 1.  EVPN VXLAN implementation test

    Posted 06-29-2023 05:47

    Hi,

    I am trying to implement an evpn vxlan in gns3 using Junos-vSwitch, everything seems to be UP:

    • I can ping hosts in the same vlan
    • routes are shared between leafs

    However, when i am trying to add a community for vrf-import it simply not works. i will post config and topology.

    set version 23.1R1.8
    set system host-name SPINE1
    set system root-authentication encrypted-password "$6$t4kcdt3x$rZByILwNxJEq8UoeXFmPWMtBS/ufls5Cs8569m5Y7K69xPZyq5HlK4qUe2X581qiHlSVcb.58jF7WIgWEA3.70"
    set system services ssh root-login allow
    set system arp aging-timer 5
    set system syslog file interactive-commands interactive-commands any
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set interfaces ge-0/0/0 unit 0 family inet address 172.11.11.1/24
    set interfaces ge-0/0/1 unit 0 family inet address 172.12.12.1/24
    set interfaces ge-0/0/2 unit 0 family inet address 172.13.13.1/24
    set interfaces fxp0 unit 0 family inet address 192.168.0.200/24
    set interfaces lo0 unit 0 family inet address 1.1.1.1/32
    set multi-chassis mc-lag consistency-check
    set routing-options autonomous-system 65001
    set protocols router-advertisement interface fxp0.0 managed-configuration
    set protocols bgp group RR type internal
    set protocols bgp group RR local-address 1.1.1.1
    set protocols bgp group RR family evpn signaling
    set protocols bgp group RR cluster 12.12.12.12
    set protocols bgp group RR neighbor 2.2.2.2
    set protocols bgp group RR neighbor 11.11.11.11
    set protocols bgp group RR neighbor 22.22.22.22
    set protocols bgp group RR neighbor 33.33.33.33
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols lldp interface all
    set protocols lldp-med interface all

    root@SPINE2# show | display set | no-more 
    set version 23.1R1.8
    set system host-name SPINE2
    set system root-authentication encrypted-password "$6$t4kcdt3x$rZByILwNxJEq8UoeXFmPWMtBS/ufls5Cs8569m5Y7K69xPZyq5HlK4qUe2X581qiHlSVcb.58jF7WIgWEA3.70"
    set system services ssh root-login allow
    set system arp aging-timer 5
    set system syslog file interactive-commands interactive-commands any
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set interfaces ge-0/0/0 unit 0 family inet address 172.21.21.1/24
    set interfaces ge-0/0/1 unit 0 family inet address 172.22.22.1/24
    set interfaces ge-0/0/2 unit 0 family inet address 172.23.23.1/24
    set interfaces fxp0 unit 0 family inet address 192.168.0.201/24
    set interfaces lo0 unit 0 family inet address 2.2.2.2/32
    set multi-chassis mc-lag consistency-check
    set routing-options autonomous-system 65001
    set protocols router-advertisement interface fxp0.0 managed-configuration
    set protocols bgp group RR type internal
    set protocols bgp group RR local-address 2.2.2.2
    set protocols bgp group RR family evpn signaling
    set protocols bgp group RR cluster 12.12.12.12
    set protocols bgp group RR neighbor 1.1.1.1
    set protocols bgp group RR neighbor 11.11.11.11
    set protocols bgp group RR neighbor 22.22.22.22
    set protocols bgp group RR neighbor 33.33.33.33
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols lldp interface all
    set protocols lldp-med interface all

    set version 23.1R1.8
    set system host-name LEAF1
    set system root-authentication encrypted-password "$6$Bkz1QzqM$ZqFuuzCr9JJE4AHEStCJEEKeFX5tn5mVsXtrc9bpnT82o4eAgGd9ZqBlnKz3rmMVg9nLFwSCVlL0H/wYNYD6V1"
    set system services ssh root-login allow
    set system arp aging-timer 5
    set system syslog file interactive-commands interactive-commands any
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set interfaces ge-0/0/0 unit 0 family inet address 172.11.11.2/24
    set interfaces ge-0/0/1 unit 0 family inet address 172.21.21.2/24
    set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members 10
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members 20
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members 30
    set interfaces fxp0 unit 0 family inet address 192.168.0.202/24
    set interfaces irb unit 1010 virtual-gateway-accept-data
    set interfaces irb unit 1010 family inet address 10.10.1.1/24 virtual-gateway-address 10.10.1.254
    set interfaces irb unit 2020 virtual-gateway-accept-data
    set interfaces irb unit 2020 family inet address 20.20.1.1/24 virtual-gateway-address 20.20.1.254
    set interfaces irb unit 3030 virtual-gateway-accept-data
    set interfaces irb unit 3030 family inet address 30.30.1.1/24 virtual-gateway-address 30.30.1.254
    set interfaces lo0 unit 0 family inet address 11.11.11.11/32
    set interfaces lo0 unit 10 family inet address 10.10.10.10/32
    set multi-chassis mc-lag consistency-check
    set forwarding-options storm-control-profiles default all
    set policy-options policy-statement EVPN_SHARE from protocol evpn
    set policy-options policy-statement EVPN_SHARE then accept
    set policy-options policy-statement FIFTY from community FIFTY
    set policy-options policy-statement FIFTY then accept
    set policy-options policy-statement TEN from interface irb.1010
    set policy-options policy-statement TEN then community add TEN
    set policy-options policy-statement TEN then accept
    set policy-options policy-statement load-balancing-policy then load-balance per-packet
    set policy-options community FIFTY members target:5050:1
    set policy-options community TEN members target:1010:1
    set routing-instances TEN instance-type vrf
    set routing-instances TEN routing-options multipath
    set routing-instances TEN routing-options auto-export
    set routing-instances TEN interface irb.1010
    set routing-instances TEN interface lo0.10
    set routing-instances TEN route-distinguisher 10.10.1.1:1010
    set routing-instances TEN vrf-import FIFTY
    set routing-instances TEN vrf-target target:1010:1
    set routing-instances THIRTY instance-type vrf
    set routing-instances THIRTY routing-options auto-export
    set routing-instances THIRTY interface irb.3030
    set routing-instances THIRTY route-distinguisher 30.30.1.1:3030
    set routing-instances THIRTY vrf-target target:3030:1
    set routing-instances TWENTY instance-type vrf
    set routing-instances TWENTY routing-options auto-export
    set routing-instances TWENTY interface irb.2020
    set routing-instances TWENTY route-distinguisher 20.20.1.1:2020
    set routing-instances TWENTY vrf-target target:2020:1
    set routing-options router-id 11.11.11.11
    set routing-options autonomous-system 65001
    set routing-options forwarding-table export load-balancing-policy
    set protocols router-advertisement interface fxp0.0 managed-configuration
    set protocols bgp group LEAF type internal
    set protocols bgp group LEAF local-address 11.11.11.11
    set protocols bgp group LEAF family evpn signaling
    set protocols bgp group LEAF neighbor 1.1.1.1
    set protocols bgp group LEAF neighbor 2.2.2.2
    set protocols evpn encapsulation vxlan
    set protocols evpn default-gateway no-gateway-community
    set protocols evpn multicast-mode ingress-replication
    set protocols evpn vni-options vni 1010 vrf-target target:1010:1
    set protocols evpn vni-options vni 2020 vrf-target target:2020:1
    set protocols evpn vni-options vni 3030 vrf-target target:3030:1
    set protocols evpn vni-options vni 4040 vrf-target target:4040:1
    set protocols evpn vni-options vni 5050 vrf-target target:5050:1
    set protocols evpn vni-options vni 6060 vrf-target target:6060:1
    set protocols evpn extended-vni-list all
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols lldp interface all
    set protocols lldp-med interface all
    set protocols igmp-snooping vlan default
    set switch-options vtep-source-interface lo0.0
    set switch-options route-distinguisher 11.11.11.11:1
    set switch-options vrf-target target:1000:1
    set vlans FIFTY vlan-id 50
    set vlans FIFTY vxlan vni 5050
    set vlans FORTY vlan-id 40
    set vlans FORTY vxlan vni 4040
    set vlans SIXTY vlan-id 60
    set vlans SIXTY vxlan vni 6060
    set vlans TEN vlan-id 10
    set vlans TEN l3-interface irb.1010
    set vlans TEN vxlan vni 1010
    set vlans THIRTY vlan-id 30
    set vlans THIRTY l3-interface irb.3030
    set vlans THIRTY vxlan vni 3030
    set vlans TWENTY vlan-id 20
    set vlans TWENTY l3-interface irb.2020
    set vlans TWENTY vxlan vni 2020

    root@LEAF2# show | display set | no-more 
    set version 23.1R1.8
    set system host-name LEAF2
    set system root-authentication encrypted-password "$6$Bkz1QzqM$ZqFuuzCr9JJE4AHEStCJEEKeFX5tn5mVsXtrc9bpnT82o4eAgGd9ZqBlnKz3rmMVg9nLFwSCVlL0H/wYNYD6V1"
    set system services ssh root-login allow
    set system arp aging-timer 5
    set system syslog file interactive-commands interactive-commands any
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set chassis aggregated-devices ethernet device-count 1
    set interfaces ge-0/0/0 unit 0 family inet address 172.12.12.2/24
    set interfaces ge-0/0/1 unit 0 family inet address 172.22.22.2/24
    set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members 40
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members 50
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members 60
    set interfaces ge-0/0/3 ether-options 802.3ad ae0
    set interfaces ae0 esi 00:01:01:01:01:01:01:01:01:01
    set interfaces ae0 esi all-active
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp system-id 00:01:01:01:01:01
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members 10
    set interfaces ae0 unit 0 family ethernet-switching vlan members 20
    set interfaces ae0 unit 0 family ethernet-switching vlan members 30
    set interfaces ae0 unit 0 family ethernet-switching vlan members 40
    set interfaces ae0 unit 0 family ethernet-switching vlan members 50
    set interfaces ae0 unit 0 family ethernet-switching vlan members 60
    set interfaces fxp0 unit 0 family inet address 192.168.0.203/24
    set interfaces irb unit 1010 virtual-gateway-accept-data
    set interfaces irb unit 1010 family inet address 10.10.1.2/24 virtual-gateway-address 10.10.1.254
    set interfaces irb unit 2020 virtual-gateway-accept-data
    set interfaces irb unit 2020 family inet address 20.20.1.2/24 virtual-gateway-address 20.20.1.254
    set interfaces irb unit 3030 virtual-gateway-accept-data
    set interfaces irb unit 3030 family inet address 30.30.1.2/24 virtual-gateway-address 30.30.1.254
    set interfaces irb unit 4040 virtual-gateway-accept-data
    set interfaces irb unit 4040 family inet address 40.40.1.2/24 virtual-gateway-address 40.40.1.254
    set interfaces irb unit 5050 virtual-gateway-accept-data
    set interfaces irb unit 5050 family inet address 50.50.1.2/24 virtual-gateway-address 50.50.1.254
    set interfaces irb unit 6060 virtual-gateway-accept-data
    set interfaces irb unit 6060 family inet address 60.60.1.2/24 virtual-gateway-address 60.60.1.254
    set interfaces lo0 unit 0 family inet address 22.22.22.22/32
    set multi-chassis mc-lag
    set policy-options policy-statement EVPN_SHARE from protocol evpn
    set policy-options policy-statement EVPN_SHARE then accept
    set policy-options policy-statement FIFTY from interface irb.5050
    set policy-options policy-statement FIFTY from community FIFTY
    set policy-options policy-statement FIFTY then community add FIFTY
    set policy-options policy-statement FIFTY then accept
    set policy-options policy-statement FORTY from community FORTY
    set policy-options policy-statement FORTY then accept
    set policy-options policy-statement SIXTY from community SIXTY
    set policy-options policy-statement SIXTY then accept
    set policy-options policy-statement TEN from community TEN
    set policy-options policy-statement TEN then accept
    set policy-options policy-statement THIRTY from community THIRTY
    set policy-options policy-statement THIRTY then accept
    set policy-options policy-statement TWENTY from community TWENTY
    set policy-options policy-statement TWENTY then accept
    set policy-options policy-statement load-balancing-policy then load-balance per-packet
    set policy-options community FIFTY members target:5050:1
    set policy-options community FORTY members target:4040:1
    set policy-options community SIXTY members target:6060:1
    set policy-options community TEN members target:1010:1
    set policy-options community THIRTY members target:3030:1
    set policy-options community TWENTY members target:2020:1
    set routing-instances FIFTY instance-type vrf
    set routing-instances FIFTY routing-options multipath
    set routing-instances FIFTY routing-options auto-export
    set routing-instances FIFTY interface irb.5050
    set routing-instances FIFTY interface lo0.50
    set routing-instances FIFTY route-distinguisher 50.50.1.2:5050
    set routing-instances FIFTY vrf-import TEN
    set routing-instances FIFTY vrf-export TEN
    set routing-instances FIFTY vrf-target target:5050:1
    set routing-instances FORTY instance-type vrf
    set routing-instances FORTY routing-options auto-export
    set routing-instances FORTY interface irb.4040
    set routing-instances FORTY route-distinguisher 40.40.1.2:4040
    set routing-instances FORTY vrf-target target:4040:1
    set routing-instances SIXTY instance-type vrf
    set routing-instances SIXTY routing-options auto-export
    set routing-instances SIXTY interface irb.6060
    set routing-instances SIXTY route-distinguisher 60.60.1.2:6060
    set routing-instances SIXTY vrf-target target:6060:1
    set routing-instances TEN instance-type vrf
    set routing-instances TEN routing-options auto-export
    set routing-instances TEN interface irb.1010
    set routing-instances TEN route-distinguisher 10.10.1.2:1010
    set routing-instances TEN vrf-import FIFTY
    set routing-instances TEN vrf-target target:1010:1
    set routing-instances THIRTY instance-type vrf
    set routing-instances THIRTY routing-options auto-export
    set routing-instances THIRTY interface irb.3030
    set routing-instances THIRTY route-distinguisher 30.30.1.2:3030
    set routing-instances THIRTY vrf-target target:3030:1
    set routing-instances TWENTY instance-type vrf
    set routing-instances TWENTY routing-options auto-export
    set routing-instances TWENTY interface irb.2020
    set routing-instances TWENTY route-distinguisher 20.20.1.2:2020
    set routing-instances TWENTY vrf-target target:2020:1
    set routing-options router-id 22.22.22.22
    set routing-options autonomous-system 65001
    set routing-options forwarding-table export load-balancing-policy
    set protocols router-advertisement interface fxp0.0 managed-configuration
    set protocols bgp group LEAF type internal
    set protocols bgp group LEAF local-address 22.22.22.22
    set protocols bgp group LEAF family evpn signaling
    set protocols bgp group LEAF neighbor 1.1.1.1
    set protocols bgp group LEAF neighbor 2.2.2.2
    set protocols evpn encapsulation vxlan
    set protocols evpn default-gateway no-gateway-community
    set protocols evpn multicast-mode ingress-replication
    set protocols evpn vni-options vni 1010 vrf-target target:1010:1
    set protocols evpn vni-options vni 2020 vrf-target target:2020:1
    set protocols evpn vni-options vni 3030 vrf-target target:3030:1
    set protocols evpn vni-options vni 4040 vrf-target target:4040:1
    set protocols evpn vni-options vni 5050 vrf-target target:5050:1
    set protocols evpn vni-options vni 6060 vrf-target target:6060:1
    set protocols evpn extended-vni-list all
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols lldp interface all
    set protocols lldp-med interface all
    set protocols igmp-snooping vlan default
    set switch-options vtep-source-interface lo0.0
    set switch-options route-distinguisher 22.22.22.22:1
    set switch-options vrf-target target:1000:1
    set vlans FIFTY vlan-id 50
    set vlans FIFTY l3-interface irb.5050
    set vlans FIFTY vxlan vni 5050
    set vlans FORTY vlan-id 40
    set vlans FORTY l3-interface irb.4040
    set vlans FORTY vxlan vni 4040
    set vlans SIXTY vlan-id 60
    set vlans SIXTY l3-interface irb.6060
    set vlans SIXTY vxlan vni 6060
    set vlans TEN vlan-id 10
    set vlans TEN l3-interface irb.1010
    set vlans TEN vxlan vni 1010
    set vlans THIRTY vlan-id 30
    set vlans THIRTY l3-interface irb.3030
    set vlans THIRTY vxlan vni 3030
    set vlans TWENTY vlan-id 20
    set vlans TWENTY l3-interface irb.2020
    set vlans TWENTY vxlan vni 2020

    root@LEAF3# show | display set | no-more 
    set version 23.1R1.8
    set system host-name LEAF3
    set system root-authentication encrypted-password "$6$t4kcdt3x$rZByILwNxJEq8UoeXFmPWMtBS/ufls5Cs8569m5Y7K69xPZyq5HlK4qUe2X581qiHlSVcb.58jF7WIgWEA3.70"
    set system services ssh root-login allow
    set system arp aging-timer 5
    set system syslog file interactive-commands interactive-commands any
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set chassis aggregated-devices ethernet device-count 1
    set interfaces ge-0/0/0 unit 0 family inet address 172.13.13.2/24
    set interfaces ge-0/0/1 unit 0 family inet address 172.23.23.2/24
    set interfaces ge-0/0/2 ether-options 802.3ad ae0
    set interfaces ae0 esi 00:01:01:01:01:01:01:01:01:01
    set interfaces ae0 esi all-active
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp system-id 00:01:01:01:01:01
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members 10
    set interfaces ae0 unit 0 family ethernet-switching vlan members 20
    set interfaces ae0 unit 0 family ethernet-switching vlan members 30
    set interfaces ae0 unit 0 family ethernet-switching vlan members 40
    set interfaces ae0 unit 0 family ethernet-switching vlan members 50
    set interfaces ae0 unit 0 family ethernet-switching vlan members 60
    set interfaces fxp0 unit 0 family inet address 192.168.0.204/24
    set interfaces irb unit 1010 virtual-gateway-accept-data
    set interfaces irb unit 1010 family inet address 10.10.1.3/24 virtual-gateway-address 10.10.1.254
    set interfaces irb unit 2020 virtual-gateway-accept-data
    set interfaces irb unit 2020 family inet address 20.20.1.3/24 virtual-gateway-address 20.20.1.254
    set interfaces irb unit 3030 virtual-gateway-accept-data
    set interfaces irb unit 3030 family inet address 30.30.1.3/24 virtual-gateway-address 30.30.1.254
    set interfaces irb unit 4040 virtual-gateway-accept-data
    set interfaces irb unit 4040 family inet address 40.40.1.3/24 virtual-gateway-address 40.40.1.254
    set interfaces irb unit 5050 virtual-gateway-accept-data
    set interfaces irb unit 5050 family inet address 50.50.1.3/24 virtual-gateway-address 50.50.1.254
    set interfaces irb unit 6060 virtual-gateway-accept-data
    set interfaces irb unit 6060 family inet address 60.60.1.3/24 virtual-gateway-address 60.60.1.254
    set interfaces lo0 unit 0 family inet address 33.33.33.33/32
    set multi-chassis mc-lag
    set policy-options policy-statement FIFTY from community FIFTY
    set policy-options policy-statement FIFTY then accept
    set policy-options policy-statement FORTY from community FORTY
    set policy-options policy-statement FORTY then accept
    set policy-options policy-statement SIXTY from community SIXTY
    set policy-options policy-statement SIXTY then accept
    set policy-options policy-statement TEN from community TEN
    set policy-options policy-statement TEN then accept
    set policy-options policy-statement THIRTY from community THIRTY
    set policy-options policy-statement THIRTY then accept
    set policy-options policy-statement TWENTY from community TWENTY
    set policy-options policy-statement TWENTY then accept
    set policy-options policy-statement load-balancing-policy then load-balance per-packet
    set policy-options community FIFTY members target:5050:1
    set policy-options community FORTY members target:4040:1
    set policy-options community SIXTY members target:6060:1
    set policy-options community TEN members target:1010:1
    set policy-options community THIRTY members target:3030:1
    set policy-options community TWENTY members target:2020:1
    set routing-instances FIFTY instance-type vrf
    set routing-instances FIFTY routing-options auto-export
    set routing-instances FIFTY interface irb.5050
    set routing-instances FIFTY route-distinguisher 50.50.1.3:5050
    set routing-instances FIFTY vrf-import TEN
    set routing-instances FIFTY vrf-target target:5050:1
    set routing-instances FORTY instance-type vrf
    set routing-instances FORTY routing-options auto-export
    set routing-instances FORTY interface irb.4040
    set routing-instances FORTY route-distinguisher 40.40.1.3:4040
    set routing-instances FORTY vrf-target target:4040:1
    set routing-instances SIXTY instance-type vrf
    set routing-instances SIXTY routing-options auto-export
    set routing-instances SIXTY interface irb.6060
    set routing-instances SIXTY route-distinguisher 60.60.1.3:6060
    set routing-instances SIXTY vrf-target target:6060:1
    set routing-instances TEN instance-type vrf
    set routing-instances TEN routing-options auto-export
    set routing-instances TEN interface irb.1010
    set routing-instances TEN route-distinguisher 10.10.1.3:1010
    set routing-instances TEN vrf-import FIFTY
    set routing-instances TEN vrf-target target:1010:1
    set routing-instances THIRTY instance-type vrf
    set routing-instances THIRTY routing-options auto-export
    set routing-instances THIRTY interface irb.3030
    set routing-instances THIRTY route-distinguisher 30.30.1.3:3030
    set routing-instances THIRTY vrf-target target:3030:1
    set routing-instances TWENTY instance-type vrf
    set routing-instances TWENTY routing-options auto-export
    set routing-instances TWENTY interface irb.2020
    set routing-instances TWENTY route-distinguisher 20.20.1.3:2020
    set routing-instances TWENTY vrf-target target:2020:1
    set routing-options router-id 33.33.33.33
    set routing-options autonomous-system 65001
    set routing-options forwarding-table export load-balancing-policy
    set protocols router-advertisement interface fxp0.0 managed-configuration
    set protocols bgp group LEAF type internal
    set protocols bgp group LEAF local-address 33.33.33.33
    set protocols bgp group LEAF family evpn signaling
    set protocols bgp group LEAF neighbor 1.1.1.1
    set protocols bgp group LEAF neighbor 2.2.2.2
    set protocols evpn encapsulation vxlan
    set protocols evpn default-gateway no-gateway-community
    set protocols evpn multicast-mode ingress-replication
    set protocols evpn vni-options vni 1010 vrf-target target:1010:1
    set protocols evpn vni-options vni 2020 vrf-target target:2020:1
    set protocols evpn vni-options vni 3030 vrf-target target:3030:1
    set protocols evpn vni-options vni 4040 vrf-target target:4040:1
    set protocols evpn vni-options vni 5050 vrf-target target:5050:1
    set protocols evpn vni-options vni 6060 vrf-target target:6060:1
    set protocols evpn extended-vni-list all
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols lldp interface all
    set protocols lldp-med interface all
    set protocols igmp-snooping vlan default
    set switch-options vtep-source-interface lo0.0
    set switch-options route-distinguisher 33.33.33.33:1
    set switch-options vrf-target target:1000:1
    set switch-options vrf-target auto
    set vlans FIFTY vlan-id 50
    set vlans FIFTY l3-interface irb.5050
    set vlans FIFTY vxlan vni 5050
    set vlans FORTY vlan-id 40
    set vlans FORTY l3-interface irb.4040
    set vlans FORTY vxlan vni 4040
    set vlans SIXTY vlan-id 60
    set vlans SIXTY l3-interface irb.6060
    set vlans SIXTY vxlan vni 6060
    set vlans TEN vlan-id 10
    set vlans TEN l3-interface irb.1010
    set vlans TEN vxlan vni 1010
    set vlans THIRTY vlan-id 30
    set vlans THIRTY l3-interface irb.3030
    set vlans THIRTY vxlan vni 3030
    set vlans TWENTY vlan-id 20
    set vlans TWENTY l3-interface irb.2020
    set vlans TWENTY vxlan vni 2020

    Here are the routuing tables from LEAFS:

    LEAF1:

    TEN.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
    @ = Routing Use Only, # = Forwarding Use Only
    + = Active Route, - = Last Active, * = Both
    10.10.1.0/24       *[Direct/0] 00:37:27
                        >  via irb.1010
    10.10.1.1/32       *[Local/0] 00:37:27
                           Local via irb.1010
    10.10.1.10/32      *[EVPN/7] 00:29:26   
                        >  via irb.1010
    10.10.1.254/32     *[Local/0] 00:37:27
                           Local via irb.1010
    10.10.10.10/32     *[Direct/0] 00:37:27
                        >  via lo0.10
    THIRTY.inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    30.30.1.0/24       *[Direct/0] 00:37:27
                        >  via irb.3030
    30.30.1.1/32       *[Local/0] 00:37:27
                           Local via irb.3030
    30.30.1.10/32      *[EVPN/7] 00:29:37
                        >  via irb.3030
    30.30.1.254/32     *[Local/0] 00:37:27
                           Local via irb.3030
    TWENTY.inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    20.20.1.0/24       *[Direct/0] 00:37:27
                        >  via irb.2020
    20.20.1.1/32       *[Local/0] 00:37:27
                           Local via irb.2020
    20.20.1.254/32     *[Local/0] 00:37:27
                           Local via irb.2020

    LEAF2:

    FIFTY.inet.0: 9 destinations, 9 routes (9 active, 0 holddown, 0 hidden)
    @ = Routing Use Only, # = Forwarding Use Only
    + = Active Route, - = Last Active, * = Both
    10.10.1.0/24       *[Direct/0] 00:29:05
                        >  via irb.1010
    10.10.1.2/32       *[Local/0] 00:29:05
                           Local via irb.1010
    10.10.1.30/32      *[EVPN/7] 00:29:04   
                        >  via irb.1010
    10.10.1.254/32     *[Local/0] 00:29:05
                           Local via irb.1010
    50.50.1.0/24       *[Direct/0] 00:54:16
                        >  via irb.5050
    50.50.1.2/32       *[Local/0] 00:54:16
                           Local via irb.5050
    50.50.1.20/32      *[EVPN/7] 00:17:50
                        >  via irb.5050
    50.50.1.30/32      *[EVPN/7] 00:03:09
                        >  via irb.5050
    50.50.1.254/32     *[Local/0] 00:54:16
                           Local via irb.5050
    FORTY.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    40.40.1.0/24       *[Direct/0] 00:54:16
                        >  via irb.4040
    40.40.1.2/32       *[Local/0] 00:54:16
                           Local via irb.4040
    40.40.1.20/32      *[EVPN/7] 00:16:29
                        >  via irb.4040
    40.40.1.30/32      *[EVPN/7] 00:15:21
                        >  via irb.4040     
    40.40.1.254/32     *[Local/0] 00:54:16
                           Local via irb.4040
    SIXTY.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    60.60.1.0/24       *[Direct/0] 00:54:16
                        >  via irb.6060
    60.60.1.2/32       *[Local/0] 00:54:16
                           Local via irb.6060
    60.60.1.20/32      *[EVPN/7] 00:15:33
                        >  via irb.6060
    60.60.1.30/32      *[EVPN/7] 00:15:32
                        >  via irb.6060
    60.60.1.254/32     *[Local/0] 00:54:16
                           Local via irb.6060
    TEN.inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    10.10.1.0/24       *[Direct/0] 00:29:05
                        >  via irb.1010
    10.10.1.2/32       *[Local/0] 00:29:05
                           Local via irb.1010
    10.10.1.30/32      *[EVPN/7] 00:29:04
                        >  via irb.1010
    10.10.1.254/32     *[Local/0] 00:29:05  
                           Local via irb.1010
    50.50.1.0/24       *[Direct/0] 00:18:31
                        >  via irb.5050
    50.50.1.20/32      *[EVPN/7] 00:17:50
                        >  via irb.5050
    50.50.1.30/32      *[EVPN/7] 00:03:09
                        >  via irb.5050
    THIRTY.inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    30.30.1.0/24       *[Direct/0] 00:29:05
                        >  via irb.3030
    30.30.1.2/32       *[Local/0] 00:29:05
                           Local via irb.3030
    30.30.1.254/32     *[Local/0] 00:29:05
                           Local via irb.3030
    TWENTY.inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    20.20.1.0/24       *[Direct/0] 00:29:05
                        >  via irb.2020
    20.20.1.2/32       *[Local/0] 00:29:05
                           Local via irb.2020
    20.20.1.30/32      *[EVPN/7] 00:28:58
                        >  via irb.2020     
    20.20.1.254/32     *[Local/0] 00:29:05
                           Local via irb.2020

    LEAF3:

    FIFTY.inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    10.10.1.0/24       *[Direct/0] 00:32:10
                        >  via irb.1010
    10.10.1.3/32       *[Local/0] 00:32:10
                           Local via irb.1010
    10.10.1.30/32      *[EVPN/7] 00:29:22
                        >  via irb.1010     
    10.10.1.254/32     *[Local/0] 00:32:10
                           Local via irb.1010
    50.50.1.0/24       *[Direct/0] 00:53:08
                        >  via irb.5050
    50.50.1.3/32       *[Local/0] 00:53:08
                           Local via irb.5050
    50.50.1.30/32      *[EVPN/7] 00:03:28
                        >  via irb.5050
    50.50.1.254/32     *[Local/0] 00:53:08
                           Local via irb.5050
    FORTY.inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    40.40.1.0/24       *[Direct/0] 00:53:08
                        >  via irb.4040
    40.40.1.3/32       *[Local/0] 00:53:08
                           Local via irb.4040
    40.40.1.30/32      *[EVPN/7] 00:15:39
                        >  via irb.4040
    40.40.1.254/32     *[Local/0] 00:53:08
                           Local via irb.4040
    SIXTY.inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    60.60.1.0/24       *[Direct/0] 00:53:08 
                        >  via irb.6060
    60.60.1.3/32       *[Local/0] 00:53:08
                           Local via irb.6060
    60.60.1.30/32      *[EVPN/7] 00:15:51
                        >  via irb.6060
    60.60.1.254/32     *[Local/0] 00:53:08
                           Local via irb.6060
    TEN.inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    10.10.1.0/24       *[Direct/0] 00:53:08
                        >  via irb.1010
    10.10.1.3/32       *[Local/0] 00:53:08
                           Local via irb.1010
    10.10.1.30/32      *[EVPN/7] 00:29:22
                        >  via irb.1010
    10.10.1.254/32     *[Local/0] 00:53:08
                           Local via irb.1010
    50.50.1.0/24       *[Direct/0] 00:32:10
                        >  via irb.5050
    50.50.1.3/32       *[Local/0] 00:32:10
                           Local via irb.5050
    50.50.1.30/32      *[EVPN/7] 00:03:28
                        >  via irb.5050     
    50.50.1.254/32     *[Local/0] 00:32:10
                           Local via irb.5050
    THIRTY.inet.0: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    30.30.1.0/24       *[Direct/0] 00:53:08
                        >  via irb.3030
    30.30.1.3/32       *[Local/0] 00:53:08
                           Local via irb.3030
    30.30.1.254/32     *[Local/0] 00:53:08
                           Local via irb.3030
    TWENTY.inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    20.20.1.0/24       *[Direct/0] 00:53:08
                        >  via irb.2020
    20.20.1.3/32       *[Local/0] 00:53:08
                           Local via irb.2020
    20.20.1.30/32      *[EVPN/7] 00:29:16
                        >  via irb.2020
    20.20.1.254/32     *[Local/0] 00:53:08
                           Local via irb.2020

    • i can ping hosts in the same vlan just fine
    • i can ping the gateway on leaf2 from host connected to leaf3 (from vlan 10 to vlan 50) but i cant ping host in leaf 2 from the same vlan
    • vrf import appear to be not working on leaf1

    How can i fix this, cannot find more information online and from what i found the config should be working.

    Regards,

    Alex



    ------------------------------
    ALEXANDRU MINZAT
    ------------------------------