Junos OS

 View Only
last person joined: 4 days ago 

Ask questions and share experiences about Junos OS.
  • 1.  Direct ping doesn't work on vQFX but it works using bypass-routing

    Posted 07-18-2023 10:20

    We have vQFX deployed on EVE-NG server.  The issue is in pinging our default gateway or other box (in the eve-ng or outside of eve-ng) doesn't work.

    Samething works with bypass-routing command.

    Works                       =>    ping bypass-routing routing-instance mgmt_junos 16.78.48.1

    Doesn't work        =>    ping 16.78.48.1

    How device config output looks like below:

    em0 {
            unit 0 {
                family inet {
                    address 16.78.49.53/20;
                }
            }
        }

    routing-options {
        static {
            route 0.0.0.0/0 next-hop 16.78.48.1;
        }
    }

    mgmt_junos {
            routing-options {
                static {
                    route 0.0.0.0/0 next-hop 16.78.48.1;
                }
            }
            description qfx-desc;
        }



    ------------------------------
    SHIKHA TANDON
    ------------------------------



  • 2.  RE: Direct ping doesn't work on vQFX but it works using bypass-routing

    Posted 07-19-2023 06:54

    Hello,

    I have had many issues with vQFX before, one command to make sure its working correctly is show chassis hardware, and I found this blog:  https://jncie.eu/  for all things eve-ng/JUNOS, he has done them all! :) , most of the time when it comes to eve-ng and junos is to do with the image and some little things you need to tweak.



    ------------------------------
    ROBERTO SOTO
    ------------------------------



  • 3.  RE: Direct ping doesn't work on vQFX but it works using bypass-routing

    Posted 07-19-2023 12:47

    vQFX runs very nice in EVE-NG.  I've used it many times.  I have not had this issue you mention about pinging other devices.  See the video I made where I show various things related to vQFX.  Hope it helps.

    ....here's where I start talking about how I connected them...
    https://www.youtube.com/watch?v=jZY5JhEoY9s&t=65s

    ...here's where I start pinging between vQFX instances....
    https://www.youtube.com/watch?v=jZY5JhEoY9s&t=860s



    ------------------------------
    - Aaron
    ------------------------------



  • 4.  RE: Direct ping doesn't work on vQFX but it works using bypass-routing

    Posted 09-13-2023 10:37

    Arron, thanks for your videos. Shikha and I have narrowed the problem down to a issue with the default gateway. 

    set routing-options static route 0.0.0.0/0 next-hop 16.78.4.1
    set routing-options static route 16.78.48.0/20 next-hop 16.78.48.1
    set routing-options static route 16.78.48.0/20 retain
    set routing-options static route 16.78.48.0/20 no-readvertise
    set routing-options static route 10.88.0.0/16 next-hop 16.78.48.1
    set routing-options static route 10.88.0.0/16 retain
    set routing-options static route 10.88.0.0/16 no-readvertise
    set routing-options static route 15.0.0.0/8 next-hop 16.78.48.1
    set routing-options static route 15.0.0.0/8 retain
    set routing-options static route 15.0.0.0/8 no-readvertise

    In the above, we route all networks to the same gateway address. Adding the additional non-sense routing options for the specific routes, seems to fix the issue when we attempt to ping with (no route to host).  So the question is why wouldn't the default route get selected to begin with.  

    And this fixes both ping into the router from 10.88 network and ping out of the router to 10.88 network addresses.

    Note, I used your qfx to qfx with a management port added on em0 with gateway setup to that same network. 

    I've tried experimenting with the route-options to see if I could get gateway working by adding the other options(no-readvertize and retain). But same behavior of gateway not applied seems to be prevalent. 

    Kevin



    ------------------------------
    KEVIN WILSON
    ------------------------------