Switching

 View Only
last person joined: 5 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Connecting 4550 SW to existing 4600 SW

    Posted 11-08-2022 10:25
    Good Afternoon All,

    I am working working on a project connecting 2 Juniper SWs. a 4550 ( blank / new SW ) with the existing 4600 ( configured in production ).

    I am having issues trunking the 2 SWs together and cannot pass data. I have see the other SW from a "show lldp neighbors" command but am not passing data.

    Any help would be appreciated. 


    ------------------------------
    Salvador Marin
    ------------------------------


  • 2.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-08-2022 13:03
    Can you share the configuration of the connected ports?

    I assume this is a basic multiple vlan trunk port

    https://supportportal.juniper.net/s/article/EX-QFX-Example-Configuring-VLANS-and-Trunking

    Or are you created a multi-interface AE link?

    https://www.juniper.net/documentation/us/en/software/junos/virtual-chassis-ex-4200-4500/topics/example/interfaces-aggregated-ethernet-virtual-chassis-uplinks.html

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-08-2022 17:00
    I have tried to connect via AE. I am new to Juniper

    4600

    set int ae4 desc ""
    set int ae4 enable
    set int ae4 aggregated-ether-options lacp active
    set int ae4 aggregated-ether-options lacp periodic fast
    set int ae4 unit 0 family ethernet-switching interface-mode trunk
    set int ae4 unit 0 family ethernet-switching vlan members management


    set int ge-0/0/5 des""
    set int ge-0/0/5 speed 1g
    set int ge-0/0/5 ether options 802.3ad ae4

    4550

    set int ae1 desc ""
    set int ae1 enable
    set int ae1 aggregated-ether-options lacp active
    set int ae1 aggregated-ether-options lacp periodic fast
    set int ae1 unit 0 family ethernet-switching interface-mode trunk
    set int ae1 unit 0 family ethernet-switching vlan members management


    set int ge-0/0/30 des""
    set int ge-0/0/30 enable
    set int ge-0/0/30 ether options 802.3ad ae1

    ------------------------------
    Salvador Marin
    ------------------------------



  • 4.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-08-2022 17:00

    4550 SW

    Set int ae1 enable

    Set int ae1 aggregated-ether-options lacp active

    Set int ae1 aggregated-ether-options lacp periodic fast

    Set int ae1 unit 0 family ethernet-switching port-mode trunk

    Set int ae1 unit 0 family ethernet-switching plan members management

    set int ge-0/0/30 des""

    set int ge-0/0/30 ether options 802.3ad ae1

    4600 SW

    Set int ae4 enable

    Set int ae4 aggregated-ether-options lacp active

    Set int ae4 aggregated-ether-options lacp periodic fast

    Set int ae4 unit 0 family ethernet-switching port-mode trunk

    Set int ae4 unit 0 family ethernet-switching plan members management

    set int ge-0/0/5 des""

    set int ge-0/0/5 speed 1g

    set int ge-0/0/5 ether options 802.3ad ae4



    ------------------------------
    Salvador Marin
    ------------------------------



  • 5.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-09-2022 19:30
    These portions look good.  Do you also have the following
    • the ae device count set
    • the vlan created with the same vlan id on both devices

    What is the interface status
    show interface terse

    How are you testing connectivity?  Other interfaces in the vlan with devices or layer 3 interfaces on the switch or some other method?

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 6.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-09-2022 20:14
    The ae count on the 4600 is higher because on the SW i believe its around 0-14 ( ae4 was unused to i created the group using that set )
    For the 4550 i created 5 ( that was the blank SW that i hand transferred some of the basic configs over from either a 4600 or 4300 )

    When i created the 4550 i made sure to give it the same vlan id.

    On both SW the ae and the ge for the above commands are both UP UP.

    Im testing the connection by just attempting to PING from one SW to another.

    On the 4600 its our SW thats in Production and has a couple of Firewalls and a couple of SW coming off of it. Also has users. Alot of the other ae sets are very similar in Layer 2. There is only 1 Layer 3 ae group and that is connected for the Firewall. The other ae groups for the other SWs are Layer 2 using a very similar command lines ( Like i said just tried to copy to make it easy since im new to Juniper )

    We have another SW that is just a user access SW for a different room and i tried to copy a lot of the configs from that one to the new 4550. ( thats the 4300 or 4600 i mentioned earlier in this message )

    ------------------------------
    Salvador Marin
    ------------------------------



  • 7.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-12-2022 20:05
    The ping test is layer 3 with an ip address that would need to be in the same subnet as the vlan being tested on both switches.  These trunk port will only have the layer 2 connection between the two switches.

    So to test internally you would need an irb on both switches in the same vlan as the trunk port and in the same subnet on both sides.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 8.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-12-2022 20:20

    Is there any way you can help me out with examples to set IRBs on both the 4600 and 4550?

    I believe the 4600 has some IRB already or it's the 4300 we use. 

    For layer2 how can I see if I'm passing data across from the Production SW to the new access SW? Just want to set it up for about 6 users in a different area.

    Thanks!!!



    ------------------------------
    Salvador Marin
    ------------------------------



  • 9.  RE: Connecting 4550 SW to existing 4600 SW

    Posted 11-12-2022 20:13
    Also the ping I have being trying to hit is the IP for the me port ( management port. The way I have been in the SW this whole time )

    thanks!

    ------------------------------
    Salvador Marin
    ------------------------------