Management

 View Only
last person joined: 14 days ago 

Ask questions and share experiences with Junos Space and network management.
  • 1.  Junos Space and EVEng. has anyone got this working ? if so what version

    Posted 06-18-2021 18:25

    I have followed instructions on eveng and also posted in their forums but to no avail. 

    My space starts up but only gets so far but at a certain point the boot up process appears to stall. 
    does anyone know the secret to get this working. 



    ------------------------------
    Simon Bingham
    ------------------------------


  • 2.  RE: Junos Space and EVEng. has anyone got this working ? if so what version

    Posted 06-19-2021 14:03
    Hi,

    which junos space version n eve-ng version that u use? Im dont have face the issue using any junos space version in eve-ng/pnetlab.

    Thanks


  • 3.  RE: Junos Space and EVEng. has anyone got this working ? if so what version

    Posted 06-19-2021 16:34
    Edited by jeff 06-19-2021 16:34
    I just installed Space 19.4R1.4 on my EVE-NG server following the EVE-NG guide with no issues.  I even played around setting the CPU to 2 and memory to 2g, it still booted every time with no issues.  

    I am suspecting that the image you are using may have an issue ( maybe corrupt ) - see if you can re-download the image from Juniper and add it to your server again.



    ------------------------------
    Jeff Fry

    ------------------------------



  • 4.  RE: Junos Space and EVEng. has anyone got this working ? if so what version

    Posted 06-19-2021 18:10
    Edited by Simon Bingham (technical debt collector) 06-19-2021 18:11

    Hi,

    I have tried 16,1 , 19.3 and 21.1R1.4 , all 3 seem to have the same issue from what I can work out from googling the error its looking for a floppy drive that does not exist. 

    I'm using in eve community , could this be an issue with the QEMU custom options. ?
    are yours the same ?  

    does the screen shot of my settings look the same as yours.

    Thanks again , Simon



    ------------------------------
    Simon Bingham
    ------------------------------



  • 5.  RE: Junos Space and EVEng. has anyone got this working ? if so what version

    Posted 06-20-2021 03:06

    Thanks I have tried 3 versions, this is very odd

    I download the  "KVM Image for Virtual Appliance" cow2 file from Juniper upload  to eve and then rename the filename exactly as suggested.  and run  the "fix permissions "

    I'm using EVE community. 

    I'm running Linux boxes, vSRX, vMX vQFX all on the same platform with no problems at all. 

    Its looking like my space install is looking for a disk that does not exist "dev fd0"

    root@eve-ng:/opt/unetlab/addons/qemu# ls -lnh
    drwxr-xr-x 2 0 0 4.0K Jun 19 11:45 jspace-16.1R1.7-001
    drwxr-xr-x 2 0 0 4.0K May 29 13:36 jspace-19.3R1.3
    drwxr-xr-x 2 0 0 4.0K Jun 19 11:44 jspace-21.1R1.4

    root@eve-ng:/opt/unetlab/addons/qemu# cd jspace-21.1R1.4
    root@eve-ng:/opt/unetlab/addons/qemu/jspace-21.1R1.4# ls
    virtioa.qcow2
    root@eve-ng:/opt/unetlab/addons/qemu/jspace-21.1R1.4# 

    I think this must be the eve template. it seems my VM is expecting to find a drive. 

    is there any chance you could screen shot the template for me, I wonder about the QEMU custom options. 

    Thanks again for your time 



    ------------------------------
    Simon Bingham
    ------------------------------



  • 6.  RE: Junos Space and EVEng. has anyone got this working ? if so what version

    Posted 06-20-2021 16:12
    Here the yml file that is on my EVE-NG server.  For reference, I am running EVE-NG Professional v4.01-16-PRO  on Ubuntu  18.04.5 LTS



    ------------------------------
    Jeff
    ( aka Fryguy )
    ------------------------------



  • 7.  RE: Junos Space and EVEng. has anyone got this working ? if so what version

    Posted 12-22-2021 20:17
    Hello Simon,  Were you able to solve this issue?  I'm facing same one.

    ------------------------------
    Manuel Serrano
    ------------------------------