Junos OS

 View Only
last person joined: 18 hours ago 

Ask questions and share experiences about Junos OS.
  • 1.  Failed to deploy JunOS vMX 18 on ESXI 6.5

    Posted 01-12-2022 09:33
    Hi Everybody
    Recently I got a new ESXI 6.5 server and I tried to deploy a vMX image on it. I am using "vmx-bundle-esxi-18.1R1.9".
    Everything worked fine during the deployment procedure but when I started the vCP and vFPC machines I ran into the problem.

    When vCP booted up and tries to communicate with vFCP, it tries to start the riot process but it fails and generates an error log(see the attachment).

    After this log, the following log is generated on the vFPC console constantly:

    VMXT not running. sleeping

    I searched google and I found out this is related to FPC mode configuration on CP so I changed it to lite mode but there was no luck. 
    The CPU/RAM configurations of Machines are as follow:
    CPU: 8 core
    RAM: 16 GB 

    CPU: 8 core
    RAM: 8 GB 
    In some tries I also have this log on vFPC console:
    Jan 12 10:03:52 localhost user.notice root: : /home/pfe/riot/build/app/riot -c 0xff -n 2 --log-level=5 -- --rx "" --tx "" --w "3,4,5,6,7" --f "1" --l2_mode "1" --rpio "local,3000,3001" -hostif"local,3002" --bsz "(32,32),(64,64),(512,512)"
    Another important clue is I deployed this image on an ESXI 6.0 before and there was no issue. Unfortunately, that machine is not accessible anymore.

    Would you please help me out with this issue?
    Thank you

    Ali Soltan

  • 2.  RE: Failed to deploy JunOS vMX 18 on ESXI 6.5

    Posted 01-12-2022 14:23
      |   view attached
    Sorry, I forgot to attach the log. This reply is for that purpose.
    Also, I want to ask does version 18.1 of vMX support ESXI 6.5?
    And should I change the CPU/MMU Virtualization for each machine?
    Thank you

    Ali Soltan


    vFPC_Error.txt   8 KB 1 version