Junos OS

 View Only
last person joined: yesterday 

Ask questions and share experiences about Junos OS.
  • 1.  Upgrade MX204. ERROR: Require 12 kernel support

    Posted 02-14-2022 10:13
    Trying to upgrade junos from 21.1R3.11 to 21.2R1.10 errors occur "ERROR: Require 12 kernel support"

    > request vmhost software validate /var/tmp/junos-vmhost-install-mx-x86-64-21.2R1.10.tgz
    Junos Validation begin. Procedure will take few minutes.
    Initializing...
    Verified os-libs-12-x86-64-20210529 signed by PackageProductionECP256_2021 method ECDSA256+SHA256
    ERROR: Require 12 kernel support
    Verified os-runtime-x86-64-20210529 signed by PackageProductionECP256_2021 method ECDSA256+SHA256
    ERROR: Require 12 kernel support
    Verified os-zoneinfo-20210529 signed by PackageProductionECP256_2021 method ECDSA256+SHA256
    Mounting os-zoneinfo-20210529.2f59a40_builder_stable_12
    Verified junos-net-prd-x86-64-20210621 signed by PackageProductionECP256_2021 method ECDSA256+SHA256
    ............
    chroot: pwd_mkdb: No such file or directory
    Hardware Database regeneration succeeded
    Validating against /config/juniper.conf.gz
    Abort trap (core dumped)
    Validation failed
    ERROR: Failed to add /var/tmp/junos-vmhost-install-mx-x86-64-21.2R1.10.tgz
    warning: Host software installation has failed.

    > show version
    Model: mx204
    Junos: 21.1R3.11
    JUNOS OS Kernel 64-bit [20211011.a9cfe96_builder_stable_11]

    any ideas??

    ------------------------------
    MAXIM AGAPOV
    ------------------------------


  • 2.  RE: Upgrade MX204. ERROR: Require 12 kernel support

    Posted 02-15-2022 09:59

    Problem solved!

    It was necessary to add no-validate, that is to say:
    request vmhost software add /var/tmp/junos-vmhost-install-mx-x86-64-21.2R1.10.tgz no-validate

    > show version
    Hostname: jRT201.DC
    Model: mx204
    Junos: 21.2R1.10
    JUNOS OS Kernel 64-bit [20210529.2f59a40_builder_stable_12]

    https://www.juniper.net/documentation/us/en/software/junos/junos-install-upgrade/topics/topic-map/upgrading-and-downgrading-to-upgraded-bsd.html#d14e511



    ------------------------------
    MAXIM AGAPOV
    ------------------------------



  • 3.  RE: Upgrade MX204. ERROR: Require 12 kernel support

    Posted 09-22-2022 19:26
    Hello

    I faced the same issue on MX204
    My path upgrade was: 19.4R3-S1.3 (initial version)----1step----> 20.2R3-S5.6 ----2step------> 20.4R3-S4.8 ----3step-----> 21.2R3-S2.9

    My first step (1step) and second step (2step), the command below help to upgrade
    request vmhost software add /var/tmp/junos-vmhost-install-mx-x86-64-20.xRx-Sx
    But the last step (3step) no-validate was mandatory to upgrade successfully (without no-validate at the end, the upgrade was failling with this error

    ERROR: Require 12 kernel support

    Validation failed
    ERROR: Failed to add /var/tmp/junos-vmhost-install-mx-x86-64-21.2R3-S2.9.tgz
    warning: Host software installation has failed.

    Do you know why we have this behavior ?

    Thank you.


  • 4.  RE: Upgrade MX204. ERROR: Require 12 kernel support

    Posted 09-23-2022 06:42
    There is a PR about this: https://prsearch.juniper.net/problemreport/PR1568757

    ------------------------------
    CHRIS JONES
    ------------------------------