Junos OS

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Trouble enabling 100g port

    Posted 07-01-2022 05:18
    Hello,

    I am in the process of setting up our first Juniper MX204, running junos 22.R1.10. 

    Unfortunately, I am largely being left to my own devices in terms of learning how to configure this, and I'm starting with zero experience of Juniper devices, so any advice will be appreciated.

    At the moment, I am tryionmg to bring up a link between us and our partners using et-0/0/0 in a lag interface, I have the interface configured as follows

    interfaces {
    et-0/0/0 {
    gigether-options {
    802.3ad ae2;
    }
    }


    and I have the lag interface configured

    }
    ae2 {
    description LINK_TO_OFNL;
    mtu 2000;
    aggregated-ether-options {
    lacp {
    active;
    }
    }
    }

    When I run show interfaces terse, this still shows as link down, even though the remote end is running.

    Am I missing something here?






    ------------------------------
    KEVIN RIDING
    ------------------------------


  • 2.  RE: Trouble enabling 100g port

     
    Posted 07-01-2022 05:50
    Do you have the number of ae interfaces allowed configured?
    set chassis aggregated-devices ethernet device-count 3

    Note that interfaces start numbering at 0 so to configure ae2 you would need 3 allowed interfaces.

    Also is the physical interfaces showing link up?

    And to actually pass traffic you will need to configure units on the interface with ip address or layer 2 associated configuration.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: Trouble enabling 100g port

     
    Posted 07-01-2022 06:43

    In addition to what Steve suggests, make sure you've set the port speeds. 

    https://phil.lavin.me.uk/2019/04/juniper-mx204-enabling-100g-ports/




  • 4.  RE: Trouble enabling 100g port

    Posted 07-06-2022 05:33
    Hi smicker,

    Thank you for your advice, I have already set these up following another blog to the one you posted, this had originally caught me out in the beginning. It had definitely been a journey for learning :)

    ------------------------------
    KEVIN RIDING
    ------------------------------



  • 5.  RE: Trouble enabling 100g port

    Posted 07-06-2022 05:33
    Hi spuluka, sorry for the late response, it's been a hectic start to my week. 

    I do have the correct device-count set, I currently use 3 (this may change in the future, we are simply testing the links now and getting our heads around setting this up as a BRAS)

    The physical interface is showing up, it's the protocol that is down, however, I have not set a unit on this yet, so once I revisit I will correct this, thank you for your advice.

    ------------------------------
    KEVIN RIDING
    ------------------------------



  • 6.  RE: Trouble enabling 100g port

    Posted 07-05-2022 09:56

    set chassis fpc 0 pic 0 port 0 speed 100g

    also, strangely, sometimes ether-options works when gigether-options doesn't

    try...

    set interfaces et-0/0/0 ether-options 802.3ad ae2



    ------------------------------
    Aaron Gould
    Senior Network Engineer
    aaron@gvtc.com
    https://www.linkedin.com/in/agould123/
    ------------------------------



  • 7.  RE: Trouble enabling 100g port

    Posted 07-05-2022 12:05
    maybe your problem isn't related to that ether-options thing... i see my MX204 config'd like this....

    set chassis aggregated-devices ethernet device-count 25
    set chassis fpc 0 pic 0 port 1 speed 100g
    set interfaces et-0/0/1 gigether-options 802.3ad ae0
    set interfaces ae0 mtu 9216
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 unit 0 family inet address 10.10.10.10/30



    ------------------------------
    Aaron Gould
    Senior Network Engineer
    aaron@gvtc.com
    https://www.linkedin.com/in/agould123/
    ------------------------------



  • 8.  RE: Trouble enabling 100g port

    Posted 07-06-2022 05:33
    Hi aaron, thank you for the advice, my config also matches yours, it is the unit I am missing. I will be applying that later today when I get logged back onto the device :)

    ------------------------------
    KEVIN RIDING
    ------------------------------