View Only


This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.

  • 1.  Switches managed by Mist

    Posted 05-24-2022 18:59
      |   view attached

    I am running a POC to decide if moving from Cisco to Juniper is right for the business.  

    As of right now I am seeing a difference in the configuration on the switches from what is set up in Mist.  
    "Configuration is Managed by Mist" is enabled
    I was unable to setup the VC and so Support assisted with pre-provisioned VC.

    I see "error commit-confirm: [edit virtual-chassis] member 0: Can't have mastership priority configuration with preprovisioned set" under Switch Insights, but I am told by Support this is normal due to pre-provisioned VC config

    I removed the virtual chassis configuration and then one config change push worked, but the same error above has re-appeared

    Local config is attached, minus hidden details for security.

    Any advice is appreciated.



    config.txt   4 KB 1 version

  • 2.  RE: Switches managed by Mist

    Posted 05-25-2022 09:52
    Hi Graham,
    In the virtual chassis config commands is a priority specified? for example:
    [edit virtual-chassis]
    user@switch# set member 0 mastership-priority 255

    the configs don't show the virtual chassis config being used (I just noticed my Mist VC is doing this too) so can you also provide the output of "show virtual-chassis"?

    My VC in Mist doesn't give the error you're seeing so trying to see if it's a hidden config issue or not :)

    Allyn Crowe

  • 3.  RE: Switches managed by Mist

    Posted 05-25-2022 17:18

    I *think* it is hidden config since I don't see anything on the switch:

    root@Sw-trial-1> show virtual-chassis

    Virtual Chassis ID: 0378.8760.af14
    Virtual Chassis Mode: Enabled
    Mstr Mixed Route Neighbor List
    Member ID Status Serial No Model prio Role Mode Mode ID Interface
    0 (FPC 0) Prsnt JY*********** ex2300-24p 128 Master* N VC 1 vcp-255/1/0
    1 (FPC 1) Prsnt JY*********** ex2300-24p 128 Backup N VC 0 vcp-255/1/0

    Member ID for next new member: 2 (FPC 2)

    {master:0}[edit virtual-chassis]
    root@Sw-trial-1# show

    {master:0}[edit virtual-chassis]

    This also leads me to believe that their is no mastership nor priority that could be conflicting in the local config.

    I was told that if I plan to take advantage of the Mist AI management, I should avoid managing the switches locally.


  • 4.  RE: Switches managed by Mist

    Posted 06-01-2022 17:46

    For those that may be interested, since I am testing these devices to make a refresh decision, I ended up doing a reset to factory.

    I worked with support to remove the VC config files because they remained after the reset and was still causing issues.

    Remove VC config:
    delete virtual-chassis
    commit and-quit

    Delete VC files
    start shell user root
    cd /config/vchassis
    rm vc*
    ps -auwx | grep vccp
    Kill "vccp process id"

    credit: Convert Virtual Chassis to Stand Alone - Network Direction