SRX

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  VLAN and non-VLAN traffic on same interface?

    Posted 08-15-2022 20:01
    I want to have a single interface pass both inet 100.64.10.1/24 traffic on unit 0 and also tag a management vlan-id 99 traffic on unit 1 of 10.10.20.122/24, Is this possible single interface? I tried something like:
    ge-0/0/11 {
        unit 0 {
        description segment1;
            family inet {
                address 100.64.10.1/24;
            }
        }
        unit 1 {
        description segment1mgmt;
        vlan-id 99;
            family inet {
                address 10.10.20.122/24;
        }
    }​

    but I get an error:

      'unit 1'
        Only unit 0 is valid for this encapsulation
    


  • 2.  RE: VLAN and non-VLAN traffic on same interface?

    Posted 08-16-2022 06:43
    Hello,

    Yes it's technically possible.
    You should enable Vlan Tagging on ge-0/0/11 before.

    ge-0/0/11 {
           vlan-tagging
    }

    ------------------------------
    WYA ABU
    ------------------------------



  • 3.  RE: VLAN and non-VLAN traffic on same interface?

    Posted 08-16-2022 13:15
    I tried that, now I get the error:
      'unit 1'
         VLAN-ID must be specified on tagged ethernet interfaces
    ​



  • 4.  RE: VLAN and non-VLAN traffic on same interface?

    Posted 08-16-2022 20:23
    Give this one a try.
    ge-0/0/11 {
        description test;
        vlan-tagging;
        unit 0 {
            vlan-id 0;
            family inet {
                address 100.64.10.1/24;
            }
        }
        unit 2 {
            vlan-id 99;
            family inet {
                address 10.10.20.122/24;
            }
        }
    }
    ​


    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------



  • 5.  RE: VLAN and non-VLAN traffic on same interface?

    Posted 08-17-2022 20:00
    So does vlan-id 0 mean not a VLAN at all? Sort of like 0.0.0.0/0 means any?

    For the moment, I placed an unmanaged switch downstream from two ports and then connected my single connection with both VLAN and non-VLAN to that and it worked, but I'd like a more permanent solution.


  • 6.  RE: VLAN and non-VLAN traffic on same interface?

    Posted 08-20-2022 14:46
    vlan-id 0 means not tag at all on that vlan.  So untagged traffic is here while the tagged traffic is handled by their respective unit configurations.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP - Retired)
    http://puluka.com/home
    ------------------------------