Automation

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



dev.facts long delay about 10 minutes

This thread has been viewed 2 times
  • 1.  dev.facts long delay about 10 minutes

    Posted 06-27-2022 12:42
    Hi community,

    I have a strange behaviour in some our devices. Netconf basic queries take long time to get answered for some devices, no other issues with ssh connections or rest of performance for same devices.

    Example the hello-world script in GitHub:

    with Device(host='100.64.1.130', user='App_Dev', password='xxxx',port=22 ) as dev:
        time.time()
        pprint( dev.facts )
        time.time()
    ​

    This basic script takes 619.06 second, in some devices.

    I tested other commands, I found the delay is relate to the answer format (again, only some devices) for xml no delay for json long delay, example:

    version = device.rpc.get_software_information() # No delay, all ok
    
    version = device.rpc.get_software_information({'format':'json'}) # Long delay, or timeout
    


    When I tested "show version | display json" from cli there is no issues. 
    The issue looks not related to specific version or device type, I've seen that in a MX480  - 16.1R5.7 or and  NFX250 20.4R3

    Appreciated any help

    Regards,
    JI






    ------------------------------
    JOSE IBANEZ VELA
    ------------------------------