Junos OS

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

Cannot get PXE boot working with SRX 300

This thread has been viewed 7 times
  • 1.  Cannot get PXE boot working with SRX 300

    Posted 07-06-2022 05:34
      |   view attached
    Hi Folks,

    I have the following issue on a Juniper SRX 300 we setup dhcp to  point to the PXE server  see below

    set routing-instances FLVPN000536 access address-assignment pool Junos-DHCPPool-Corp family inet dhcp-attributes boot-file "smsboot\x86\wdsmgfw.efi"

    However it adds an extra y character to the filename (see attachment).

    Any ideas how to resolve this would be appreciated.


    Regards



    ------------------------------
    Ryan Neil
    ------------------------------


  • 2.  RE: Cannot get PXE boot working with SRX 300

     
    Posted 07-06-2022 06:07
    ÿ = 0xFF (or 0x00FF UTF-16), so either the PXE client is misinterpreting an EOL character of some sort, either as part of the dhcp filename option, or maybe just when printing the output. 

    You could try setting the PXE client to boot as  Legacy/BIOS instead of UEFI, or try padding the file name with an extra space?