View Only

If you have a question or a use case, likely there are others who are experiencing or worked through the same thing. Don't hesitate to jump in and ask or share your knowledge!

Need additional guidance?  Check out these Juniper Resources.

Knowledge Base Security Advisories Technical Bulletins

Latest Discussion Posts

  • Hi dear community, While attempting to connect to SRX devices using Pyez with Ansible i get the following error : 'Connection' object has no attribute 'nonetype' Here is my playbook : --- - name: Get Device Information hosts: router_juniper ...

  • Hi Mark, I encountered issues when executing your script. System complained about line 14... Then, I changed script a little bit, based on some other public documentation, and it worked well. Here is my script, if anyone find issues with your: version ...

  • version 1.1; ns junos = "*/junos"; ns xnm = ""; ns jcs = ""; import "../import/junos.xsl"; /* Junos Space annotations */ /* @CONTEXT = "/device" ...

  • Hi Mark, would you be so kind to share your solution. Thanks, Milan ------------------------------ MILAN MARKOVIC ------------------------------

  • I tried and got the same issue with below message. " error: unknown command: xml-mode error: permission denied: netconf" Regards, Tayzar Lwin

Latest Shared Files



  • Elevate Community Updates

    We are making improvements to the Community based on your feedback. Keep an eye out for updates as they are implemented.

    Please give us feedback any time by posting in Community Talk.

  • How can we improve the Juniper Elevate Community?

    Please take moment to give us insights on the Juniper Elevate Community. We’re planning to update it, and the feedback you share will help guide our improvements.

    Complete the Community Experience Survey

     The survey should take you about 5 minutes to complete, and your responses will be anonymous unless you want to discuss the community experience further.

Current Members