View Only


This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.

  • 1.  vSRX

    Posted 09-12-2021 22:51
    Does vSRX support grpc telemetry?
    whith show version, i see there is openconfig!
    "user@vsrx> show version | match "Openconfig|na\ telemetry"
    JUNOS na telemetry [21.2R1.10]
    JUNOS Openconfig [21.2R1.10]"

    someone who tried?
    I tried but it does not work.


  • 2.  RE: vSRX

    Posted 09-13-2021 09:20
    It should be supported as per the feature navigator,


  • 3.  RE: vSRX

    Posted 09-14-2021 14:54
    But, it does not work!

    Sep 14 17:47:26 17:47:25.983271:CID-0:THREAD_ID-01:LSYS_ID-00:RT:check self-traffic on ge-0/0/0.0, in_tunnel 0x0 dp 32767
    Sep 14 17:47:26 17:47:25.983273:CID-0:THREAD_ID-01:LSYS_ID-00:RT:pak_for_self: No handler function found for proto:6, dst-port:32767, drop pkt
    Sep 14 17:47:26 17:47:25.983284:CID-0:THREAD_ID-01:LSYS_ID-00:RT: flow_first_in_dst_nat: in <ge-0/0/0.0>, out <N/A> dst_adr, sp 33814, dp 32767
    Sep 14 17:47:42 17:47:42.110852:CID-0:THREAD_ID-01:LSYS_ID-00:RT:~~~FLOW <>;6,0x0> of root-logical-system for iif ge-0/0/0.0:
    Sep 14 17:47:42 17:47:42.110869:CID-0:THREAD_ID-01:LSYS_ID-00:RT: ge-0/0/0.0:>, tcp, flag 2 syn
    Sep 14 17:47:42 17:47:42.110871:CID-0:THREAD_ID-01:LSYS_ID-00:RT: find flow: table 0x2aa75480, hash 50070(0xffff), sa, da, sp 33814, dp 32767, proto 6, tok 24, conn-tag 0x00000000, vrf-grp-id 0
    traffic is coming in on vsxr but it drops, i don´t understand why.
    security zone trust which ge-0/0/0 belongs i configured:
    security-zone trust {
    host-inbound-traffic {
    system-services {
    protocols {
    interfaces {

    This is only a lab environment!