Junos OS

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  EX2300 high fxpc and no ping/ssh on vlan interface

    Posted 12-24-2021 09:24
    Hello all,

    The CPU usage on EX2300 goes high after even a small multicast traffic is incoming on one of the ports.  As a result I cannot ping the VLAN interface and SSH into EX2300. 

    root@kgm_core_sw> show system processes extensive | except 0.00
    last pid: 39902; load averages: 1.27, 1.00, 0.94 up 0+01:01:18 13:30:10
    209 processes: 4 running, 187 sleeping, 18 waiting
    
    Mem: 738M Active, 557M Inact, 279M Wired, 36M Buf, 332M Free
    Swap:
    
    
    PID USERNAME PRI NICE SIZE RES STATE TIME WCPU COMMAND
    11 root 155 ki31 0K 16K RUN 29:55 50.98% idle
    14382 root 44 0 720M 266M RUN 14:10 28.96% fxpc{fxpc}
    14382 root -52 r0 720M 266M select 4:33 7.96% fxpc{fxpc}
    39888 root 44 0 335M 66080K RUN 0:01 5.96% cli
    0 root 20 - 0K 144K - 0:17 1.95% kernel{bcm560xgmac0 que}​


    root@kgm_core_sw> show version
    fpc0:
    --------------------------------------------------------------------------
    Hostname: kgm_core_sw
    Model: ex2300-48t
    Junos: 18.1R3.3​

    Upgraded to versions 21.4R1, 21.3R1 but behavior is the same.  As soon as the incoming multicast is enabled, ping and SSH to the switch is lost.  Switch is as below:

    Is there anything wrong in the config to cause this issue?

    {master:0}
    root@kgm_core_sw> show configuration 
    ## Last commit: 2021-12-24 13:04:54 UTC by root
    version 18.1R3.3;
    system {
        host-name kgm_core_sw;
        auto-snapshot;
        root-authentication {
            encrypted-password "#####"; ## SECRET-DATA
        }
        name-server {
            8.8.8.8;
        }
        services {
            ssh {
                root-login allow;
                protocol-version v2;
            }
            netconf {
                ssh;
            }
            web-management {
                http;
            }
        }
        syslog {
            user * {
                any emergency;
            }
            file interactive-commands {
                interactive-commands any;
            }
            file messages {
                any notice;
                authorization info;
            }
        }
        processes {
            dhcp-service {
                traceoptions {
                    file dhcp_logfile size 10m;
                    level all;
                    flag all;
                }
            }
        }
        ntp {                               
            server 172.16.2.10;
        }
    }
    chassis {
        redundancy {
            graceful-switchover;
        }
    }
    interfaces {
        interface-range iptv {
            member ge-0/0/47;
            member "ge-0/0/[0-45]";
            unit 0 {
                family ethernet-switching {
                    interface-mode access;
                    vlan {
                        members iptv;
                    }
                }
            }
        }
        ge-0/0/0 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        ge-0/0/1 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        ge-0/0/45 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        ge-0/0/46 {
            unit 0 {
                family ethernet-switching {
                    interface-mode trunk;
                    vlan {
                        members all;
                    }
                    storm-control default;
                }
            }
        }
        ge-0/0/47 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }                               
        }
        ge-0/1/0 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        xe-0/1/0 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        ge-0/1/1 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        xe-0/1/1 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        ge-0/1/2 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        xe-0/1/2 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        ge-0/1/3 {
            unit 0 {                        
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        xe-0/1/3 {
            unit 0 {
                family ethernet-switching {
                    storm-control default;
                }
            }
        }
        irb {
            unit 0 {
                family inet {
                    address 172.16.2.1/24;
                }
            }
            unit 60 {
                family inet {
                    address 172.16.1.1/24;
                }
            }
        }
        vme {
            unit 0 {
                family inet {
                    address 172.16.2.3/24;
                }
            }
        }
    }
    forwarding-options {
        storm-control-profiles default {
            all;
        }
    }
    routing-options {
        static {
            route 0.0.0.0/0 next-hop 172.16.2.10;
        }
    }
    protocols {
        ##
        ## Warning: requires 'igmp' license 
        ##
        igmp {
            interface irb.60;
        }
        lldp {
            interface all;
        }
        lldp-med {
            interface all;
        }
        igmp-snooping {
            vlan iptv {
                immediate-leave;
                interface ge-0/0/47.0 {
                    multicast-router-interface;
                }
            }
        }
        rstp {
            interface ge-0/0/0;
            interface ge-0/0/1;
            interface ge-0/0/2;
            interface ge-0/0/3;
            interface ge-0/0/4;
            interface ge-0/0/5;
            interface ge-0/0/6;
            interface ge-0/0/7;
            interface ge-0/0/8;
            interface ge-0/0/9;
            interface ge-0/0/10;
            interface ge-0/0/11;
            interface ge-0/0/12;
            interface ge-0/0/13;
            interface ge-0/0/14;
            interface ge-0/0/15;
            interface ge-0/0/16;
            interface ge-0/0/17;
            interface ge-0/0/18;
            interface ge-0/0/19;
            interface ge-0/0/20;
            interface ge-0/0/21;
            interface ge-0/0/22;
            interface ge-0/0/23;
            interface ge-0/0/24;
            interface ge-0/0/25;            
            interface ge-0/0/26;
            interface ge-0/0/27;
            interface ge-0/0/28;
            interface ge-0/0/29;
            interface ge-0/0/30;
            interface ge-0/0/31;
            interface ge-0/0/32;
            interface ge-0/0/33;
            interface ge-0/0/34;
            interface ge-0/0/35;
            interface ge-0/0/36;
            interface ge-0/0/37;
            interface ge-0/0/38;
            interface ge-0/0/39;
            interface ge-0/0/40;
            interface ge-0/0/41;
            interface ge-0/0/42;
            interface ge-0/0/43;
            interface ge-0/0/44;
            interface ge-0/0/45;
            interface ge-0/0/46;
            interface ge-0/0/47;
            interface ge-0/1/0;
            interface xe-0/1/0;
            interface ge-0/1/1;
            interface xe-0/1/1;
            interface ge-0/1/2;
            interface xe-0/1/2;
            interface ge-0/1/3;
            interface xe-0/1/3;
        }
    }
    vlans {
        default {
            vlan-id 1;
            l3-interface irb.0;
        }
        iptv {
            vlan-id 60;
            l3-interface irb.60;
        }
    }
    
    {master:0}
    ​


    ------------------------------
    Tuncay Gunes
    ------------------------------


  • 2.  RE: EX2300 high fxpc and no ping/ssh on vlan interface

    Posted 01-26-2022 17:45
    Was this ever resolved?  I am having the exact same issue.

    ------------------------------
    PAUL PETERSON
    ------------------------------



  • 3.  RE: EX2300 high fxpc and no ping/ssh on vlan interface

    Posted 01-28-2022 09:30
    Unfortunately it wasn't resolved. I also followed the instructions in the KB below, but the issue still remains. 

    https://kb.juniper.net/InfoCenter/index?page=content&id=JSA11065&actp=METADATA

    ------------------------------
    Tuncay Gunes
    ------------------------------



  • 4.  RE: EX2300 high fxpc and no ping/ssh on vlan interface

    Posted 01-28-2022 09:30
    Long shot .
    Can you jump to the re shell and just watch the fpc0 .
    2300-switch> start shell
    % vty fpc0
    show threads