Junos OS

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  shmlog eats all space on RE

    Posted 04-10-2020 12:24

    Hello,
    I've found that some files with *.arg extensions located in /.mount/var/log/shmlog/arg concumes alot of space on RE and not rotated (cleared) automatically.
    To fix this I switch to backup RE and delete biggest *.arg file by hand.
    Last time it was 13GB

    root@:/.mount/var/log/shmlog/arg # rm jdhcpd-event.95.jdhcpd.0.arg

    I'm not using telemetry and:

    subscriber-management {
        overrides {
            shmlog {
                disable;
            }
        }
        enable;
    }
    

    Is it save to clear all files in directory /.mount/var/log/shmlog/arg?



  • 2.  RE: shmlog eats all space on RE
    Best Answer

     
    Posted 04-10-2020 15:35

    Hey schadel,

     

    Greetings,  these are shared memory logs and they will not cause any harm, nothing to worry about please check below:

     

    https://www.juniper.net/documentation/en_US/junos/topics/reference/configuration-statement/shmlog-config-edit-system-services-subscriber-management-overrides.html

     

    Now if they are cluttering and not rotating as they should you might want to check this PR:

     

    https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1364775

     

    The correct way to clear them is ">clear shmlog all-info logname all" or disable them as you did also will do the job!

     

    Good luck and happy Friday.

     

    If this solves your problem, please mark this post as "Accepted Solution" so we can help others too \:)/

    Regards,

     

    Lil Dexx
    JNCIE-ENT#863, 3X JNCIP-[SP-ENT-DC], 4X JNCIA [cloud-DevOps-Junos-Design], Champions Ingenius, SSYB

     

     



  • 3.  RE: shmlog eats all space on RE

    Posted 04-11-2020 02:40

    Thank you very much.Smiley Happy



  • 4.  RE: shmlog eats all space on RE

    Posted 07-10-2022 09:20
    On EX 23/34/43/43MP Running 20.4RX-SY versions of  code and the the subscriber-managment does not work still.
    Thankfully the clear shmlog all-info logname all   does !

    kernel: %KERN-3: pid 67056 (jdhcpd), uid 0 inumber 31831 on /.mount/var/log: filesystem full
    kernel: %KERN-3: pid 8044 (eventd), uid 0 inumber 59 on /.mount/var/log: filesystem full
     
    good opportunity to run a schedule event

    set event-options generate-event ClearSMLOG-ARG time-of-day "23:10:22 -0400"
    set event-options policy ClearSMLOG-ARG-policy events ClearSMLOG-ARG
    set event-options policy ClearSMLOG-ARG-policy then execute-commands commands "clear shmlog all-info logname all"
    set event-options policy ClearSMLOG-ARG-policy then execute-commands output-filename ClearSMLOG-ARG-policy.text
    set event-options policy ClearSMLOG-ARG-policy then execute-commands destination local-directory
    set event-options policy ClearSMLOG-ARG-policy then execute-commands output-format text
    set event-options destinations local-directory archive-sites /var/tmp/

    **If your running dhcp snooping,  i've needed to run restart dhcp-service to release inodes. **